Allow Write Permissions to a C: drive folder in Group Policy on win2k

Is there a way to set up in group policy for users to be able to write to a folder on their C: drive?  I don't have users set up as local admins and would like to keep it that way and I didn't want to have to go into every machine and change the permissions on each folder.
cbish21577Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

oBdACommented:
Yes, that's possible. Just apply a GPO to the machines in question, and add the folder in Computer Configuration\Windows Settings\Security Settings\File System. Note that you don't need to be able to browse to the folder, you can just enter the full local path (in case the folder doesn't exist on the machine you're running the GPMC on).
Apply or modify permission entries for objects using Group Policy
http://technet.microsoft.com/en-us/library/cc756952(WS.10).aspx
0
cbish21577Author Commented:
So I would just add C:\program files\blah in Computer Configuration\Windows Settings\Security Settings\File System?
0
oBdACommented:
And add the necessary permissions in the dialog afterwards, yes. I'd create a domain local group "NTFS_Blah_C" or whatever and assign this group Change permissions, then add the required users or groups to this group.
You might want to try it with a test folder on a test client first before you go into production.
0
cbish21577Author Commented:
I'm confused as to adding C:\program files\blah in Computer Configuration\Windows Settings\Security Settings\File System.  I'm on my win2k server and in Group Policy and I'm under  Computer Configuration\Windows Settings\Security Settings\File System but I'm adding C: drive.  Isn't that referring to the servers c: drive and not the local machines I want to grant some access too?  I've added this all and selected everything I can imagine that is associated with the test computer and test user to give permission and nothing is working.
0
oBdACommented:
No; the client side extensions of the group policy will see the C: reference and set the permissions on this local path.
The test user is of no importance; the GPO has to be applied to a *computer* object.
Assuming you have XP clients: apply the GPO, logon with an admin account to the XP machine, open a command prompt, enter
gpupdate /target:computer /force
The permissions on the folder should change to the ones defined in the GPO.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.