how to update the tivoli library with current volumes

Posted on 2009-06-30
Last Modified: 2013-11-15
What is the command to have the library rescan it's contents? I add tapes, run q libv and it displays outdated information.
Question by:every1isevil2
  • 3
  • 2
LVL 68

Expert Comment

ID: 24749040
Hi again,

what do you mean with 'add tapes?

Inserting them into the library is not enough, you need to run 'checkin libvolume ...' or 'label libvolume ...' to make them known to TSM.

Btw. the command you requested is 'AUDIT LIBRARY libraryname' - doesn't work on all library types, however.
And it doesn't replace the checkin... or label... comands. You need to run them anyway.



Author Comment

ID: 24749251
Well the problem is that we run the "checkin libv" command with the waittime=0 so it does it now... it says that it is processing... a min later, it goes away. When I run q act search=checkin, I see that it processed, but it doesn't find any tapes. Any ideas?

tsm: WYOMING>checkin libv lib01 search=yes vollist=b00007l2 status=scratch checkl=barcode waittime=0

ANS8003I Process number 328 started.

tsm: WYOMING>q pro

 Process     Process Description      Status


--------     --------------------     -------------------------------------------------

     328     CHECKIN LIBVOLUME        ANR8425I Checking in volumes in search mode in

                                       library LIB01.

when I run the q act search=checkin command... this is what i see

06/30/2009 15:27:14      ANR2017I Administrator ADMIN issued command: CHECKIN

                          LIBVOLUME lib01 search=yes vollist=b00007l2

                          status=scratch checkl=barcode waittime=0  (SESSION:


06/30/2009 15:27:14      ANR0984I Process 328 for CHECKIN LIBVOLUME started in the

                          BACKGROUND at 15:27:14. (SESSION: 13710, PROCESS: 328)

06/30/2009 15:27:14      ANR8422I CHECKIN LIBVOLUME: Operation for library LIB01

                          started as process 328. (SESSION: 13710, PROCESS: 328)

06/30/2009 15:27:20      ANR8431I CHECKIN LIBVOLUME process completed for library

                          LIB01; 0 volume(s) found. (SESSION: 13710, PROCESS: 328)

06/30/2009 15:27:20      ANR0985I Process 328 for CHECKIN LIBVOLUME running in the

                          BACKGROUND completed with completion state SUCCESS at

                          15:27:20. (SESSION: 13710, PROCESS: 328)

06/30/2009 15:27:52      ANR2017I Administrator ADMIN issued command: QUERY ACTLOG

                          search=checkin  (SESSION: 13710)

Open in new window

LVL 68

Expert Comment

ID: 24749460
So the tapes are not yet known to your library hardware!

Try AUDIT LIBRARY libraryname as said above.

What kind of library is it? Do you have to run special procedures to insert tapes?

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.


Author Comment

ID: 24749509
well when I try to run the audit library command... it doesn't do anything.

it's an IBM ULT3583-TL library

from what i understand, we just have to run the checkin command to checkin the tapes.

Here is a snippet from the q libv

I just ran the checkin command for the b00007l2 tape.
tsm: WYOMING>q libv

Library Name     Volume Name     Status               Owner          Last Use      Home        Device

                                                                                   Element     Type

------------     -----------     ----------------     ----------     ---------     -------     ------

LIB01            05JL02L2        Private                             Data          4,132       LTO

LIB01            05JN04L2        Private                                           4,106       LTO

LIB01            05MR02L2        Scratch                                           4,097       LTO

LIB01            05OC01L2        Private                             Data          4,126       LTO

LIB01            05SE05L2        Private                                           4,113       LTO

LIB01            06AP11L2        Private                             Data          4,119       LTO

LIB01            06AP12L2        Private                                           4,103       LTO

LIB01            06AP20L2        Private                             Data          4,116       LTO

LIB01            06FE002L        Private                             Data          4,121       LTO

LIB01            06FE003L        Private                             Data          4,108       LTO

LIB01            06FE005L        Private                             DbBackup      4,127       LTO

LIB01            06JA05L2        Private                                           4,118       LTO

LIB01            06JN01L2        Private                             Data          4,102       LTO

LIB01            06JN02L2        Private                                           4,115       LTO

LIB01            08FE01L2        Private                             Data          4,120       LTO

LIB01            08FE03L2        Private                                           4,109       LTO

LIB01            08FE04L2        Private                                           4,104       LTO

LIB01            08SE01L2        Private                             Data          4,124       LTO

LIB01            08SE07L2        Private                                           4,130       LTO

LIB01            A00006L2        Private                                           4,131       LTO

LIB01            A00007L2        Private                             Data          4,117       LTO

LIB01            A00008L2        Private                                           4,128       LTO

LIB01            A00013L2        Private                                           4,123       LTO

LIB01            A00014L2        Private                                           4,114       LTO

LIB01            A00017L2        Private                                           4,122       LTO

LIB01            A00018L2        Private                             Data          4,111       LTO

LIB01            A00023L2        Private                             Data          4,133       LTO

LIB01            A00029L2        Private                             Data          4,134       LTO

LIB01            A00030L2        Private                             Data          4,096       LTO

LIB01            A00031L2        Private                             Data          4,125       LTO

LIB01            B00005L2        Private                             Data          4,107       LTO

LIB01            B00006L2        Private                             Data          4,112       LTO

Open in new window

LVL 68

Accepted Solution

woolmilkporc earned 500 total points
ID: 24749662
CHECKIN uses the information it gets from the library (search=yes). If the library doesn't know about the tapes, CHECKIN will not find anything.
For many libraries it is normal for the AUDIT to run quite a short time.
Did you repeat the CHECKIN after the AUDIT?
If still no success, I fear you will have to re-inventory your library by means of library functions, not TSM commands!


Expert Comment

by:Maurizio TERUZZI
ID: 24853516
Hello, also verify if you TAPES are present in the HW library inventory, if there are missing you dont' have a chance to get it in TSM.


Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Suggested Solutions

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now