Caught exception: No such file or directory when running cvs ant task

I am trying to write a script that can download a project from cvs.  It works on windows but if I put it on a fedora 10 machine. I receive this error and I can't seem to figure out what's causing it.
 [cvs] Caught exception: No such file or directory

I took a guess that maybe it was the .cvspass file since it comes right after that line and I tried just setting the rights on that file to 777 to make sure it had full access.  It had no effect and I still receive the error.

Below is the verbose log from the ant script

     [echo] Checking out the required sources from CVS
    [input] Please enter the tag name(default is head): [HEAD]
      [cvs] Using cvs passfile: /home/user/.cvspass
      [cvs] Executing 'cvs' with arguments:
      [cvs] '-d:pserver:ptg\username:******@'
      [cvs] '-q'
      [cvs] '-z3'
      [cvs] 'checkout'
      [cvs] '-rHEAD'
      [cvs] 'project_trak/trak'
      [cvs] The ' characters around the executable and arguments are
      [cvs] not part of the command.
      [cvs] environment:
      [cvs] 	ORBIT_SOCKETDIR=/tmp/orbit-alandauser
      [cvs] 	HOSTNAME=localhost.localdomain
      [cvs] 	SHELL=/bin/bash
      [cvs] 	TERM=xterm
      [cvs] 	HISTSIZE=1000
      [cvs] 	XDG_SESSION_COOKIE=0a5e7f3f32307f40b33b325f4a4507fe-1246368860.903027-2138618770
      [cvs] 	GTK_RC_FILES=/etc/gtk/gtkrc:/home/user/.gtkrc-1.2-gnome2
      [cvs] 	WINDOWID=69206079
      [cvs] 	USER=user
      [cvs] 	LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:do=00;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=00;32:*.tar=00;31:*.tgz=00;31:*.svgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.lzma=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.dz=00;31:*.gz=00;31:*.bz2=00;31:*.tbz2=00;31:*.bz=00;31:*.tz=00;31:*.deb=00;31:*.rpm=00;31:*.jar=00;31:*.rar=00;31:*.ace=00;31:*.zoo=00;31:*.cpio=00;31:*.7z=00;31:*.rz=00;31:*.jpg=00;35:*.jpeg=00;35:*.gif=00;35:*.bmp=00;35:*.pbm=00;35:*.pgm=00;35:*.ppm=00;35:*.tga=00;35:*.xbm=00;35:*.xpm=00;35:*.tif=00;35:*.tiff=00;35:*.png=00;35:*.mng=00;35:*.pcx=00;35:*.mov=00;35:*.mpg=00;35:*.mpeg=00;35:*.m2v=00;35:*.mkv=00;35:*.ogm=00;35:*.mp4=00;35:*.m4v=00;35:*.mp4v=00;35:*.vob=00;35:*.qt=00;35:*.nuv=00;35:*.wmv=00;35:*.asf=00;35:*.rm=00;35:*.rmvb=00;35:*.flc=00;35:*.avi=00;35:*.fli=00;35:*.gl=00;35:*.dl=00;35:*.xcf=00;35:*.xwd=00;35:*.yuv=00;35:*.svg=00;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:
      [cvs] 	GNOME_KEYRING_SOCKET=/tmp/keyring-XtaGY3/socket
      [cvs] 	SSH_AUTH_SOCK=/tmp/keyring-XtaGY3/ssh
      [cvs] 	SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2161,unix/unix:/tmp/.ICE-unix/2161
      [cvs] 	USERNAME=user
      [cvs] 	MAIL=/var/spool/mail/user
      [cvs] 	PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/alandauser/bin
      [cvs] 	DESKTOP_SESSION=gnome
      [cvs] 	PWD=/home/user/Desktop
      [cvs] 	XMODIFIERS=@im=imsettings
      [cvs] 	LANG=en_US.UTF-8
      [cvs] 	GNOME_KEYRING_PID=2154
      [cvs] 	GDM_LANG=en_US.UTF-8
      [cvs] 	GDMSESSION=gnome
      [cvs] 	SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
      [cvs] 	SHLVL=7
      [cvs] 	HOME=/home/user
      [cvs] 	GNOME_DESKTOP_SESSION_ID=this-is-deprecated
      [cvs] 	LOGNAME=alandauser
      [cvs] 	DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-23vgO14Fua,guid=84f46e3f9c5c47660458f6484a4a145d
      [cvs] 	LESSOPEN=|/usr/bin/ %s
      [cvs] 	DISPLAY=:0.0
      [cvs] 	G_BROKEN_FILENAMES=1
      [cvs] 	COLORTERM=gnome-terminal
      [cvs] 	CVS_PASSFILE=/home/user/.cvspass
      [cvs] Caught exception: No such file or directory

Open in new window

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Your username is presumably something other than 'user' ..? 'user' looks like a placeholder to me
If in doubt, run

ethnarchAuthor Commented:
I changed some of the values I didn't want to post this online

1. user is a place holder for my real username
2. username is also a place holder for my real username
3. project  is really the name of a project

Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

Please post result of

ls -l ~/.cvspass

Open in new window

ethnarchAuthor Commented:
[user@localhost ~]$ ls -l ~/.cvspass
-rwxrwxrwx 1 user user 57 2009-06-30 14:26 /home/user/.cvspass
[user@localhost ~]$

I had previously ran chmod a+rwx on it (only as a temporary solution) so it has all rights
Well maybe that's not the file it's complaining about. What's the current ant command?
ethnarchAuthor Commented:
I am running the command below

ant -v -f setup.xml project-checkout

I'll post the script
ethnarchAuthor Commented:
below is the target that is being called
  <target name="project-checkout" depends="dir" 
          description="Update or check out required sources
                       from CVS">
    <echo message="Checking out the required sources from CVS"/>
	<cvspass cvsroot="${project.cvsroot}"
		message="Please enter the tag name(default is head):"
    <cvs cvsroot="${project.cvsroot}" quiet="true"
         dest="${src.local}" compression="true" 

Open in new window

You could try using the --debug parameter to Ant. Probably a good idea to echo the properties too to make sure they're set
ethnarchAuthor Commented:
I am only getting the lines below in between CVS_PASSFILE and the ioexception line

This really is one of those times where you just wished they put the file name out to the console/log.  Probably is a ridiculously simple problem, just can't figure out what the problem is!
      [cvs] 	CVS_PASSFILE=/home/alandauser/.cvspass
Execute:Java13CommandLauncher: Executing 'cvs' with arguments:
The ' characters around the executable and arguments are
not part of the command.
      [cvs] Caught exception: No such file or directory

Open in new window

ethnarchAuthor Commented:
I fixed it, ugh I didn't have cvs installed on the linux box.  On fedora i just did

yum install cvs

I got the clue from this site
where it says
     This task needs "cvs" on the path. If it isn't, you will get an error (such as error 2 on windows). If  
     <cvs> doesn't work, try to execute cvs.exe from the command line in the target directory in which
     you are working.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Glad you got it ;-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.