Port 25 problem Trying to enable exchange

I am enabling exchange 2007 tomorrow morning and I have a problem. I am going through my test list to ensure everything is correct and I cannot connect (from the outside) to port 25. I have opened it up on the Router and point it to the server and I have added a firewall rule to allow it.
If I attempt to ping it I get:

C:\Users\Don>telnet 25
Connecting To not open connection to the host, on port 25
: Connect failed

I should be able to connect in on port 25 shouldn't I?
Who is Participating?
candyman2112Connect With a Mentor Commented:
I assume you can telnet to port 25, and that you have tested it, on your internal network?

If so, then the only thing that can prevent you telnetting externally would be an incorrect firewall setting, or IP restrictions set in Exchange System Manager. What firewall are you using?

Do you have a fixed external IP?
just as long as it is not configured for ssl..

Do you need to port-forward the public IP?
LostInWindowsAuthor Commented:
I have not yet changed the MX record. I want to test that everything is going to work easily and quickly as i have other issues that I will need to address.
I did verify from the ISP that there are no port restrictions in or out on the IP address. I am pinging by address, not name just to be sure I reach the correct server.
Where would it configured for SSL?
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

in the certificate, if you have your own CA..

LostInWindowsAuthor Commented:
I did purchase a cert from Go Daddy. How do I check if I added Port 25 for SSL? Is this a default? Will this make it work without any further concerns?

My OS is SBS 2008 if that matters.
There is nothing to do with SSL. Probably you have to configure your connector. Start with http://technet.microsoft.com/en-us/library/bb125128.aspx for overview then follow links at the bottom.
debuggerauConnect With a Mentor Commented:
your cert should have your domain registered, if that is not changing, neither will it..

Have you gone into your Virtual SMTP adaptor and checked if SSL is enabled?
QuoriConnect With a Mentor Commented:
Check the IPv4 ranges the server is set to accept connection from. I can provide more detail tomorrow when I am back in the office.
How did you go?
LostInWindowsAuthor Commented:
I had multiple problems, the largest being bad router firmware. Thank you for all your help
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.