I cant uninstall Trend Micro Internet Security 2009

Hi Guys, im trying to uninstall trend micro however the uninstalling keeps failing saying that the process was inturrupted. ive tried using TISTOOL, PCCTool, and TISSuprt after the standard methods of uninstallation didnt work. has anyone got any ideas? i'd like to keep registry editing as a last resort.

im using a laptop with vista home prem and SP2

cheers :)
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RartemassLife CoachCommented:
Have you tried uninstalling from Safe Mode?
beefstu123Author Commented:
uninstallations dont really work in safe mode as the installer service is disabled.  
RartemassLife CoachCommented:
you should be able to start the service from running services.msc
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!


1) Try to repair it from Add/Remove Programs or run the installation again to override any corrupted files/registry keys, then uninstall it normally.


2) Try to set the startup type of all Trend Micro services to DISABLED, reboot, then try to uninstall it again.

3) Use "Trend Micro Support Diagnostic Toolkit" to automatically collect the different log files then submit them Trendmicro support to troubelshoot the uninstallation failure.  


Go to
C:\Program Files\Trend Micro\Internet Security\TISTOOL.exe
and go to the uninstall tab
This program will remove it for you when the uninstall fails from the control panel.
Try the RevoUninstaller:


Hope it helps.
beefstu123Author Commented:
its all fixed now, i got a removal tool from trend.  the installer service cannot be started in sfae mode....as is it disabled, i cannot be enabled. i had already tried the other methods except the program suggested by warturtle, however i dont download third party uninstallers as i havent had a good run with them in the past.  thanks for all ur comments and help. have a good one :)


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hey beefstu123 how or what did you use to fix your problem im haveing the same problems and am about to go nuts
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.