We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Script using custom DLL not working

templeavenue
templeavenue asked
on
Medium Priority
572 Views
Last Modified: 2013-11-10
I have a custom DLL and imported in the script component to use it. Withing the script designer, I can see the method accessing (from Intellisense). But when I run the package, it says that it does not find the method (if try to access the static method) or not able to load "type" I am instantiating it within the script.  
Comment
Watch Question

You could try late binding
Set oObject = CreateObject("YourDLLProgID")
Call oObject.YourMethod
To enable late binding you need to untick a setting in the editor though

Author

Commented:
Thanks for the reply. But it doesn't work. It will give me exception when I run the package. I need to add more info so that it can be resolved easier.
First, I am modifying existing DLL. In the same DLL, the classes existed before seems to be accessed and accessing the new class is giving me exception. The DLL is being done by different person in the past.
Second, Can you add reference fromt he Script Editor without putting the DLL in the .NET framework folder? I now have to put the DLL in the .NET framework folder as before in order to reference.
Also,  I tested the DLL by testing a small program to the the new class in the DLL.
I hope this would help us.

thanks again!
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.