We help IT Professionals succeed at work.

RemoteApp won't move between two screens/monitors

gorlaz
gorlaz asked
on
Medium Priority
2,590 Views
Last Modified: 2018-05-10
Hi Guys,

If anyone can shed any light on this it would be fantastic as I'm banging my head up against the wall.

Win2k8 TS Std; RemoteApps being used are MS Office XP products and 2 LOB apps. I have the same issue with all of them.

I've set up a win2k8 TS and in prior testing I had (or thought so anyway) no issues with moving a RemoteApp between my two monitors, ie the app isn't maximised, and just drag it to the other screen as you would do with any local app.

I'm now running into the problem where when I try to drag the RemoteApp to the other monitor it hits the edge of the first monitor then jumps to the right hand side of the first monitor whilst the mouse cursor continues to move to the other screen.

From some reading it appears the /span switch may / may not have something to do with this. /span has it's own requirements to work such as identical sized screens and primary monitor being the left monitor. I've tried it in this scenario and it has no effect, the RemoteApp still does the same thing. BUT the span monitor:i:1 switch is enabled by default in the RDP files and hasn't had any effect.

If I connect a full desktop RDP session it will span and move to/from the second screen with no issues.

So questions are;

a) Is this expected behaviour?
b) Is /span doing something it shouldn't
c) Has anyone got the above working and did they have to do something special to get it?

Any help much appreciated.
Comment
Watch Question

Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
doesn't make any diffrence on my set up, moved to the left, the right, middle.. no joy, still does the same thing... oh well.
The fix: Edit the RDP file in notepad, add the line below to the file and save it. If there's already a line for "use multimon", change the value to 1. Note the user's RDP session will have to be logged off form the server for the change to take effect.

use multimon:i:1
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.