Error when proposing new time for meeting request

I have a user that receives a meeting request in Lotus Notes 8.5 & then opens it up, clicks on the respond drop-down & clicks on Propose New Time. He then receives an error "Object variable not set". When he then clicks OK the Propose Options window opens up & he can continue to propose a new time. How do I get rid of this error message? I haven't been able to reproduce the problem on any other notes client & reinstall at this stage is not an option since he's a difficult user that wants the problem solved.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Are all your mailfiles based on the same template? Does this happen to other users if the exact same procedure is followed? Does it happen if you open his mailfile on your computer and try the process (either with your own ID if allowed, or with his ID)?

I haven't tried doing what you are doing without first accepting the meeting. Does the user get the same error if he accepts the meeting, then opens it and proposes a new time?

Lastly, it would be worth, if possible, running the LotusScript Debugger when trying to do this, as when it hits the error the debugger should show you where the problem is, assuming you are comfortable with LotusScript. Note that I think you need deisgner installed to do that.
GijimaAuthor Commented:
Some answers to your questions:
1. All our mailfiles are based on the same template.
2. This hasn't happened to any other user that I'm aware of.
3. I will need to get permission to open his mailfile on my PC since he's a senior IT manager at the company.
4. The user doesn't accept the meeting before proposing a new time, I'll try to have the user accept the meeting 1st & then propose a new time. If this fixes the problem he's going to want to know why he has to do it this way when other users don't. Like I said, he's a difficult user (being an IT manager & all)

I have to admit that I don't know how LotusScript works at all so at this stage that would be a last resort for me, but I'm not unwilling to try it :)
Sjef BosmanGroupware ConsultantCommented:
Problem could be related to:
- database error (database corrupt)
- design error in a form (e.g. a form can get corrupt)
- wrong preferences

If it happens to only that person, try File/Application/Replace Design, and select the server's mail template.
If that doesn't help, try a compact.
If it still happens, do a Fixup, and then the Replace Design again (won't hurt)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Yup, if it's just happening to him, it's most likely specific to his database. Do as sjef says and ensure the database design itself is correct.

I would still be inclined to try the same process on a different PC/Notes install with his ID and mailfile. This would rule out any PC/Client install specific problems, which I have experienced many times in the past.

If the process works using his ID and mail file on a different PC, try deleting the bookmarks.nsf file and the cache.ndk file from his Notes Data directory and then try again (note it's best to simply move the bookmarks.nsf file so you don't loose anything!).
Sjef BosmanGroupware ConsultantCommented:
Could be the cache indeed!  

PS isn't it "lose" ??
Yes sjef, it is, although I wasn't aware spelling was under scrutiny on this board :)
Sjef BosmanGroupware ConsultantCommented:
LOL Yes sorry, it's (and not "its") a nasty habit of mine. I also think that we'd better stick to standard English here instead of business English and als its (and not it's) dialects. The number of times I see the "its" mistake, mostly from native English speakers... Oh, and one of my favourite examples of business "English" is this: a Frenchman and an Italian guy were having a lively discussion in English, and the Englishman who stood next to them couldn't understand a single word!

Anyway, I'd really appreciate it if you correct me when I make a mistake!! Not the obvious typo, but the more serious ones.

PS You could add some info to your EE-profile, so we know whom we're dealing with...
PS2 Sorry Gijima for the off-topic discussion here :-))
GijimaAuthor Commented:
Not a problem sjef. Thanks everyone for all the suggestions. I'll try them out once the user is available & update if any of them solved the problem.
GijimaAuthor Commented:
I apologize for the long delay, the user has now retired & no one else experiences this problem. But I'm pretty sure your solutions would have worked. Thanks guys.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.