Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 579
  • Last Modified:

Redhat 5 Realtek R8168 suddenly stopped working

Hello Experts,

one of our machines, running Redhat Linux 5 suddenly lost its network connection.
we are using the driver from Realtek website for several months without any problem.

tried two times ethtool command and received different results:
[root@ ~]# ethtool eth3
Settings for eth3:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
        Link detected: yes

[root@ ~]# ethtool eth3
Settings for eth3:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: Unknown! (0)
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
        Link detected: no

The switchport is always down, its not coming up (set to auto/auto).

Any help will be appreciated
[root@ ~]# lsmod | grep r81
r8169                  37573  0
mii                     9409  1 r8169
r8168                  43796  0

Open in new window

0
alonfo
Asked:
alonfo
1 Solution
 
remeshkCommented:
Did you tried after restarting the machine the network is start working ?

Please try to unload the module and re-add.
0
 
rindiCommented:
Try another cable, port on the switch. If still the same use another NIC.
0
 
alonfoAuthor Commented:
Thank you, eventually we sent technician last night to the datacenter and he replaced the cable and connected the second card (there are two on-board 8168 cards). Now we don't know if it was faulty cable or NIC.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now