change drive letter greyed out

Hi, I have a problem with disk management on an XP Pro machine

Under Disk Management console, it shows the volume names but no letters, if I click change drive letters and paths, only add is available. Drive letters already taken.

All drives are available in file explorer.

diskpart.exe allows me to assign a drive letter to the drive (USB external western digital, or memory stick). If I change the USB drive to another letter, it changes in file explorer, but still the same in disk management console, change not available.

mountvol.exe shows correct key and drive letter assigned, but diskpart select volume does not show a drive letter attached.

The problem surfaced when norton 360 was installed and tried to do a backup. only available items were the CD burner and external web based backup. No usb devices, or local storage available.

I feel there might have been some corruption in the registry, so examined /hkey_local_machine/system/mountedDevices and removed volume ID for usb and dosdevices\E: from there. rebooted and still the same?

Any thoughts as to where else I might look in either registry or services section. I couldn't see any services that should be running as disabled, or not running.

Bit stuck on this one!
pc_docAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

noxchoGlobal Support CoordinatorCommented:
In case the system restore points were created, restore the system to the day before Norton 360 installation. This could help but no guarantee. You registry hive is somehow screwed up.
In past one of the users reported the same problem and fix was only reinstalling Windows.
0
noxchoGlobal Support CoordinatorCommented:
Another thought came to my mind, is your HDD dynamic or basic?
0
Davis McCarnOwnerCommented:
Some viruses or registry problems can change the settings for which drives are available.  Try this; but, you would need to be reversing the entries, meaning check the drives so they become available: http://www.worldstart.com/tips/tips.php/1638
If that doesn't get it, I would suggest creating a new user acount to test.  Log into it and see if it has the same problem.
If it does, you probably have a permissions problem.  Get Dial-A-Fix, go to the tools section (hammer button), highlight repair permissions, and Go. http://wiki.lunarsoft.net/wiki/Dial-a-fix
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

pc_docAuthor Commented:
Thanks for the suggestions.

Davis, have tried tweakui with hiding the drives then unhiding them. No good.

I have created a new user, still the same problem.

I will give dial a fix a go tomorrow. Client is working with machine at the moment.

Noxcho, Norton 360 has been installed for 12 months, we just installed the new version for the client, and they asked could we look at the backup as it hasn't been working for a long time, so restoring to a previous point is a no go.

There is something strange going on as mountvol shows drive letters, but diskpart does not. They must read from different parts of the registry.

I am going to try sysinternals regmon tomorrow to see if I can find where the two programs read from, this might point me down the correct path.

Thanks for your suggestions and I will try dial-a-fix tomorrow, you never know.
0
pc_docAuthor Commented:
Sorry, Noxcho.

This happens with either external USB hard drives and USB devices.

Also if I try and change drive letters for either the CDROM, or the second partition on the machine I get the same problem, only add shows up, not change.

Additionally, the user is admin user, and I created another new user also as admin and the same problem exhibited itself with that user.
0
noxchoGlobal Support CoordinatorCommented:
ok, got it. I think you will end up with reinstall just recalling my steps I've taken with absolutely the same issue.
0
Davis McCarnOwnerCommented:
An off-the-wall though; does the system have either GoBack or Ghost installed?
I believe DISKPART primarilly reads the info from the drives themselves and either of those change the partition information.
0
pc_docAuthor Commented:
Denis, sorry it does not have either GoBack or Ghost installed.

Noxcho, I need to find a solution to the fix. I know with Microsoft that is the common fix is the reinstall, but that won't fix the problem, just make it go away.

I prefer to find a solution as to what has caused the problem in the first place, and fix the cause. That is the difference between a computer professional and a computer expert!
0
noxchoGlobal Support CoordinatorCommented:
Do you have Delete Drive Letter option when you right click on partition in Windows Disk Management?
There is a  note on techRepublic forum that reassigning drive letter resolves the problem.
0
noxchoGlobal Support CoordinatorCommented:
Ok, ignore my previous post.
Here is the solution you were looking for:
Start Windows - press Start - run - type regedit and press ok/enter.
Then find the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
There you will need to select Edit - New - Multi-String Value.
Rename it to UpperFilters. Then right click on this value and select Modify. Type PartMgr.
Then quit and restart Windows.
Open Windows Disk Management and see if the problem gone.
I have attached the screen shot, it should look as on screen shot after you edit it.


regedit.PNG
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Davis McCarnOwnerCommented:
noxcho,
That looks promising and is useful information; but,
every reference to it points to a failed Vista upgrade attempt, GoBack (hmmmmm), or, as the root cause, a modified MBR.
pc_doc,
Be very careful!!!  If there is an entry for the UpperFilters registry value, make note of it as you may have to put it back and I would strongly suggest verifying a complete backup of the user's data files.  We are talking about making very low level changes here and a booboo will result in an innaccessible volume.
The other distinct possibility is an MBR virus which, if there, might well have disastrous consequences if you remove it.
0
noxchoGlobal Support CoordinatorCommented:
This is XP problem and pc_doc is working with XP Pro.
Prior to publish this info here I tested it on my own XP machine, done several restarts already and nothing wrong happened yet.
The problem with corrupt or deleted UpperFilters is normally caused by rootkit virus or product behaving like virus.
pc_doc, you can save the registry in the same regedit before apply the changes I described.
0
pc_docAuthor Commented:
Your blood is worth bottling. That fixed the problem exactly. I noticed when I went there that the Multi-string Value was already there although blank, and there was another one called UpperFilters.bak, also blank.

Finally, where did you get this information? I have hunted everywhere and could find no clues to the fault. What Class does this reg entry point to?

Once again, my humble thanks.
0
pc_docAuthor Commented:
Just on a final note. Thank you to both Davis and Noxcho for your assistance.

Weird problem, and I have done root kit, malware, virus scans on the system without finding anything. The only think I can see that may have caused this problem is the client tried unsuccessfully to uninstall Norton 360 a couple of months ago.

He states that the fault has been there for a couple of months.

Thank you both for your assistance.
0
noxchoGlobal Support CoordinatorCommented:
Yahooo!!! Glad to hear that it worked. Now the big mystery of missing drive letters is uncovered!
Actually, I was working with another problem that one of my users met on machine. After resize the space was reported differently in WDM and Windows Explorer. I know that PartMgr is responsible for drives correct representation. It was corrupt like PartM&& and I had to edit it comparing with correct value.
Then accidentally decided that this could be your issue too. Erased value and restarted - vualya! No drive letter. Added the value - restart - Bingo! Letters back.
Again I am happy I could help you.
Take care next time and do not forget taking backups of the system.
0
Davis McCarnOwnerCommented:
OK, what would be very useful was knowing if the entry was completely missing or had another value instead of partmgr and, if so, what was there?
I can certainly see Norton 360 replacing it with its own manager and then failing to correct it.  As a note, even after using Norton's removal tools (which are highly recommended as the uninstaller stinks), there are still Non-plug-and-pray drivers left in the registry.
I'm glad that fixed it.
0
noxchoGlobal Support CoordinatorCommented:
Checked on several WinXP already, PartMgr must be there, and if not then user\admin should add it.
0
pc_docAuthor Commented:

I am looking towards Norton 360 with a big frown. I think it is to blame for this.

The UpperFilter string was there, but had no value. Additionall, there was an UpperFilter.bak string with no value as well.

I removed the .bak string and put PartMgr as the value, rebooted and it works.

Good timing I guess noxcho
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.