Solved

sbs monitoring wizard fails on all steps

Posted on 2009-07-01
30
1,178 Views
Last Modified: 2012-05-07
I have been getting events in the log for my SBS2003 for a long while regarding Sharepoint and Monitoring.
Both are failing;
Monitoring generates a 4104 error (cannot connect to the monitoring database) and Sharepoint generates a 1000 event - the #50070 error - cannot connect to database STS_servername on servername\sharepoint

Initially I want to get monitoring working again and then sharepoint. I mention both in this question because they may be related (both being SQL database connection errors).

I tried running the Monitoring setup wizard but it fails on all steps. Here is the log:

MCW.exe execution started...
Finish text:
-----------------------------------
- Display performance reports in Server Management.
- Configure your server to send daily performance reports at 6:00 am.
- Configure your server to send bi-weekly usage reports at 6:30 am on every other Monday.
- Reports will be e-mailed to the following recipient(s):
      name@domain
- Display usage reports in Server Management.
- Enable logging for your applications.
- Assign the following users permissions to view the usage report on the intranet:
      Domain Admins
- Configure your server to e-mail immediate notification of performance alerts to the following recipient(s):
      name@domain
- Send welcome e-mail to recipients specified for each report.
-----------------------------------
Inside CConfigWizardCommit::Commit
Starting Datastore configuration, now is Date: 2009-07-01 Time: 13:28:01
Inside SetTaskSchedulerService
Exit SetTaskSchedulerService
Inside DeleteOldTasks
GetConfigurations returned. *** ERROR: hr = 0x80004005, Unspecified error
Exit DeleteOldTasks
Inside SetupDatabase
CreateDB returned. *** ERROR: hr = 0x80040e14
Exit SetupDatabase
SetupDatabase returned. *** ERROR: hr = 0x80040e14
***** Configuring Data Store Failed *****
Progress page finished


=====================

At the moment I can't reinstall because I'm not on site and the setup wizard for SBS won't run unless I'm on the built-in admin account - remote desktop isn't good enough it seems.

Any ideas?

Thanks
0
Comment
Question by:ATOCONS
  • 15
  • 14
30 Comments
 
LVL 10

Expert Comment

by:PlusIT
ID: 24754030
you have a problem with your Sharepoint SQL database, are you using sharepoint at all?  Check the services to see if the database can start up.  IF you are not using sharepoint at this moment and you cannot startup the database sql service, reinstalling sharepoint would be your best option
0
 

Author Comment

by:ATOCONS
ID: 24754390
Both the sharepoint service and the Monitoring service are running, but how do I see if  the database is running? Currently I have a tray icon saying MSSQL Server is running...and the SQL Server 2005 console shows the same, but neither mentions specific databases.

MSSQL$SBSMONITORING is running as is MSSQL$SHAREPOINT.
SQLAgent$SBSMONITORING is started but SQLAgent$SHAREPOINT won't start (starts and stops)
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24754715
this is your sharepoint database: MSSQL$SHAREPOINT

If yo uaren't using sharepoint as off know i suggest you completly remove and reinstall it use these url's as pointers:
http://support.microsoft.com/kb/829114
http://www.programminghelp.com/software/installing-sharepoint-services-on-small-business-server-2003/

Let me know if you need further assistance.
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24754731
btw before i forget can you make sure you can connect to the TCP port of the sharepoint database, just to see that it's not a firewall issue
0
 

Author Comment

by:ATOCONS
ID: 24754838
Sharepoint appears to be on port 80.
Telnet to server port 80 gives:
HTTP/1.1 400 Bad Request
Content-Type: text/html
Date: Wed, 01 Jul 2009 14:37:53 GMT
Connection: close
Content-Length: 35

<h1>Bad Request (Invalid Verb)</h1>

Connection to host lost.

HTTP to tat port gives:
 The page cannot be displayed
The page you are looking for might have been removed or had its name changed.

--------------------------------------------------------------------------------

Please try the following:

Open the s: home page, and then look for links to the information you want.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

If you still cannot open the page, click the Internet Explorer
Search button to look for similar sites.

Internet Explorer  
--------------------------------------
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24754991
i ment the sharepoint SQL port not the web service.  Sorry if i wasn't clear about this.
0
 

Author Comment

by:ATOCONS
ID: 24761412
It seems the port should be 1433 then?
If so, then it fails to connect...
SQLAgent$SHAREPOINT is not running now

I tried reinstalling the Monitoring component and it now at least tries to run, but it gives an error Access Denied trying to open assembly 'usage'
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24776788
could you reinstall the sharepoint modules with the links i gave you ?
0
 

Author Comment

by:ATOCONS
ID: 24777986
Yes, done that - the firstt link as I don't have sharepoint 3 which is what the second ink seems to be about..
I now have "Cannot connect to the config database"
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24783476
0
 

Author Comment

by:ATOCONS
ID: 24783646
Hi

The link is for SQL2000 and my system appears  to be using SQL2005 - the update in the link can't be installed.
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24784323
sry didnt know you were using 2005:

http://support.microsoft.com/kb/823287/en-us
0
 

Author Comment

by:ATOCONS
ID: 24784363
Many thanks

In this link, I ahve checked 1, 2 and 4.
For step 3, I found somne difficulty because I don't have the "Enterprise Manager" referred to. I have SQL Server Configuration Manager but it doesn't have the interface described so I can't perform step 3.
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24784520
Enterprise manager is not delivered with the MSDE versions.  IS their another way you can find this info in the configuration manager you have ?

Also a few other things to note:
- do you have a  SQL Server Embedded Edition service (if so make sure it's started)
- Check in IIS if application pool used for sharepoint central admin is running
- If you dont have the SQL Server 2005 Express management studio, download it and check if you have the configuraiton database in the sharepoint.
- Did you perhaps change the NETBIOS ( Domain name of the server? This might also be the reason.)
- make sure their's no local firewall software / antivirus blocking things (disable the services to test it!)
- check file permissions on the config DB database file and try setting it temp to everyone full control to see if this changes anything) -> there has been a patch in the past which changed ntfs permissions to admins only.


PS. when you reinstalled sharepoint, did you first delete the sharepoint MSDE instances ?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:ATOCONS
ID: 24784602
1. I haven't found a way to find the information. Sharepoint Central Site Administration shows me quite a lot of information - what do we need to know?

2. I don't know if I have "Embedded Edition" service. Certainly there's nothing of that name in the Services application. All my SQL seervices are started except SQLAgent$sharepoint, which starts and stops if I try to start it.

3. Sharepoint central admn (and therefore its app pool) is running. Whether sharepoint (and Monitoring) is using a running app pool is another question.

4. I am downloading the Express management studio now

5. The netBIOS name of the server has not changed

6. All firewall software (Windows) is OFF. There is no other firewall software installed.

7. I tried giving Everyone Full Control on the config database file but to no avail. TST_Servername is inaccessible too. I don't know what file this is in (it's servername\Sharepoint I suppose but what's the physical file?

8. I deleted the MSDE instances when I upgraded to SQL Server 2005 if I recall correctly
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24784880
There's seems to be some issues with that sql installation i think, i would remove the databases completely, then remove sharepoint, then remove monitoring and reinstall everything.  After reinstalling make sure the service information is gone after a reboot!  If not delete it manually from registry and reboot again.  After you deleted everything backup and delete any left over files from the installation.  So you are 100% sure you can start clean.

When reinstalling test everything in detail step by step.  

I'm sorry i don't have an out of the box solution for you but this doesn't seem to be a 'standard problem'.
0
 

Author Comment

by:ATOCONS
ID: 24785100
Express Management downloaded.

So part three of that article:

First section
Application Name in point 5 is root
Application pool identity pane says Network Service is the user

Second section
Network service does not appear in the list of logins in step 6. Nor can it be added as a login as it says it's an invalid name
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24785185
which ones do show in the list of logins ?
0
 

Author Comment

by:ATOCONS
ID: 24785225
"i would remove the databases completely, then remove sharepoint, then remove monitoring and reinstall everything.  After reinstalling make sure the service information is gone after a reboot!  If not delete it manually from registry and reboot again.  After you deleted everything backup and delete any left over files from the installation.  So you are 100% sure you can start clean."

Well, yesterday (or Saturday?) I removed the sharepoint and reinstalled, following this article:
http://support.microsoft.com/kb/829114

which removes the registry keys, the services etc.
Is there something I need to do in addition?

0
 

Author Comment

by:ATOCONS
ID: 24785245
The following logins are shown:

ATO-MAIN\SQLServer2005MSSQLUser$ATO-DELL-SERVER$MSSQLSERVER
builtin\administrators
builtin\users
NT AUTHORITY\system
sa
0
 

Author Comment

by:ATOCONS
ID: 24789576
Uninstalled Intranet and Monitoring, removed the sts app pool, removed the sharepoint and monitoring web sites, deleted all associated directories and registry keys, rebooted and reinstalled sharepoint 2 (but not SQL Server 2005).

Result:
Companyweb - Cannot connect to the configuration database.

RWW - repeated prompt for credentials and when Cancelled
 "Access to the path "c:\windows\microsoft.net\framework\v1.1.4322\Temporary ASP.NET Files\remote\3f1585d2\3070828a" is denied."

Monitoring (on the server itself in Server Management) - "Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request."

0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24792875
seeing those errors i"m fairly sure you have permission problems:

could you open up a cmd line go to c:\windows\microsoft.net\framework\v1.1.4322\ and run the following command: aspnet_regiis -i
0
 

Author Comment

by:ATOCONS
ID: 24793148
OK done.
Installed the framework apparently.

Companyweb - from he server itself, as administrator I get the 401.1 error (I can't get the KB961143 fix to install so I kind of expected that)

Trying from a client over a vpn (servername/companyweb) gives a 404 error

RWW remotely gives repeated credential requests then, when I cancel, the
"Access to the path "c:\windows\microsoft.net\framework\v1.1.4322\Temporary ASP.NET Files\remote\3f1585d2\3070828a" is denied."
error

OWA works

Monitoring gives the Server Application Unavailable  error still


One thing I came across was a suggestion that two frameworks couldn't be asigned to the same site, but instructions for making sure only one was, and that it was the correct one, weren't clear. Is that a possibility - that this is using the wrong framework?
How do I know, for example, that the v1.1.4322 framework is the one associated with the application pool that RWW is using?
And similarly that the monitoring and companyweb sites are using the same framework their application pools are associated with?
Or is that a red herring?
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24801753
that could be a problem also yes i once had a similar problem on an SBS 2003 R1.

Go to ytour IIS manager, go to websites rightclick the Virtual Dir or object you want to change on the Tab ASP.NET you can change the .NET fw version.


0
 

Author Comment

by:ATOCONS
ID: 24801775
Is there a way to tell what version each virtual server SHOULD be using? To make sure it's using the same framework as the application pool it's in? (In other words, how can I find which framework a given application pool uses - assuming that an app pool can only use one framework version?)
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24801789
i cannot answer that question tbh, i for once should cross check with a similar server setup
0
 

Author Comment

by:ATOCONS
ID: 24801914
Well, it looks like there is no particular framework version associated with any given app pool under IIS6 (though you can force one under IIS7).
So the problem would be if you have two Virtual Servers using different versions and you put them both in one app pool.
I've created two new pools with names matching the framework versions I have installed, and have made sure my companyweb is in the pool with the right version name. It's the only app in the pool so it should do away with a potential problem from trying to mix framework versions in one app pool.
But it still isn't accessible from the server's own browser because of the 401.1 problem (that I can't resolve because KB961143 won't install).
And from my laptop across the VPN it gives a 404 error
0
 

Accepted Solution

by:
ATOCONS earned 0 total points
ID: 24802532
Well I just re-ran the monitoring wizard and it ran through!
Couldn't produce a report because no data collected yet.

What did I do?
Well I got hold of an IIS Troubleshooting tool from MS and that said the permissions weren't there on my companyweb.
I started digging and found an article with all the default permissions that should be there on the directory for an IIS website. I applied them and that did nothing for the companyweb.

However, while I was at it I applied the same to the Monitoring directory. Then I went to look at the monitoring report to see if I got the same error, but all I got was a notice to run the monitoring wizard - so that looked like progress.
So I ran the wizard and it went right through (although there's no data for a report).

So I guess the title of this post has been resolved by re-applying the default directory permissions for monitoring.

Now I need to get companyweb fixed...
0
 
LVL 10

Expert Comment

by:PlusIT
ID: 24829894
nice to hear, couldn't be that also a permission problem?  Have you figured otu why they have been reset?  Ie rootkit or something?
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

The problem of the system drive in SBS 2003 getting full continues to be an issue, even though SBS 2008 and SBS 2011 are both in the market place.  There are several solutions to this, including adding additional drive space or using third party uti…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now