Sharepoint Email Trouble

I have a new Dell Poweredge Server with SBS 2008 preinstalled. I ran through the configurations for both Exchange 2007, and Sharepoint. Everything is functioning fine, we even have the Remote Web Workplace functioning. The problem was noticed as I tried to assign tasks to a user and they did not receive any email. I checked into the problem and verified that the list is set to send email, the Central Administration settings are set to allow the web application to send and receive email, but none of my alerts will send email. I tried to use the exchange test and I am receiving the error:

550 5.7.1 Unable to relay for...

The local exchange is using a .local pattern and the external email is a .com, but exchange is configured to also know the local users as .com. The default name of the Sharepoint site is CompanyWeb, but the remote name is remote.domainname.com which has its own MX on our DNS server.

I have tried changing the Central Administration Outgoing Email Settings to point to our local server name, IP, and I also left it as the SharepointSMTPServer which was set up by default which has a Host A record pointing to the local server IP. I just fell like I must be missing something obvious because nothing is working
HutsonAssociatesITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gikkelCommented:
This is pretty confusing...is this a completely new setup?  Is your registered domain name correctly setup to point to your IP address?  Are you just trying to get internal email to work?  Who is your ISP? Do you need to forward to smarthosts?  
Assuming everything else is setup correctly, 5.7.1 Unable to relay is most likely related to your default virtual SMTP server settings.  Ensure relay access from all successfully authenticated computers is marked. Let me know if you need help getting there...
0
CitacompCommented:
Unless you are using POP3 or IMAP for email, don't enable the checkbox for allowing all computers which successfully authenticate to relay, except for diagnostic purposes.

In the error log, unable to relay for....?  For who/what?  Is this an account that you have set SharePoint to use, or something else?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gikkelCommented:
Relaying has so many caveats its difficult to properly configure...its not a bad idea to have it checked until you have everything properly setup.  As long as relaying is not marked checked in your default sbs smtp connector, you shouldnt see any problems for quite some time.  Also, under your virtual smtp server, ensure anonymous access is enabled under the access tab and the authentification button.
0
HutsonAssociatesITAuthor Commented:
I finally solved it, I had to configure not only the outgoing email settings in Central Administration, but also in the IIS Administration for the Server as well. I have never had to do this in prior versions of server, but after opening the IIS Manager and finding the SMTP setting page within it all began to work.

Thanks for trying anyway.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.