Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 950
  • Last Modified:

cannot connect to SQL Server 2005 Reporting Services after install on Windows server 2008 and IIS 7.0

I successfully installed and configured SQL Server 2005 Reporting Services on Windows Server 2008 Standard and IIS 7.0.  

When I try to access Reporting Services through SQL Management Studio, I get an error saying that I cannot connect.  I have attached the text of the error in the "Code" section below.

How do I eliminate this error?
Cannot connect to ppgpsrv01.
 
------------------------------
ADDITIONAL INFORMATION:
 
Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
The request failed with the error message:
--
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml"> 
<head> 
<title>IIS 7.0 Detailed Error - 500.23 - Internal Server Error</title> 
<style type="text/css"> 
<!-- 
body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;background:#CBE1EF;} 
code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;} 
.config_source code{font-size:.8em;color:#000000;} 
pre{margin:0;font-size:1.4em;word-wrap:break-word;} 
ul,ol{margin:10px 0 10px 40px;} 
ul.first,ol.first{margin-top:5px;} 
fieldset{padding:0 15px 10px 15px;} 
.summary-container fieldset{padding-bottom:5px;margin-top:4px;} 
legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;} 
legend{color:#333333;padding:4px 15px 4px 10px;margin:4px 0 8px -12px;_margin-top:0px; 
 border-top:1px solid #EDEDED;border-left:1px solid #EDEDED;border-right:1px solid #969696; 
 border-bottom:1px solid #969696;background:#E7ECF0;font-weight:bold;font-size:1em;} 
a:link,a:visited{color:#007EFF;font-weight:bold;} 
a:hover{text-decoration:none;} 
h1{font-size:2.4em;margin:0;color:#FFF;} 
h2{font-size:1.7em;margin:0;color:#CC0000;} 
h3{font-size:1.4em;margin:10px 0 0 0;color:#CC0000;} 
h4{font-size:1.2em;margin:10px 0 5px 0; 
}#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS",Verdana,sans-serif; 
 color:#FFF;background-color:#5C87B2; 
}#content{margin:0 0 0 2%;position:relative;} 
.summary-container,.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} 
.config_source{background:#fff5c4;} 
.content-container p{margin:0 0 10px 0; 
}#details-left{width:35%;float:left;margin-right:2%; 
}#details-right{width:63%;float:left; 
}#server_version{width:96%;_height:1px;min-height:1px;margin:0 0 5px 0;padding:11px 2% 8px 2%;color:#FFFFFF; 
 background-color:#5A7FA5;border-bottom:1px solid #C1CFDD;border-top:1px solid #4A6C8E;font-weight:normal; 
 font-size:1em;color:#FFF;text-align:right; 
}#server_version p{margin:5px 0;} 
table{margin:4px 0 4px 0;width:100%;border:none;} 
td,th{vertical-align:top;padding:3px 0;text-align:left;font-weight:bold;border:none;} 
th{width:30%;text-align:right;padding-right:2%;font-weight:normal;} 
thead th{background-color:#ebebeb;width:25%; 
}#details-right th{width:20%;} 
table tr.alt td,table tr.alt th{background-color:#ebebeb;} 
.highlight-code{color:#CC0000;font-weight:bold;font-style:italic;} 
.clear{clear:both;} 
.preferred{padding:0 5px 2px 5px;font-weight:normal;background:#006633;color:#FFF;font-size:.8em;} 
--> 
</style> 
 
</head> 
<body> 
<div id="header"><h1>Server Error in Application "DEFAULT WEB SITE/REPORTSERVER"</h1></div> 
<div id="server_version"><p>Internet Information Services 7.0</p></div> 
<div id="content"> 
<div class="content-container"> 
 <fieldset><legend>Error Summary</legend> 
  <h2>HTTP Error 500.23 - Internal Server Error</h2> 
  <h3>An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.</h3> 
 </fieldset> 
</div> 
<div class="content-container"> 
 <fieldset><legend>Detailed Error Information</legend> 
  <div id="details-left"> 
   <table border="0" cellpadding="0" cellspacing="0"> 
    <tr class="alt"><th>Module</th><td>ConfigurationValidationModule</td></tr> 
    <tr><th>Notification</th><td>BeginRequest</td></tr> 
    <tr class="alt"><th>Handler</th><td>AboMapperCustom-1656311240</td></tr> 
    <tr><th>Error Code</th><td>0x80070032</td></tr> 
     
   </table> 
  </div> 
  <div id="details-right"> 
   <table border="0" cellpadding="0" cellspacing="0"> 
    <tr class="alt"><th>Requested URL</th><td>http://ppgpsrv01:80/reportserver/ReportService2005.asmx</td></tr> 
    <tr><th>Physical Path</th><td>C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\ReportService2005.asmx</td></tr> 
    <tr class="alt"><th>Logon Method</th><td>Not yet determined</td></tr> 
    <tr><th>Logon User</th><td>Not yet determined</td></tr> 
     
   </table> 
   <div class="clear"></div> 
  </div> 
 </fieldset> 
</div> 
<div class="content-container"> 
 <fieldset><legend>Most likely causes:</legend> 
  <ul> 	<li>This application defines configuration in the system.web/httpHandlers section.</li> </ul> 
 </fieldset> 
</div> 
<div class="content-container"> 
 <fieldset><legend>Things you can try:</legend> 
  <ul> 	<li>Migrate the configuration to the system.webServer/handlers section. You can do so manually or by using AppCmd from the command line - for example, <b>%SystemRoot%\system32\inetsrv\appcmd migrate config "Default Web Site/"</b>. Using appcmd to migrate your application will enable it to work in Integrated mode, and continue to work in Classic mode and on previous versions of IIS.</li> 	<li>If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.</li> 	<li>Alternatively, switch the application to a Classic mode application pool - for example, <b>appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool"</b>. Only do this if you are unable to migrate your application.</li> </ul>       (Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name)      
 </fieldset> 
</div> 
 
 
<div class="content-container"> 
 <fieldset><legend>Links and More Information</legend> 
  Integrated mode is the preferred mode for running ASP.NET applications on IIS 7.0. 
  <p><a href="http://go.microsoft.com/fwlink/?LinkID=62293&IIS70Error=500,23,0x80070032,6001">View more information ยป</a></p> 
   
 </fieldset> 
</div> 
</div> 
</body> 
</html> 
 
--. (Microsoft.SqlServer.Management.UI.RSClient)
 
------------------------------
BUTTONS:
 
OK
------------------------------

Open in new window

0
apitech
Asked:
apitech
  • 2
1 Solution
 
apitechAuthor Commented:
I got past that error.  But, now, I get a new and similar error:

Access to the path 'C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\RSReportServer.config' is denied.

Ideas?
0
 
apitechAuthor Commented:
I got past that error, even.  Now, I'm getting this:

An error occurred while parsing the configuration file. The ReportServerVirtualDirectory element is missing.

Ay, ay, ay!
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now