Solved

Intermec 2435 barcode scanner won't communicate with PC over serial cable

Posted on 2009-07-01
13
1,481 Views
Last Modified: 2012-05-07
Hello Experts,

I've been pulling my hair out over this one. We have a few discontinued Intermec 2435 barcode scanners that need a firmware upgrade in order to work with our systems. I was able to find the firmware and upgrade software but I am unable to get the PC to communicate with the Intermec scanner. I understand that both sides need to have the same settings in order to function properly but I can't for the life of me get them to talk. I haven't worked with configuring COM ports very much so I could just be a victim to unfamiliarity. I would appreciate any input and would really appreciate info from anyone that has had experience with these scanners before, although I imagine that is unlikely. Thanks!
0
Comment
Question by:andrewc2189
  • 8
  • 5
13 Comments
 
LVL 3

Expert Comment

by:sasllc
ID: 24760261
I will try to help, having had years of experience with other 2400 family Intermec models similar to the 2435.

In a situation like this, I like to start by establishing communications with the scanner using Intermec's FileCopy utility.  It is named t24fcopy.exe.  If you don't have it, I will try to find a place it can be downloaded.  Or, I can send it to your e-mail address (assuming that's allowed on E-E).

Be sure you are using a NULL 9-pin cable, because a standard 9-pin will not work.  Also, your computer's serial port must be set to COM1, COM2, COM3, or COM4, as these are the only ones FileCopy can work with.

You will want to reboot your 2435.  I see that the key sequences are different on the 2435 compared to their earlier 2400 models.  This link shows the five keys you need to press to reboot the 2435 on page 10:  http://epsfiles.intermec.com/eps_files/eps_man/071792.pdf

Once you reboot, go down to system menu, press Enter three times, and you should see a list of files.  Find the one named APPTSK.BIN and press Enter, and it should take you to a date and time screen.

Then, put it in the dock, and run FileCopy on your PC.  In the field named PC filename and Path, point to wherever your have the APPTSK.BIN file.  If you can't find it, I can get you that file as well.  Then below for Terminal Filename and Path, key in C:APPTSK.BIN.  Be sure none of the checkboxes to the right are checked.  Then, press the Download button, and if all is well, it should transfer the APPTSK.BIN file within 60 seconds.

If all of THAT somehow works, then you can look at your COM Port Setup tab and your Serial Setup tab to see the settings needed to communciate with your 2435 from other programs.

But if it's not working out, let me know where things stand and I'll try to help further.

Another doc that covers some of the setup detail is:  http://epsfiles.intermec.com/eps_files/eps_man/071791.pdf
0
 
LVL 4

Author Comment

by:andrewc2189
ID: 24760342
Thanks so much for your reply! I honestly did not think anyone would have since I'm trying to fix a discontinued product and all the help I can get online is from left over manuals. I do in fact have the file copy program and was playing with it earlier today, but I didn't really know what I was doing. I knew I needed a null cable but I didn't know how to find out which one in the bin I had was. I'll try asking my co-worker to see if he knows of any and I'll try out the filecopy again tomorrow when I get into work.

The reason I am trying to upgrade the firmware is because we came across a very strange issue and I assumed it would fix it. We purchased these used guns off ebay and for some reason the advanced ip/network options do not show up under the configuration/communications menu. We have previous guns of the same model and firmware that did have this. It's as if certain files on the scanner were deleted. Anyway, I assume a full firmware upgrade will fix this but I would gladly take any other suggestions. No doubt I have to get this to communicate with a PC no matter what. Thanks for your help!
0
 
LVL 4

Author Comment

by:andrewc2189
ID: 24798475
Sassllc,

I am positive now that I am using a null modem cable as we decided to be sure and go out and get a new one. I still have had no luck copying files back and forth or upgrading the device. I can't for the life of me get the pc and the scanner to communicate! What should the COM settings be for the unit and the pc? I have tried making them identical but have still had no luck.
0
 
LVL 3

Expert Comment

by:sasllc
ID: 24804548
Re: the cable, I do hope the vendor who sold it to you really knew that it was a null cable, and I'm saying that only because I know that some--or all--of the big box retailers wouldn't know a null cable if they tripped over it.  We always ordered ours online from cable vendors who deal with such things.  If you'd like, I can certainly ship you a cable, free of charge, that I know for a fact works, and/or I can find you a legit model number for a Tripp-Lite cable.

As for settings, we always used what I think are default settings in FileCopy.  On the FileCopy tab, you will want to clear all check marks on the right.

Them, on the COM Port Setup tab, we used these:

PC COM port: COM1 - COM4 on your computer.
TRAKKER COM Port: always COM1 on the ones we used--the 2410, 2415, 2420, and 2425.
Communication Protocol: Configurable
File Transfer Protocol: YModem
Baud Rate: 19200
Parity Types: Even
Data Bits: 7
Stop Bits: 1

Serial Setup Tab:
SOM: \x02
EOM#1: \x03
EOM#2: (Blank)
Commands via Serial Port: Enabled No TMF
LRC: Disabled
Handshake: Disabled

And, these were the same settings, by default, in the Intermec's BIOS.  I am just assuming that the 2435 uses the same conventions, and of course they need to be checked and compared--like you've already likely done.

There is a chance the guys in Intermec tech support have some ideas that I'm not thnking of, and they always provided free support for me in the past, at 800-755-5505.

Two other possibilities come to mind:

1) I can get online with the computer connected to the dock and see if I can find a solution.  I will be limited, of course, since Intermec never provided a way for me to "see" the 2435 screen remotely, like I can do with newer scanners.

2) You can ship me a 2435 and I can try to get it going.  Since the 2435 dock is different from the 241x and 242x series, I would need a dock as well.

Let me know if you want/need to pursue any of these options, and we'll go from there.
0
 
LVL 4

Author Comment

by:andrewc2189
ID: 24804679
Thanks for the reply, you're being a fantastic help! Here is the cable we ordered:

http://www.pcconnection.com/IPA/Shop/Product/Detail.htm?sku=131239

Let me check this out with a different computer setup and I'll get back to you. It does seem as simple as the cable being incorrect but that one is listed as the right one, be it wrong or not.
0
 
LVL 3

Expert Comment

by:sasllc
ID: 24804777
Yeah, that cable looks right to me.  I guess it couldn't be THAT easy...
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 4

Author Comment

by:andrewc2189
ID: 24805328
So I hooked it up to a different computer and I think I've gotten further. When I attempted your directions with the file transfer, the transfer window opened and the status read "Protocol handshaking in progress". After 4 or 5 block errors reported the transfer would fatally time out. The good news is that during this time the guns scanner was blinking and when the transfer ended it would stop. I guess this at least means there is some communication going on back and forth!
0
 
LVL 3

Expert Comment

by:sasllc
ID: 24805552
Yes, that is a good sign.  Things to check--if you have already done so:

1) Be sure that the 2435 is turned on, and the screen is showing the date and time.  The apptsk program needs to be running, and it will be evidenced by a basic screen showing the date and time--and it's OK if it's wrong.

2) Reboot the scanner, go to Configuration Menu> Communications Menu> Serial Port (COM1) and be sure all the settings match what is showing in the FileCopy setup.  BTW, if the 2435 does NOT show COM1, then we need to know what it does say, and change the TRAKKER port setting in FileCopy accordingly.  When you are finished with this screen, ESC out to the main menu, then System Menu, then press Enter 3 times, choose APPTSK.BIN, and press Enter to get to the date and time screen.

0
 
LVL 4

Author Comment

by:andrewc2189
ID: 24806330
I verified 1 and 2. It does say COM1 on the 2435 but it's still not happy. I'm not sure even updating the firmware will return the missing menus like advanced networking under communications. I just assumed I would have to connect to a PC to resolve it.

If you would like to remote in using teamviewer (www.teamviewer.com) I have a session open as ID: 335703284 password 4234
0
 
LVL 4

Author Comment

by:andrewc2189
ID: 24806408
You may notice I was playing around with it and changed it to the xmodem. I believe it's y by default
0
 
LVL 3

Accepted Solution

by:
sasllc earned 500 total points
ID: 24806516
It looks like everything is set up right.  While online with you, I brought up FileCopy on my computer, and clicked on Download, and it does show the same info on that transfer screen that yours does.  Right now I do not have an Intermec scanner connected, and as a result, my FileCopy showed no progress, either, and had all zeroes on the righ side, and eventually timed out--just like yours does.

I see you have a nice, normal COM1 port, so that should be no problem.  I'm sure you've tried this with another scanner.  If I had one of yours here in my office, I'd have a pretty good chance of seeing the problem and getting it working, but I can't be sure unless we decide to go that route.  Maybe it something different in the settings for the 2435; presumably the guys at Intermec tech support would know that.  If you do talk with them, you can ask them if, right out of the box, you should be able to send files to the 2435 via serial port using FileCopy.  And, you might ask if there are settings in the 2435 that would prevent you from doing so.  In fact, when I get back to the office, I will call them and ask about this.

Still, there is a chance that you will get this going, and then not be able to resolve the wireless settings issues after the firmware upgrade.  I have not dealt with those on any of the Intermecs, so I just don't know.

But if I can get any new info regarding serial comms later today, I will let you know.
0
 
LVL 4

Author Comment

by:andrewc2189
ID: 24808202
I have it working! Thanks so much for all your help sasllc, I'm awarding you points. I contacted their support and apparently for this model I could only use one of their 9 to 6 pin cables which I already had. After hooking up that as well as using a new computer, I was able to get the file transfer to work and using taup to upgrade the firmware. The upgraded firmware fixed all the issues I was having with the guns! Thanks again for all your help!
0
 
LVL 4

Author Closing Comment

by:andrewc2189
ID: 31598846
You went above and beyond to help me ensure all the settings on the pc and gun were accurate and were a great help along the way to a correct answer. Thanks!
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

This story has been written with permission from the scammed victim, a valued client of mine – identity protected by request.
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
The Bounty Board allows you to request an article or video on any technical topic, or fulfill a bounty request to earn points. Watch this video to learn how to use the Bounty Board to get the content you want, earn points, and browse submitted bount…
Saved searches can save you time by quickly referencing commonly searched terms on any topic. Whether you are looking for questions you can answer or hoping to learn about a specific issue, a saved search can help you get the most out of your time o…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now