Creating Access Permissions with DCOM on both Server and Client for Dialogic Application.

hi,

I'm working on a Dialogic Software product. Trying to login to server where the dialogic board is installed, and it keeps pushing me out from the client.
On some R&D found out that the software allows a client machine to connect to the server machine through DCOM security permissions.

Client Machine: Windows XP Professional.
                         Dialogic Software installed.

Server Machine: Windows XP Professional
                          Dialogic Software installed
                          Dialogic Hardware installed

When trying to create access permissions for client on server on DCOM config, the "Locations" part does not
display the "WORKGROUP" domain, whihc both server and client are part of. Hence not able to create permissions
for the client on server.

How Do I take care of this?

Thanks,
Raja
dolphin_gAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
It wont show the workgroup, but the Computername. In the case of not having a Domain, you will need to have identical user accounts/passwords on the client and the server...... That way you can choose the local user that will be connecting to the server....
0
dolphin_gAuthor Commented:
That is exactly what I tried. Creating same user account names with same passwords on both client and server machines. It did not help.
I found this on the software vendors website:

Due to security enhancements implemented in
Windows Server 2003 SP1, Remote DCM will no
longer work with this operating system.
Workaround: In order to allow Remote DCM to
work again, you have to revert the security
settings to the pre-service pack states for the
machine being accessed remotely by modifying
the following two Windows settings:
First Setting:
" Go to Control Panel -> Administrative Tools ->
Component Services.
" Go into the Properties page of Console Root ->
Computers -> My Computer.
" Under the COM Security tab, click on Edit
Limits& button for both Access Permissions as
well as Launch and Activation Permissions.
" For Access Permissions, make sure
ANONYMOUS LOGON has local as well as
remote access.
" For Launch and Activation Permissions, make
sure Everyone has all local as well as remote
permissions.
Second Setting:
" Create/modify the registry value
HKEY_LOCAL_MACHINE\SOFTWARE\Policie
s\Microsoft\Windows
NT\RPC\RestrictRemoteClients. It is a DWORD
value that has to be set to 0 in order for Remote
DCM to work.

DCM - Dialogic Configuration Manager.

Thanks,
Raja
0
dolphin_gAuthor Commented:
This one is for Windows 2003 SP1, does this apply for Windows XP SP3 as well?
0
johnb6767Commented:
It might be worth a shot.... Don't. Just make note of what you change, in case you need to reverse it....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dolphin_gAuthor Commented:
I did try the above. But It did not help. Was'nt able to find anything in the registry entry's. But did make those changes in the DCOM securitysettings . Did not help.
Planning to contact the vendor for more help.

Thanks,
Raja
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.