Solved

5.3.4 Message size exceeds fixed maximum message size (Mode: queuesafe)

Posted on 2009-07-01
13
3,022 Views
Last Modified: 2012-05-07
I am receiving this error on inbound mail in excess of 5 MB, but it looks by the shell that I am set to unlimited size for incoming mail

[PS] C:\Windows\System32>get-transportconfig | fl *


Name                           : Transport Settings
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {127.0.0.1}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 50MB
MaxDumpsterTime                : 7.00:00:00
VerifySecureSubmitEnabled      : False
WritingBrandingInDSNEnabled    : True
PreserveReportBodypart         : False
ConvertReportToMessage         : False
DSNConversionMode              : UseExchangeDSNs
ClearCategories                : True
VoicemailJournalingEnabled     : True
Xexch50Enabled                 : True
MaxReceiveSize                 : unlimited
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : unlimited
OtherWellKnownObjects          : {}
AdminDisplayName               :
ExchangeVersion                : 0.1 (8.0.535.0)
DistinguishedName              : CN=Transport Settings,CN=First Organization,CN
                                 =Microsoft Exchange,CN=Services,CN=Configurati
                                 on,DC=nutting,DC=local
Identity                       : Transport Settings
Guid                           : 3e59d39e-dd56-4650-b0a9-59b8537f650c
ObjectCategory                 : nutting.local/Configuration/Schema/ms-Exch-Tra
                                 nsport-Settings
ObjectClass                    : {top, container, msExchTransportSettings}
WhenChanged                    : 7/1/2009 2:43:54 PM
WhenCreated                    : 3/6/2009 2:02:04 PM
OriginatingServer              : NUTTINGSERVER.nutting.local
IsValid                        : True
0
Comment
Question by:danhartke
  • 7
  • 6
13 Comments
 
LVL 30

Expert Comment

by:renazonse
ID: 24757301
Have you checked the per mailbox limits?

Get-mailbox | ft *, MaxSendSize, MaxReceiveSize
0
 

Author Comment

by:danhartke
ID: 24757334
individual set to unlimited
0
 
LVL 30

Expert Comment

by:renazonse
ID: 24757414
Sorry...this must be on the receive connector and not the send connector:

get-receiveconnector -identity "Default Exchange1SVR" | fl
0
 
LVL 30

Expert Comment

by:renazonse
ID: 24757438
And you'll need to restart the transport service after the change is made.
0
 

Author Comment

by:danhartke
ID: 24757530
returned:


AuthMechanism                           : Tls, Integrated, BasicAuth, BasicAu
                                          RequireTLS, ExchangeServer
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {10.0.0.6:2525, 10.0.0.6:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
Fqdn                                    : NUTTINGSERVER.nutting.local
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 1GB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 5000
PermissionGroups                        : ExchangeUsers, ExchangeServers, Exc
                                          ngeLegacyServers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {10.0.0.2-10.0.0.255, 10.0.0.0-10.0
                                          .0}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
Server                                  : NUTTINGSERVER
SizeEnabled                             : EnabledWithoutValue
TarpitInterval                          : 00:00:05
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Default NUTTINGSERVER
DistinguishedName                       : CN=Default NUTTINGSERVER,CN=SMTP Re
                                          ive Connectors,CN=Protocols,CN=NUTT
                                          GSERVER,CN=Servers,CN=Exchange Admi
                                          strative Group (FYDIBOHF23SPDLT),CN
                                          dministrative Groups,CN=First Organ
                                          ation,CN=Microsoft Exchange,CN=Serv
                                          es,CN=Configuration,DC=nutting,DC=l
                                          al
Identity                                : NUTTINGSERVER\Default NUTTINGSERVER
Guid                                    : 6495d805-efa8-4c50-9086-2a1a47469f3
ObjectCategory                          : nutting.local/Configuration/Schema/
                                          -Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 7/1/2009 2:39:12 PM
WhenCreated                             : 3/6/2009 2:07:19 PM
OriginatingServer                       : NUTTINGSERVER.nutting.local
IsValid                                 : True
0
 
LVL 30

Expert Comment

by:renazonse
ID: 24757590
Is that the only receive connector you have? Typically, Exchange 2007 will have more than 1 receive connector. Have you recently changed the limits and not restarted the transport service?
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:danhartke
ID: 24757657
yes, I changed the limits and did not restart the services
0
 
LVL 30

Expert Comment

by:renazonse
ID: 24757703
The limits will not take effect until you restart the transport service...after that you should be good to go. Also, this topic should be in the Exchange Server section.
0
 

Author Comment

by:danhartke
ID: 24762871
I am still having the same problem
0
 
LVL 30

Expert Comment

by:renazonse
ID: 24762900
try changing this: MaxHeaderSize : 64KB

to: MaxHeaderSize : 128KB

again, you'll need to restart the transport service before it takes effect....is there anything in between your server and the incoming mail? A spam filter or anything of the sort?
0
 

Author Comment

by:danhartke
ID: 24762908
Where might I find that setting?
0
 

Author Comment

by:danhartke
ID: 24763148
Does this help?
Some say 1GB others say 10MB

AuthMechanism                           : Tls, Integrated, BasicAuth, BasicAuth
                                          RequireTLS, ExchangeServer
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {10.0.0.6:2525, 10.0.0.6:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
Fqdn                                    : NUTTINGSERVER.nutting.local
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 1GB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 5000
PermissionGroups                        : ExchangeUsers, ExchangeServers, Excha
                                          ngeLegacyServers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {10.0.0.2-10.0.0.255, 10.0.0.0-10.0.0
                                          .0}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
Server                                  : NUTTINGSERVER
SizeEnabled                             : EnabledWithoutValue
TarpitInterval                          : 00:00:05
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Default NUTTINGSERVER
DistinguishedName                       : CN=Default NUTTINGSERVER,CN=SMTP Rece
                                          ive Connectors,CN=Protocols,CN=NUTTIN
                                          GSERVER,CN=Servers,CN=Exchange Admini
                                          strative Group (FYDIBOHF23SPDLT),CN=A
                                          dministrative Groups,CN=First Organiz
                                          ation,CN=Microsoft Exchange,CN=Servic
                                          es,CN=Configuration,DC=nutting,DC=loc
                                          al
Identity                                : NUTTINGSERVER\Default NUTTINGSERVER
Guid                                    : 6495d805-efa8-4c50-9086-2a1a47469f3c
ObjectCategory                          : nutting.local/Configuration/Schema/ms
                                          -Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 7/1/2009 2:39:42 PM
WhenCreated                             : 3/6/2009 2:07:19 PM
OriginatingServer                       : Terminal.nutting.local
IsValid                                 : True

AuthMechanism                           : BasicAuth
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {127.0.0.1:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
Fqdn                                    : NUTTINGSERVER.nutting.local
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 06:00:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : 20
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 10MB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 200
PermissionGroups                        : AnonymousUsers, ExchangeUsers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {127.0.0.1-127.0.0.1}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
Server                                  : NUTTINGSERVER
SizeEnabled                             : Enabled
TarpitInterval                          : 00:00:05
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Windows SBS Fax Sharepoint Receive NU
                                          TTINGSERVER
DistinguishedName                       : CN=Windows SBS Fax Sharepoint Receive
                                           NUTTINGSERVER,CN=SMTP Receive Connec
                                          tors,CN=Protocols,CN=NUTTINGSERVER,CN
                                          =Servers,CN=Exchange Administrative G
                                          roup (FYDIBOHF23SPDLT),CN=Administrat
                                          ive Groups,CN=First Organization,CN=M
                                          icrosoft Exchange,CN=Services,CN=Conf
                                          iguration,DC=nutting,DC=local
Identity                                : NUTTINGSERVER\Windows SBS Fax Sharepo
                                          int Receive NUTTINGSERVER
Guid                                    : 7a4dc5b3-064e-4eae-b517-d56cb7c72e61
ObjectCategory                          : nutting.local/Configuration/Schema/ms
                                          -Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 3/11/2009 1:46:57 PM
WhenCreated                             : 3/6/2009 2:26:29 PM
OriginatingServer                       : Terminal.nutting.local
IsValid                                 : True

AuthMechanism                           : Tls
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {10.0.0.6:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
Fqdn                                    : remote.nutting.biz
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:01:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : 20
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 10MB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 200
PermissionGroups                        : AnonymousUsers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {10.0.1.0-255.255.255.255, 10.0.0.1-1
                                          0.0.0.1, 0.0.0.0-9.255.255.255}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
Server                                  : NUTTINGSERVER
SizeEnabled                             : Enabled
TarpitInterval                          : 00:00:05
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Windows SBS Internet Receive NUTTINGS
                                          ERVER
DistinguishedName                       : CN=Windows SBS Internet Receive NUTTI
                                          NGSERVER,CN=SMTP Receive Connectors,C
                                          N=Protocols,CN=NUTTINGSERVER,CN=Serve
                                          rs,CN=Exchange Administrative Group (
                                          FYDIBOHF23SPDLT),CN=Administrative Gr
                                          oups,CN=First Organization,CN=Microso
                                          ft Exchange,CN=Services,CN=Configurat
                                          ion,DC=nutting,DC=local
Identity                                : NUTTINGSERVER\Windows SBS Internet Re
                                          ceive NUTTINGSERVER
Guid                                    : 4e357e4a-4a03-4141-a7d3-1545dda27c56
ObjectCategory                          : nutting.local/Configuration/Schema/ms
                                          -Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 3/11/2009 1:46:57 PM
WhenCreated                             : 3/6/2009 2:57:30 PM
OriginatingServer                       : Terminal.nutting.local
IsValid                                 : True
0
 
LVL 30

Accepted Solution

by:
renazonse earned 500 total points
ID: 24763320
All of these: MaxMessageSize : 10MB need to be changed to a greater value even if you're just trying to get 5mb files through...I've noticed my mailbox will say 6mb files are 8 or 9mb+ sometimes.

Try that first but I've also read some literature that says to increase the header size if you continue to have problems and dont want to set the values to unlimited. Also, you may have some sort of transport rule that set with a limit on "AttachmentSizeOver" blocking the attachments. The articles below give a list of the size limits and commands...just make sure there's no transport rules


http://technet.microsoft.com/en-us/library/bb124345.aspx
http://technet.microsoft.com/en-us/library/aa998585.aspx
http://blogs.technet.com/sbs/archive/2008/10/28/how-do-i-change-message-size-limits-in-exchange-2007.aspx
http://articles.techrepublic.com.com/5100-10878_11-6165487.html
http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Desktop Protocol or RDP has become an essential tool in many offices. This article will show you how to set up an external IP to point directly to an RDP session. There are many reasons why this is beneficial but perhaps the top reason is con…
Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now