Opening links from outlook exchange 2003

I'm sure this is going to be simple to solve but I just cant find the solution.
When clicking on a link from within an email, Outlook 2003. Doesnt go to the link destination but opens the file browser like Im asking to save a document....
I did a Detect and Repair (just in case) in outlook but that didn't help.
I'm out of ideas...
any help would be appreciated.
Thanks.
DavidLaradlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TravisCharonCommented:
I think this is a File Association problem.

Try this,

When that "Locate Link Browser" window opens again, do you have the pull down arrow option to the right of the "Open in", or "Look in" words? If so, click the arrow to enable you to navigate through your hard disk.

You need to navigate to "C:\Program Files\Internet Explorer\iexplore.exe"

Highlight iexplore.exe, then click the OK or Open button at the bottom.

If that works, close Outlook and the IE window down, open up Outlook again, and try again, to see if it has saved the settings. If it has not, then place a shortcut of a url, (any url), on your desktop temporarily and click, (double click), it to see if it will open your IE. If not, you have a file association problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shadowlesssCommented:
I have fixed this issue on many machines and I usually fix the problem in two ways....

First...
Is your OS XP?
You need to ....
1 Open My Computer from the desktop or Start Menu.
2 Go to the Tools menu and click on Folder Options.
3. Now click on the File Types tab and youll see a list of registered file types, Extensions and File Types. Under the Extensions column, look for the entries with (NONE) and in that subset, find the entry under File Types that is called URL:HyperText Transfer Protocol.
4. Click on the Advanced button at the bottom and then click on the Edit button.
5. Click the Broswe button and browse out to "C:\Program Files\Internet Explorer\iexplore.exe"
6. Click Ok, Appy,etc...
7. Close IE (if open) and Outlook
8. Open Outlook and click on a link again

if problem still exists......

Second
1. In IE > Tools > Internet Options > Advanced > Click the Reset Button
2. Close IE and Outlook
3. Open Outlook and click a link
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.