windows or bios won't recognize my sata drive

during  install, everything goes well, install drivers at f6, then when windows is ready to install, it halts as it can't find the drive.
motherboard is asus a8v socket 939 bios has been updated (a8v-0229.rom) 500 gb seagate sata drive.
masherdaveAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arixsinCommented:
If your BIOS isn't detecting the drive, you may have a bad drive, bad cable, or bad SATA header. Can you swap any of these and check it in the BIOS again?
0
dbruntonQuid, Me Anxius Sum?Commented:
And test the drive in another machine.
0
top_rungCommented:
I suspect it is a controller issue on the board.  I have seen it many times over.  Make sure that the BIOS is updated (flash it as necessary).  Try another SATA port and use the default BIOS settings (without any mods) - reset it if necessary.

The times when this has happened to me, even after detecting the drive and installing the OS, random bluescreens and drive corruption would occur - all of those drives were and still are fully functional.  Replacing the board always resolved the issue - I stick with Gigabyte these days!



0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Diesel79Commented:
Check to see what mode your drives are operating in. Since you are using xp you made need to switch your sata controller into "compatible" mode or turn off AHCI. This can be done in cmos.
0
JeremySBrownCommented:
In your BIOS...change the settings to IDE mode.
0
tmasters2876Commented:
You said you upgraded the bios?  Did it reset the use of SAT to disabled maybe?  Do you have to enable it?  I know it's obvious, but sometimes it's something simple.
0
masherdaveAuthor Commented:
sorry none of these sugestions work. the drive was recognized in my wifes laptop through usb.
A found a possible fix on the asus site. Thanks for your help. D
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kenzacmCommented:
Hi There,
First of all i would check in your BIOS to see if your SATA is anything else other than Compatability mode as some PC's will not fully support SATA hence why on most computers in the bios SATA support is set to compatibility mode
0
arixsinCommented:
Can you tell us what you found? This could help others in the future.
0
top_rungCommented:
I object as no details of the resolution were supplied: Masherdave, please post your findings to help others.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.