Solved

Increase Exchange 2007 OWA size limit

Posted on 2009-07-01
16
2,496 Views
Last Modified: 2012-05-07
Keep getting an error in OWA that states "files were not attached because they exceed the maximum size limit of 5MB".  What do I need to do to increase this?  I have set the sendconnector maxmessagesize to 100MB and followed the following article:
http://technet.microsoft.com/en-us/library/aa996835.aspx
Still receive the error.
0
Comment
Question by:cmjtech
  • 7
  • 6
  • 2
16 Comments
 
LVL 5

Expert Comment

by:JohnmenZ
ID: 24760612
When you said you have followed the link in your question, are you sure these places are all adjusted consistently?

1. maxRequestLength in the web.config file that is located in <drive>\Program Files\Microsoft\ExchangeServer\ClientAccess\Owa

2. message size limit settings in organisation leve, database level and mailbox level

3. if Exchange is running on Windows 2008 server, also the size limit allowed by the IIS as mentioned in the link you provided.
0
 

Author Comment

by:cmjtech
ID: 24764695
Yes, I have performed all these steps.  Is there a value I can use for unlimited?  I have been using 100MB.  Is this not an accepted value (even though it accepts the input)?
0
 
LVL 5

Expert Comment

by:JohnmenZ
ID: 24770952
To do list:
1. Is your Exchange server 2007 running on Windows server 2008?
2. please return the output of these commands:

   Get-TransportConfig (run this in Exchange management shell)
   Get-Mailbox -Identity UserName | FL (the username is the one you use to send attachment from)

3. Please show me the whole content of web.config from your Exchange server
0
 

Author Comment

by:cmjtech
ID: 24780644
Get-TransportConfig:

ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : unlimited
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : unlimited
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True


Get-Mailbox -Identity UserName:
Name                      Alias                ServerName       ProhibitSendQuo
                                                                ta
----                      -----                ----------       ---------------
Administrator             Administrator        mainserver       unlimited


This is the value I changed in the web.config file:

<httpRuntime maxRequestLength="102400" />

Is there something else I need to change?
0
 
LVL 5

Expert Comment

by:JohnmenZ
ID: 24781173
All those settings look correct to me.

I know you must have read through the document but no harm double checking it again, is it the existing "maxRequestLength" field in the web.config file that you edited?

You still didn't say what Windows version the Exchange is running from.

Also can you please check:
1. get-receiveconnector | list Identity,MaxMessageSize (It gives you connector level size limits)
2. please check these two links about message size limits on Exchange 2007 (I assume you are using Exchange 2007 service pack 1?), they talk about different levels of size limits, which will help you find out if any level that has been missed:
Managing Message Size Limits(http://technet.microsoft.com/en-us/library/bb124345.aspx)
Exchange 2007 Message Size Limits(http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html)
0
 

Author Comment

by:cmjtech
ID: 24794836
I ran through all the steps again, and I'm not getting the 5MB message anymore.  I now get the following:

404 - File or directory not found.

The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.
0
 
LVL 5

Expert Comment

by:JohnmenZ
ID: 24798194
From the error message you are getting, you seem to have Exchange 2007 running on Windows 2008 server, check this excerpt from the link you mentioned in your very first question:

---------------------------------------------------
If you are running Exchange 2007 on a Windows Server 2008-based computer, you must also configure the Outlook Web Access server to allow content that is equal to the size of the maximum message size that can be sent by Outlook Web Access. If you do not do this, one of the following errors may occur.

    * When you use Outlook Web Access to send a large message from a workstation, you receive the following error message:

      Server Error 404 - File or directory not found

      The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.
    * When you use Outlook Web Access to send a large message from the console on a computer that is running Exchange Server 2007 Service Pack 1 (SP1), you receive the following error message:

      Server Error in Application "DEFAULT WEB SITE/OWA"

      HTTP Error 404.13 - Not Found

      The request filtering module is configured to deny request that exceeds the request content length.
---------------------------------------------------

You may be able to confirm the seond error message if you try the same thing from the Exchange server itself.  If you do get the excepted error message, follow these instructions:
---------------------------------------------------
If you run Exchange Server 2007 on an Windows Server 2008-based computer, you must also complete the following procedure.
To configure Outlook Web Access to allow content that is equal to the size of the maximum message size on a Windows Server 2008-based computer

   1. At a command prompt, type the following:
       cd %windir%\system32\inetsrv

   2. Type the following command:
      appcmd set config "Default Web Site/owa" -section:requestFiltering -requestLimits.maxAllowedContentLength:<Content_Length_In_Bytes>
---------------------------------------------------
0
Are your end users making ugly email signatures?

Have you left it up to your end users to create their own email signatures? Are they forgetting to add the company logo or using garish font colors? Take control and ensure all users have the same email signature.

 

Author Comment

by:cmjtech
ID: 24800249
Yes, it is Exchange 2007 on Windows 2008 Standard.  I have run this command several times as well.  I just ran the command again (rebooted server) and here is what I'm getting now:

Internally on the server itself, I can upload files larger than 5MB with no problems.

Externally, I'm back to the "files were not attached because they exceed the maximum size limit of 5 megabytes (MB) for attachments."
0
 
LVL 5

Expert Comment

by:JohnmenZ
ID: 24808081
Can you please try the OWA upload from another computer that is sitting on the same network with Exchange server?  That will help us to narrow down the problem area, just in case we thought Exchange server was the only place to make changes to.
0
 

Author Comment

by:cmjtech
ID: 24817583
I tested it from another computer on the same network, and I'm getting the same 5MB limit error message.  So, the only way it is working is if its on the Exchange server itself??
0
 
LVL 5

Expert Comment

by:JohnmenZ
ID: 24817886
Are you able to run this command is the elevated command prompt and let me know the output please?

appcmd list config "Default Web Site/owa" -section:requestFiltering
0
 

Author Comment

by:cmjtech
ID: 24817943
C:\Windows\System32\inetsrv>appcmd list config "Default Web Site/owa" -section:
equestFiltering
<system.webServer>
  <security>
    <requestFiltering>
      <fileExtensions allowUnlisted="true" applyToWebDAV="true">
        <add fileExtension=".asa" allowed="false" />
        <add fileExtension=".asax" allowed="false" />
        <add fileExtension=".ascx" allowed="false" />
        <add fileExtension=".master" allowed="false" />
        <add fileExtension=".skin" allowed="false" />
        <add fileExtension=".browser" allowed="false" />
        <add fileExtension=".sitemap" allowed="false" />
        <add fileExtension=".config" allowed="false" />
        <add fileExtension=".cs" allowed="false" />
        <add fileExtension=".csproj" allowed="false" />
        <add fileExtension=".vb" allowed="false" />
        <add fileExtension=".vbproj" allowed="false" />
        <add fileExtension=".webinfo" allowed="false" />
        <add fileExtension=".licx" allowed="false" />
        <add fileExtension=".resx" allowed="false" />
        <add fileExtension=".resources" allowed="false" />
        <add fileExtension=".mdb" allowed="false" />
        <add fileExtension=".vjsproj" allowed="false" />
        <add fileExtension=".java" allowed="false" />
        <add fileExtension=".jsl" allowed="false" />
        <add fileExtension=".ldb" allowed="false" />
        <add fileExtension=".dsdgm" allowed="false" />
        <add fileExtension=".ssdgm" allowed="false" />
        <add fileExtension=".lsad" allowed="false" />
        <add fileExtension=".ssmap" allowed="false" />
        <add fileExtension=".cd" allowed="false" />
        <add fileExtension=".dsprototype" allowed="false" />
        <add fileExtension=".lsaprototype" allowed="false" />
        <add fileExtension=".sdm" allowed="false" />
        <add fileExtension=".sdmDocument" allowed="false" />
        <add fileExtension=".mdf" allowed="false" />
        <add fileExtension=".ldf" allowed="false" />
        <add fileExtension=".ad" allowed="false" />
        <add fileExtension=".dd" allowed="false" />
        <add fileExtension=".ldd" allowed="false" />
        <add fileExtension=".sd" allowed="false" />
        <add fileExtension=".adprototype" allowed="false" />
        <add fileExtension=".lddprototype" allowed="false" />
        <add fileExtension=".exclude" allowed="false" />
        <add fileExtension=".refresh" allowed="false" />
        <add fileExtension=".compiled" allowed="false" />
        <add fileExtension=".msgx" allowed="false" />
        <add fileExtension=".vsdisco" allowed="false" />
      </fileExtensions>
      <requestLimits maxAllowedContentLength="104857600">
        <headerLimits>
        </headerLimits>
      </requestLimits>
      <verbs allowUnlisted="true" applyToWebDAV="true">
      </verbs>
      <hiddenSegments applyToWebDAV="true">
        <add segment="web.config" />
        <add segment="App_code" />
        <add segment="App_GlobalResources" />
        <add segment="App_LocalResources" />
        <add segment="App_WebReferences" />
        <add segment="App_Data" />
        <add segment="App_Browsers" />
      </hiddenSegments>
      <denyUrlSequences>
      </denyUrlSequences>
    </requestFiltering>
  </security>
</system.webServer>

C:\Windows\System32\inetsrv>
0
 
LVL 5

Accepted Solution

by:
JohnmenZ earned 250 total points
ID: 24819651
I am guessing the OWA virtual directory is somehow broken, hence the value in the web.config file is not honoured.  Some people on the net say that could be caused by the Exchange 2007 service pack 1 installation.

You may be looking at fixing the OWA virtual directory on the Exchange server.  It will be a risky and potentially destructive operation if not handled properly, having non-Exchange web sites running on the same server will even add more complexity to the process.

In short, here is the Microsoft kb article that talks about rebuilding the IIS on Exchange server, it includes Exchange 2007.
http://support.microsoft.com/default.aspx?kbid=320202

I wonder you may be able to get away fixing it by justing doing these without following the whole instructions:

-----------------------------------------------------------------
Step 4: Re-create the IIS virtual directories to restore links with the Exchange 2007 Mailbox role
If Exchange is configured to have the Mailbox role, re-create the virtual directories in IIS to restore the links to the Mailbox role.

Important If Exchange is not configured to have the Mailbox role, skip this step.

To re-create the virtual directories in IIS, follow these steps:

   1. Start the Exchange Management Shell.

      To do this, click Start, point to All Programs, point to Microsoft Exchange Server 2007, and then click Exchange Management Shell.
   2. Type the following commands. Press ENTER after you type each command.
          * get-owavirtualdirectory -server server_name -DomainController dc_name | ? {$_.OwaVersion -eq "Exchange2003or2000"} | remove-owavirtualdirectory -DomainController dc_name
          * new-OwaVirtualDirectory -OwaVersion "Exchange2003or2000" -VirtualDirectoryType "Mailboxes" -DomainController dc_name
          * new-OwaVirtualDirectory -OwaVersion "Exchange2003or2000" -VirtualDirectoryType "Exadmin" -DomainController dc_name
          * new-OwaVirtualDirectory -OwaVersion "Exchange2003or2000" -VirtualDirectoryType "PublicFolders" -DomainController dc_name
          * new-OwaVirtualDirectory -OwaVersion "Exchange2003or2000" -VirtualDirectoryType "exchweb" -DomainController dc_name
      Notes
          * Replace server_name with the name of the Exchange 2007 server.
          * Replace dc_name with the name of a domain controller.
      Note Alternatively, you can put these commands into a script file (.ps1) and then run them at the same time.
-----------------------------------------------------------------

I haven't done this kind of rebuild on Exchange 2007 before, so cannot tell you what to be aware of.  As a general principle, always backup your Exchange server (including system state, Exchange information storages and everything else) so that you have a rollback position.

If you have non-Exchange services running on that server, plan the backup / restore for those services as well.  Especially those relying on IIS to function.

I strongly suggest you go through the kb article mentioned above and make 100% sure you understand what each step is doing, then plan the whole process properly with the most important rollback plan before you consider doing it.
0
 

Expert Comment

by:Cicio1412
ID: 24961812
I am having this same problem with OWA. I found the article on how to fix the size limitation issue on EXCH07 SP1 running on Server 2008 STD. The cmdlet  [ appcmd set config "Default Web Site/owa" -section:requestFiltering -requestLimits.maxAllowedContentLength:<Content_Length_In_Bytes> ]  Does not want to play nice with me....... I keep getting "The syntax of the command line is inncorrect"..... What gives ? Any help would be appreciated.
0
 

Assisted Solution

by:Cicio1412
Cicio1412 earned 250 total points
ID: 24961866
Also,
Quick heads up...
I too had to re-install IIS and exchange to re-create the OWA virtual directories.  Very tricky (At least for me) One piece of advice is try to add and remove from the Command prompt. Using the Add/remove programs feature in Server 2008 forces you to remove options that specifically say to keep on in the http://support.microsoft.com/default.aspx?kbid=320202 knowledge base.
0

Featured Post

[Webinar] Disaster Recovery and Cloud Management

Learn from Unigma and CloudBerry industry veterans which providers are best for certain use cases and how to lower cloud costs, how to grow your Managed Services practice in IaaS clouds, and how to utilize public cloud for Disaster Recovery

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

29 Experts available now in Live!

Get 1:1 Help Now