Solved

Sybase 15.0.3 Installation / Upgrade Failed with "Floating point exception"

Posted on 2009-07-02
20
1,926 Views
Last Modified: 2013-11-05
We have a ASE 12.5 running on linux box. Now planning to upgrade to 15.0.3. After extracting the binaries, getting a error message "Floating point exception" while try to build the server.
Even try using upgrade utility but same messge. I tried the server build and upgrade without shuting down the old ASE 12.5.

Is there any memory related parameter need to be changed? Can some one help on this?
0
Comment
Question by:dearvjkumar
  • 7
  • 7
  • 4
20 Comments
 
LVL 6

Expert Comment

by:IncisiveOne
ID: 24763369
Did you make sure you downloaded the exact correct binary for your flavour of Linux:
  • 32 or 64 bit
  • Red Hat vs Suse, etc
  • your chip set
You can find out (even though you have not built the server yet), in the /bin directory:
dataserver -v
Of course, for many reasons, it is much better to install the new server on another box, but there is no problem building a new server without shutting down the existing server, as long as you are not trying to replace the old one in place.  That means:
  • use a separate directory tree
  • separate master device
  • separate data devices
  • different ports for ASE, backup, xp, etc
  • you have only one set of the variables ($SYBASE, etc) active per user
Cheers
0
 
LVL 19

Expert Comment

by:grant300
ID: 24764091
"12.5" could be very old if it is really 12.5.0 and not something newer like 12.5.4.  That being said, you may be running on a very old piece of hardware that is not fully supported by the version of the O/S you are running.

Exactly which flavor and version of Linux are you running?  Be aware, that only the "enterprise" or "Advanced Server" version of Red Hat and Suse are supported.  The consumer-grade fedora and desktop versions of SUSE are simply not going to work for you.

If you want to use a free version of Linux that is pseudo supported for Sybase, I would suggest CentOS.  It is the true open source build of Red Hat AS that has been debranded and had the few Red Hat proprietary extensions (you will never miss them) removed.  The version numbers track those of Red Hat so that CentOS 5.2 is Red Hat AS 5 Update 2.

You may actually have a combination of both problems; old chip set and unsupported O/S.  In some cases, the supported version of the O/S will make allowances for old chip sets that lack certain features; something the consumer grade distros are much less likely to bother with.

Regards,
Bill
0
 
LVL 2

Author Comment

by:dearvjkumar
ID: 24771172
My OS is RedHat Linux Enterprise 4 (2.6.9-42)
My existing ASE is Adaptive Server Enterprise/12.5.4/EBF 13396/P/x86_64/Enterprise Linux/ase1254/2006/64-bit (dataserver -v)

But after extracting the 15.0.3 binnaries even dataserver -v just gives "Floating Point Exception" message.
My 15.0.3 binnaries are located in different file system only.
Chip Set : 8 CPU - Intel(R) Xeon(TM) CPU 3.20GHz

Please advice how to solve this issue.
0
 
LVL 6

Expert Comment

by:IncisiveOne
ID: 24771652
>> But after extracting the 15.0.3 binaries even dataserver -v just gives "Floating Point Exception"

1  In that case, you definitely have the wrong binaries.

2  I just checked and there are no 32 bit versions for x86_64, for obvious reasons.  There is only one set of 64 bit binaries available for download for x86_64.  Is it possible you chose the incorrect platform, something other than
Platform: Linux x86-64
3  I would advise against the latest greatest, bleeding edge minor release.  

3.a  If you are trying out 15.0.x then
15.0.2 ESD # 6
is the latest I would recommend.  

3.b  For production, I do not support anything later than
12.5.4 ESD #8
You can always download again, and make the choices consciously.

Cheers

0
 
LVL 19

Expert Comment

by:grant300
ID: 24773439
You are trying to run the 64 bit version of Sybase on a 32 bit version of RedHat.

You have two choices:
 - Do as Incisiveone suggests and download the appropriate version (32 bit) of Sybase
 - Move to the 64 bit version of RedHat.

If you are running on an 8 core machine, you probably have at least 16GB of RAM.  It is pointless to run the 32 bit version of ASE in a hardware environment that large.  The only way to take advantage of it is to move up to 64 bit RedHat.

Regards,
Bill
0
 
LVL 6

Expert Comment

by:IncisiveOne
ID: 24775474
Bill

I was not confused before, but now (after your post) I am confused:
  1. If dearvjkumar has "ASE 12.5 running" on his Linux box; and the ASE 12.5 version string contains "/x86_64" and "/64-bit" then he must be on a 64 bit processor (otherwise ASE would not be "running").
  2. In which case he cannot be running 32-bit Linux RHEL (and then running a 64 bit ASE on top of that, successfully).
  3. AFAIK, Intel Xeon is 64 bit (only)
  4. AFAIK, you cannot run 32 bit RHEL on a 64 bit processor.
Therefore I am still of the opinion that he has a 64 bit processor.

I did not suggest that he download the 32 bit version of ASE; I did suggest he had the wrong version of ASE and that he download the appropriate version.

He has 8 CPUs, we do not know how many cores he has yet (dual or quad).


dearvjkumar

1.  "8 CPU - Intel(R) Xeon(TM) CPU 3.20GHz" is not a chipset, it is a lay description. It does not even have a model number.  There are four possible 3.2GHz processors.  Can you look at: and choose a chipset.  That is, one of:
45nm
65nm
90nm
And a processor number.

2.  Confirm that you understand you have a 64 bit chipset, and you have 64 bit RHEL running.

3.  Re-confirm that you have ASE 12.5.4 6-bit actually running.

4.  As per my post 24771652, choose the correct binary from the Sybase Download page, and download again.

Cheers

0
 
LVL 19

Expert Comment

by:grant300
ID: 24786103
IncisiveOne,

The Intel XEON, or even the desktop chips, are 64 bit capable.  They do not lose the ability to run 32 bit O/Ses or programs.  You can indeed and many sites do run 32 bit RedHat on XEON 64 bit processors.  The one thing Intel has done right all these years is ensure backward compatibility.  That's why it is still possible to boot DOS from a floppy on a brand new server box should one get the urge.  Of course, if someone has that particular urge, they should probably seek professional help 8-)

Seriously though, I have seen several instances where people have tried to run 64 bit programs on a 32 bit O/S figuring (hoping?) the CPU was the determining factor.  You can, BTW, continue to run 32 bit programs on a 64 bit version of RedHat without a problem.  All the 32 bit libraries are present...

Regards,
Bill
0
 
LVL 6

Expert Comment

by:IncisiveOne
ID: 24786508
Thanks for the explanation.  Ok, so OP has 32 bit RHEL running on 64 bit Intel Xeon.  But Sybase do not provide 32 bit ASE (12.5.4 or 15.0.x) for that platform; just 64 bit.  Also, OP states he has "existing", running Sybase ASE 12.5.4  64 bit (refer version string), which he could not possibly do on 32 bit RHEL.

Cheers
0
 
LVL 2

Author Comment

by:dearvjkumar
ID: 24791493
uname -a
Linux server2 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux
&
cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4

On the existing ASE 12.5.0.4
------------------------------------
/sybase/ASE-12_5/bin/dataserver -v
Adaptive Server Enterprise/12.5.4/EBF 13396/P/x86_64/Enterprise Linux/ase1254/2006/64-bit/OPT/Sat May 20 00:15:42 2006

On the extracted binary of ASE 15.0.3
------------------------------------
/sybase1503/ASE-15_0/bin/dataserver -v
Floating point exception

CPU Info: 8 CPU dual core
-------------------------------
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 6
model name      :                   Intel(R) Xeon(TM) CPU 3.20GHz
stepping        : 8
cpu MHz         : 3192.218
cache size      : 8192 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 6
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm pni monitor ds_cpl est tm2 cid
 cx16 xtpr
bogomips        : 6389.96
clflush size    : 64
cache_alignment : 128
address sizes   : 40 bits physical, 48 bits virtual
power management:

My new downloaded ASE 15.0.3 :
-----------------------------------------
ase1503_linx8664_64.tar.gz

Now tell me whats wrong?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 19

Expert Comment

by:grant300
ID: 24795329
Yup, your right.  Now that we have the detailed version information, we don't have to guess anymore.

What is the patch level of RedHat 4 you are running?

The Sybase certification website,
http://certification.sybase.com/ucr/platformDetail.do?certId=1151&platformId=117&productId=2
has the following information for 15.0 64 bit...
 - RedHat AS4 release 3,4,5, and 6
 - Minimum kernel version is 2.6.9-34.ELsmp
 - Glibc version required is 2.3.4-2.19

Check your Glibc version.  Also, try setting the LD_POINTER_GUARD environment variable to '0' (zero) and see if that makes a difference.

You may also want to roll back to 15.0.2 unless there is a specific feature in 15.0.3 that you absolutely have to have.

Regards,
Bill
0
 
LVL 6

Expert Comment

by:IncisiveOne
ID: 24800045
I specialise on midrange boxes and Sybase, I will defer to Bill on Intel specifics.

Your download gzip filename looks suspicious.

1  From the download website you may notice that 15.0.3 GA has been withdrawn.  They are already at 15.0.3 ESD #1.  If I start the download sequence, the files identified are completely different from that which you have, refer first attachment.  Therefore it looks like you have an out-dated file, probably 15.0.3 GA (withdrawn), or you received the file from a source other than Sybase (and you need to get support from that source).  

1.1  If you were adamant on staying with your gzip package, there is nothing authoritative to check against, because the release is withdrawn.  Therefore I cannot help you further on that point.

2  I am on ASE 15.0.2 ESD #6.  I would never recommend downloading the latest bleeding edge release (ESD).  15.0.3 has new features and the new codeline will have new bugs, which will be worked out in the next few months.  Therefore I recommend 15.0.2 ESD #6.  The second attachment shows the filenames and sizes for this release (again consistent with other releases but not with your gzip file).

We know the binaries from your current gzip file do not work, and it cannot be verified, so one way or another you have to download again.  Choose which ESD you want, download again, confirm you have the intended/desired release; we can then check your gzip filenames and sizes before you unzip and install.

Cheers

ASE-1503-ESD-1-Download.png
ASE-1502-ESD-6-Download.png
0
 
LVL 2

Author Comment

by:dearvjkumar
ID: 24802562
This is my glibc version.

glibc-devel-2.3.4-2.25
glibc-2.3.4-2.25
glibc-devel-2.3.4-2.25
compat-glibc-2.3.2-95.30
glibc-2.3.4-2.25
glibc-kernheaders-2.4-9.1.98.EL
glibc-common-2.3.4-2.25
glibc-headers-2.3.4-2.25

But still i am having the same issue. I tried downloading the setup files again also.

Do I need to change any OS level paramters? or in environment variables other than LD_POINTER_GUARD.

Please help.
0
 
LVL 6

Expert Comment

by:IncisiveOne
ID: 24802852
Did you read post 24800045 ?

What does "downloading the setup files again" mean ? I advised two specific downloads, with one preferred.  Can you confirm  which item you downloaded and what is the download filename and no of bytes.

Also, who installed and built your ASE 12.5.4 server.

Cheers

0
 
LVL 2

Author Comment

by:dearvjkumar
ID: 24811009
Hi incisive,
We have downloaded the setup file from sybase.subscribenet.com as we have support contract and licenses.

I was able to do the setup 15.0 successfully in another server which is RH Linux 5.
The current server is RH Linux 4 and getting floating point exception error while building master device.
Again I tried in GUI mode and attached the screen shot for your reference.

Do you have any idea?

Error.JPG
0
 
LVL 6

Expert Comment

by:IncisiveOne
ID: 24814140
I cannot check subscribenet readily (we are licensed on Solaris, MacOS and Widoze ... it will take a week or so to get the paperwork organised to obtain a licence on another platform).

Well, if it works on Intel Xeon/RHEL 5, but not on Intel Xeon/RHEL 4, then (a) you have the correct binary (had, all along ?) and (b) it is time to open a case with TS.  No use wasting any more time.  They will check the certification first.

The other option, as detailed above, is to try 15.0.2 ESD #6.

Cheers
0
 
LVL 2

Accepted Solution

by:
dearvjkumar earned 0 total points
ID: 24857181
Dear All,

Thanks for your time. I found and fixed the issue.

It was due to libaio-0.3.105-2.x86_64 dependency with ASE 15.0 under 64bit.

After updating the libraries, I did the setup successfully.
0
 
LVL 2

Author Comment

by:dearvjkumar
ID: 25002181
I am not able to find the accept button under my account.
0
 
LVL 2

Author Comment

by:dearvjkumar
ID: 25020353
Thanks angel !!!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

HOW TO: Connect to the VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere (HTML5 Web) Host Client 6.5, and perform a simple configuration task of adding a new VMFS 6 datastore.
HOW TO: Upload an ISO image to a VMware datastore for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere Host Client, and checking its MD5 checksum signature is correct.  It's a good idea to compare checksums, because many installat…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now