Problems with SonicWall TZ170 - Verizon DSL Router

I am helping a friend setup their network at a small non profit.  They have a Sonicwall TZ170 firewall and have new DSL service from Verizon.  Verizon provides a Westell DSLModem/Router with the connection.   Initially  we were running with double NAT.  The Westell router LAN config has DCHP turned on.  The LAN port of the Westell is connected to the WAN port of the Sonicwall.  The Sonicwall is configured to use NAT with DHCP client for the WAN and to act as a DHCP server on the LAN.  This seemingly worked fine.  We could get onto the internet with no problem in most cases.  The trouble we've seen is that we can't get to certain websites and have trouble logging on to websites that require authentication (some not all sites).   We can ping these sites fine but a web browser just hangs when trying to access the page or complete the login authentication.  It's happened on both Firefox and IE.  As soon as we remove the Sonicwall from the connection and have the desktop computer go straight to the interent through the Westell dsl router, those same website work completely fine.  I tried to adjust the Sonicwall to use Transparent mode, where the sonicwall DHCP server was turned off and the Westell acted as the DHCP server.  In that case we could still browse the internet but we had the same weird problem with certain websites.  In effect, transparent mode did not solve the problem.  So, it seems there is some issue with Double NAT (or maybe not since transparent mode didn't work either).   For now I've just removed the sonicwall from the connection entirely (the Westell has a firewall built in as well) but for obvious reasons we'd like to use that.   Any suggestions would be very helpful.
emilysamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jfer0x01Commented:
Disable NAT on the Westel Device by setting the Westel modem/router to bridge mode

I will provide a doc to facilitate soon

Jfer
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jfer0x01Commented:
Found one link

http://www.voipmechanic.com/westelltobridge.htm

let me know if thi works for you

Jfer
0
emilysamAuthor Commented:
Thanks.  I didn't see any obvious place to do that in the Westell config but maybe your doc will point it out.  
0
Do You Have a Trusted Wireless Environment?

A Trusted Wireless Environment is a framework for building a complete Wi-Fi network that is fast, easy to manage, and secure.

jfer0x01Commented:
Can you see "Expert Mode on Left Side of Screen"?

The ISP tech support may have to do this if not

Jfer
0
emilysamAuthor Commented:
I'm not onsite and don't have access to the router at this point.  When I'm back over there I'll give it a shot.  It seems the new Verizon routers from westell have been pretty "dumbed" down.   Nonetheless, I'll take a look and see if I can find it.

0
jfer0x01Commented:
any progress?

Jfer
0
jfer0x01Commented:
Hi,

please award points or close question

Jfer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.