Web Server Authentication Problem

I want to access a new web server I have created, but I am having problems with Authentication

I have gone back to basics and created an Index.htm page in the root folder that just says "Hello World" and when I type in the URL http://webserver/index.htm from the webserver it goes straight to the page and displays "Hello World", but if I run this URL from any other maching in the network then I get a Windows Authentication login page and if I enter the domain\User & password I get to the "Hello World" page, how do I configure IIS to allow me acces without seeing the Login page.

I'm assuming that for this simple test that I'm not yet going through the ISA Server

I appreciate that there are plenty of variables I haven't mentioned, so please ask any questions that will help resolve this problem.

I either have a DNS or an Authentication setting issue
Steveh24Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fosiul01Commented:
i think you will have to enable

annynomous login from IIS control panel

and take off , intregrated windows login

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steveh24Author Commented:
Tried that, but makes no difference, still get the login page
0
fosiul01Commented:
aftr change, did you restart IIS ??
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Steveh24Author Commented:
yes
0
Steveh24Author Commented:
When I uncheck the Windows Authentication, I then get an error saying Im unauthorised to view this page,

HTTP Error 4101.1
0
fosiul01Commented:
what about with windows authentciation, sorry i didnot touch windows for long, so bare with me
click the windows authentication + anynomous access
0
Steveh24Author Commented:
That was the default setting, windows authentication + anynomous access, which works but you get a login page, if I uncheck windows authentication then I get the error as described above
0
fosiul01Commented:
ok
then its must be permissin issue

can you check, the username is in annynomous user, it has the permission of that directory you are trying to access
0
Steveh24Author Commented:
Sorry, don't understand what you mean
0
fosiul01Commented:
ok
in IIS , under anynomous user, there would be a username and password ,example IUSR_PCNAME


now, go to C:\Inetpub\wwwroot\Direcotryname

check the permisison

if  IUSR_PCNAME has the permission to read that directory
0
Steveh24Author Commented:
ok, think I have found the problem, but can't resolve it.

IUSR_FILESVR is the name used for annynomous login, but if I go to  C:\Inetpub\wwwroot\Index.htm and check the security setting this name is not there and if I try to add it, IUSR_FILESVR cannot be found.

FILESVR is the name of the server box.
0
fosiul01Commented:
you need to click on find button, to get all the user list
0
Steveh24Author Commented:
Ok did that and only found IUSR_QUESTSVR & IUSREXCH1 which are our two DC's, but no IUSR_FILESVR, it doesn't exist
0
fosiul01Commented:
Can you try one thing to test its out ??

use any Administrative username and password in their, or use administrator username and password

( you can change that username later on any time)

i just want to see if it works

so use administrator username and password in annynomous login

then resatrt iis then try
0
Steveh24Author Commented:
I did find it, it is called Internet Guest Account IUSR_FILESVR
0
fosiul01Commented:
thats good, with that one , did it work ??
0
Steveh24Author Commented:
Using the administrator username and password in annynomous login didn't make any difference, still being asked to login
0
Steveh24Author Commented:
Nothing is working still being asked to login
0
fosiul01Commented:
its must of that issue....

have you checked permisison

wwwwrooot ?

0
Steveh24Author Commented:
Why, why why does it keep asking for me to login when I have it set to use annynomous logins
0
fosiul01Commented:
i saw this error for a public serve,r where i had to give IUSR_FILESVR to read permission to that directory

0
Steveh24Author Commented:
I'm not really sure what I'm looking for in wwwroot
0
fosiul01Commented:
right click on wwwroot folder
check permission

whats in the permission ??
do you hvae internetguest account and IUSR_FILESVR in their ??
0
Steveh24Author Commented:
Yes, IUSR_FILESVR is there and I have given it Full control, but makes no difference, still being asked for a damn login
0
fosiul01Commented:
are you trying with firefox or internet exploer ??
0
Steveh24Author Commented:
IE8
0
fosiul01Commented:
DAMM...

what about if you try to access the website via Ip

http://ipofyourserver/index.html

does it come ??
0
Steveh24Author Commented:
Tried that before asking for help, no joy
0
fosiul01Commented:
read this

http://forums.iis.net/t/1150013.aspx

do you want to try by  configure IE to pass credentials by adding the site to the intranet zone in IE.
0
Steveh24Author Commented:
sorry, think I've been confusing both of us, I've just tried the URL on my own pc and it goes straight to the web page "Hello World", so I checked the Laptop I was doing the test with and I've noticed that it is logged in as the Admin to the local machine so it's not part of AD, just logged in as Admin to the Domain and the test URL goes straight to the web page "Hello World"

Guess I need to go back and put everything back as it was and try and see if I can access the main Web Site, which is what I was originally tried, will ask for your help if I have problems, if not I will give u the points coz you have been very helpful.

Steve
0
Steveh24Author Commented:
I think I have now got it working, but it's asking for the login credentilas twice, the first time for Username & Password, then it's asking for Domain/Username & Password.

How can I stop it asking for Domain/Username & Password
0
Steveh24Author Commented:
I have noticed that if I use a PC connected to AD that the only login screen I see asks for Domain/Username & Password and then connects to the web page, but if I use a PC outside of AD I get the two login screens as described in my previous reply.
0
Steveh24Author Commented:
Found the problem, there was a setting in the Listener's Advnaced tab that allows authentication over http, when I ticked this, it all worked perfectly
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.