Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Unable to Set Default Domain in Windows Server 2008

Posted on 2009-07-02
12
Medium Priority
?
932 Views
Last Modified: 2013-11-21
We have configured TS Web Access which uses a Terminal Server Gateway to connect to a Terminal Server running end user applications. Both machines are running Windows Server 2008 Enterprise x64. We have mixed domain controllers (Some Windows Server 2003 and some Windows Server 2008). We have 2 problems.
First I am unable to set the default domain for either of the servers and when users attempt to login they are required to type the domain prior to their username (Domain\Username). Obviously this confuses them and often they are unable to connect. I have tried editing the registry by creating the 'DefaultDomainName' key and setting it to our domain, but that did not work. Also I tried editing the group policy setting <Computer Configuration><Administrative Templates><System><Logon><Default Domain> on the Windows Server 2008 domain controller. No luck their either. Is there something I am missing or does anyone have any other ideas that might help?
The second problem is that I would like the user to only have to sign in once, instead of being prompted at the TS Gateway and the Terminal server itself. I have read about Single Sign on (SSO) but that does not work with Windows XP machines. Thanks in advance.
0
Comment
Question by:kpurchase
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
12 Comments
 
LVL 10

Expert Comment

by:Datedman
ID: 24766350
0
 

Author Comment

by:kpurchase
ID: 24817932
I have tried to configure this by editing the group policy on one of Windows Server 2008 DC. I can see that the policy is being applied  on the TS gateway server and when I remote desktop to the server it seems to be working properly and I can see the domain that I specified is the default. The problem is that it's not working when I go through TS web access. When I attempt to log in it changes to the computer name of the TS gateway.  
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24817958
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 

Author Comment

by:kpurchase
ID: 24822376
How will this help me? I can already see that the policy is being applied by using the gpresult -r command.
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24822692
Sorry same thing basically...weird.
0
 

Author Comment

by:kpurchase
ID: 24826715
I am not really sure how the group policy would help me here. When I use TS Web Access it's using the remote desktop connection that I configured in TS Web Access to connect to the TS gateway server and then the terminal server. I could be wrong but it doesn't seem like it's checking the group policy results on the TS gateway at all. Someone has got to have run into this before.  Any ideas is appreciated I have tried everything I can possibly think of. I have already tried specifying the domain in the RDP connection, editing group policy (Both domain and local), and editing the registry.
0
 
LVL 51

Accepted Solution

by:
Netman66 earned 2000 total points
ID: 24981901
In the tsweb folder there is a file (external.htm) that can be modified to add in the domain info.

0
 

Author Comment

by:kpurchase
ID: 25198579
Where is the tsweb folder?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 25199847
On the webserver in %systemroot%\Web\Tsweb

0
 

Expert Comment

by:BenY
ID: 26846455
I have a similar issue, but do not have the "tsweb" folder.  My setup consists of the TS Gateway without the TS Web Access.  We RDC directly into the terminal servers..

I have it down to one login, but it requires the "domain\username", and my users are not used to typing in a domain name.

I was able to specify this on the properties of the Terminal Server Gateway Configuration "Log on Settings" tab, but this must not be the only place I need to modify.  This appears to only be for the remote administration of the server itself.  I've also looks at the IIS 7 configuration and specified the default domain on the "Basic" authentication, but it appears the TS gateway uses the "Windows" authentication, which isn't configurable for default domain.

Any help is much appreciated!
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question