POS Printer Issues

30+ hours into POS upgrade, hardware and software.  Last thing not working is my kitchen printer Epson TM-U230.  Connected to parallel port and shared on the network.  Here is the thing, it was working yesterday, via the server and our one station PERFECTLY.  Then (as I was about to go home, of course!) it started printing "jibberish" and returned to the status "User Intervention Required" in the printers folder.  I am lost and confused and loosing sleep! I have no more ideas so I am begging for your knowledge and help!  BTW 3 other printers are attached via USB, are shared and working perfectly.  All the printers are Epson models, kitchen is a different model than the receipt printers, however. Thank you in advance! :)
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nat WallisTechnical Services ManagerCommented:
Have you tested if it works by itself? IE take out all the other printers to see if they are causing the issue. I have seen a few weird issues with these sorts of setups. First thing I would do is just test the printer directly on the computer with nothing else attached so try and isolate the issue. See if it will printer from windows okay. you say its a printer in the kitchen so I would make sure the cable is okay as well. If the cable is thru the wall (like some I have seen are) then test a direct cable connection, as there might be cable damage. Just because some printers work okay on the cable doesnt mean that its not the cable - so I found out the hard way after lots of wasted time.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HDineleyAuthor Commented:
I have not tested it on it's own because of the issues I have had with the installation of the printers in general.  It would make me very, very nervous to disconnect my other printers!  I even called Epson on the phone twice for an hour and was hung up on once and put on perpetual hold the second time! NIGHTMARE!  I am heading back up there today, I think I may have a cable to try a direct connection first maybe without unplugging the other printers. This and all the other printers worked fine prior to installation of our NEW computer and software.  Don't know why cables could have gotten damaged?? However, it seems to be the nature of anything we do up there at our bar - it's just not easy! The new computer's parallel port is not a part of the motherboard, could this be an issue? THANK YOU! Feel better already having some support.
Nat WallisTechnical Services ManagerCommented:
I know what you mean in tht you dont want to potentially make it worse that what it is trying to get something else to work.

I have done a few jobs with the expansion cards where people are using 3 or more printers and have found them to sometimes cause the issues as they might try and used a shared resource.

I have seen other instances where having several of the same printers can cause some issues with the drivers as well but I know with these epson units they are designed to have multiple on the 1 system as well so technically that shouldnt be the issue.

Have you tallked to the POS software company as there may be additional configuration or settings for your specific setup.
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

HDineleyAuthor Commented:
naughtynat: Well between triple checking the the parallel card settings and plugging it in directly, the problem has been resolved. I always think of the commercial..."is it plugged in? .. plugged into what? ... the wall?!?  It didn't come with a wall!" when I trouble shoot computer issues.  However, this time didn't think to double check the cable.  Chalk it up to a blond moment, way too much software installation, 35+ blurry-eyed hours, and possibly the wine..... and definitely a dodgy cable connection!  Thank you for your help. Love this resource here. We are officially up and running at full speed ahead!  Thanks a million.
HDineleyAuthor Commented:
You rock!  Had a great night's sleep last night, finally! Thanks!
Nat WallisTechnical Services ManagerCommented:
Thanks for the points and glad it worked :-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.