symantec endpoint on sbs 2008 reinstall fails

I have a brand new SBS 2008 server that was once set up correctly with SEP 11 (MR4)  It was having issues with shares disappearing, clients being disabled and not registering properly with the server, etc so i decided to remove/reinstall the program on the server.  The uninstall had issues but I finally got it removed by calling Symantec for the SEP 11 removal tool.  I am now running into problems when I try to re-install the console.  It appears that there are registry permissions preventing me from continuing and the installation fails.  I have tried installing as the domain administrator as well as another account with admin privileges.  I have attached the error.  Once I get the error it rolls back and fails.  Anyone ran into this yet?
error.jpg
LVL 6
univision-computersAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jimmymcp02Commented:
did you use the latest cleanwipe?
 
http://www.experts-exchange.com/Software/Internet_Email/Anti-Virus/Symantec/Q_24355519.html
 
If not there were some issues with the previous version that left registry info. also the previous version did fully support 64bit OS for win2k8 and vista 64
0
univision-computersAuthor Commented:
Yes, I called Symantec and got the cleanwipe tool.  It removed the program but I was unable to re-install it due to the registry error above.  And yes, it was the latest version of the software so it should have been 64 bit compatible....I think... it was version 11.0.4000 MR4 (Since that original install they have released maintenance patch 2.....version 11.0.4000 MR4 MP2 which I have downloaded and will try to install)

I called Symantec again and they reviewed the logs to determine that the error was due to a failed removal of the unmanaged client on the server.  Apparently when you install from the autorun menu it defaults to the 32 bit and is not smart enough to know that you are using a 64 bit machine.  Also instead of installing the managed client on the server it installs the unmanaged...

The tech directed me to the manual removal method:

 Title: 'How to uninstall Symantec Antivirus, Symantec Endpoint Protection,and Symantec Endpoint Protection Manager, and what to do if that fails'  
0
jimmymcp02Commented:
i believe thats and issue with MR4.... symantec tries to install a 32bit on a 64 bit. that issue is fixed on MP1 or MP2
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

univision-computersAuthor Commented:
I've got MP2 but it still appears to install into the (x86) directory so it may or may not be fixed.  I am thinking of calling Symantec again to see for sure.  I don't want to go through the same thing again...
0
jimmymcp02Commented:
Did you try installing by browsing to the folder instead of using the autorun feature?
 
 
 
0
univision-computersAuthor Commented:
Symantec called me back today and the technician confirmed that it is still a 32-bit management console even in the MR4 MP2 version.  There is no 64 bit server console at this point.  However, once the console is installed and you make the client install packages you can build a x64 installer that makes the server a 64 bit managed client.  I will try the install again in a few days and post on the results.
0
univision-computersAuthor Commented:
To give an update, the admin console installed successfully on the server, but not the client.  Symantec reviewed the logs after the client install failed again and they found that the DCOM settings had been changed or restricted in some way.  They suggested this article to fix it:
http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2002103013521548?Open&seg=ent

I will post back and report if that works or not.
0
univision-computersAuthor Commented:
That solution did not fix it.  I will try to get Symantec on the phone and see if they will fix it for me.  I am out of ideas :(
0
jimmymcp02Commented:
wow.... this is an interesting issue. keep us posted...
0
univision-computersAuthor Commented:
OK so I am excited.  I found that  it was not just Symantec having this issue but also Windows updates and other programs as well.  It appears to be a registry issue dealing with the Windows Installer service.  It normally appears as an error like the one above - Error:  Could not open Key "Unknown\Components\_______" and fails with any number of different keys.  Apparently Microsoft has a fix for it in Server 2008, Vista, XP, Server 2003 and perhaps others.  Here is the link:  http://support.microsoft.com/Default.aspx?id=313222

It worked for an Exchange update and I am now rebooting, so next I will try SEP and see how it goes!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
univision-computersAuthor Commented:
SEP installed successfully.  It was definitely due to the Windows Installer issue.  Hope this helps someone else, it has been a struggle for me!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.