Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 375
  • Last Modified:

Exchange Information Store won't mount

I had a sbs 2003 go down. The information store will not mount and in ESM shows nothing, although database still in progamfiles/exchsrvr/... I have traced the source of multiple errors to a transaction log corrupt/missing. I have attempted eseutil and got nothing but errors.
I'm sure its fixable but I am out of time.

see link of previous question :
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24531289.html

I have backed up all pst files manually, 12 users, and want to delete the current information store. Then create a new information store and simply reconnect the users and import pst back into pc's. I'd rather not use exmerge if possible, and do I have to uninstall and reinstall exhchange server?

0
Howlermunkey
Asked:
Howlermunkey
3 Solutions
 
Britt ThompsonSr. Systems EngineerCommented:
Have you tried the /p switch when running eseutil? There's a chance of data loss but it should get you back up and running:

http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html
http://technet.microsoft.com/en-us/library/aa996773(EXCHG.65).aspx

I'd also run the eseutil /d after you have it repaired
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Please see my comments in the above mentioned Q you still have open.

Philip
0
 
Britt ThompsonSr. Systems EngineerCommented:
What errors are you getting when trying to run the eseutil? Have you dismounted the store when trying to run the utility?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
HowlermunkeyAuthor Commented:
renazonse -- eseutil /p == "the database is not up to date. This operation may find that this database is corrupt because data from the log files has yet to be placed in the database"   i chose to scan anyway, philip i am going over your previous link now as well. I havent been to successful with exmerge yet, thats why im trying other methods, but I'll go back and read again.
0
 
Britt ThompsonSr. Systems EngineerCommented:
So you chose to scan and the scan is running now? Or, the scan has already failed?
0
 
HowlermunkeyAuthor Commented:
yep, store is dismounted already, in fact thats the problem, it won't mount. I get the message "an internal error has occured"    I have a slew of messages in event viewer -- (see other link).. the server was off , and as it looks like it wasnt a proper shut down. It seems the transaction log files are off.. here are some of the errors in event viewe

Error 0xfffffde1 starting Storage Group /DC=local/DC=ASJC/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=ASJC/CN=Administrative Groups/CN=first administrative group/CN=Servers/CN=ASJC-SBS/CN=InformationStore/CN=First Storage Group on the Microsoft Exchange Information Store.
Storage Group - Initialization of Jet failed.

The MAPI call 'OpenMsgStore' failed with the following error:
The Microsoft Exchange Server computer is not available.  Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0526-00000000


 
 

0
 
HowlermunkeyAuthor Commented:
the scan appears to be running, although very very slowly, I see one dot at the bottom, and only % for completion so far
0
 
Britt ThompsonSr. Systems EngineerCommented:
Depending on how large and how bad off your database is along with how fast your server is it could take quite some time.
0
 
HowlermunkeyAuthor Commented:
ok, i see progress now (fingers crossed :))
0
 
HowlermunkeyAuthor Commented:
/p was successful, before i attempt to mount the store I will run /d now
0
 
kdagliCommented:
After eseutil /d is completed, mount store once and then dismount it again.

Run isinteg to fix the logical corruption.

isinteg -s <exchange server name> -fix -test alltests

E.g  isinteg -s MAIL -fix -test alltests

After you hit enter, you will get the option to selec the store number. select the store in question and proceed. Once completed, mount your store.
0
 
sujmatpCommented:
Make sure you remove/move any log files present in the default location, else you won't be able to mount the stores.
Then dismount stores and run isinteg and mount your store again.
0
 
HowlermunkeyAuthor Commented:
Great all around info for a difficult challenge. Thanks again!
(MPECSInc I am awarding you 500 points on original question for all your help)
0
 
HowlermunkeyAuthor Commented:
I just wanted to add that sujmatp was right on target  about the log files. After I ran /p and /d, and several more failed attempts to mount... I removed ALL log files out of exhcsrvr/mdbdata.. I restarted the server and went to bed. When I woke up this morning exchange was up and running, (and i see new log files in place)... One more thought: is it possible for out of sync log files to keep a store from mounting, from say a hard power down on server? because one of the very first messages i got was log related.... exchange was looking for example 12345 when all it could find was 12346... or was that just a necessary step after a necessary repair on the store?

I now realize how ignorant I am with exchange, time to pull the books out :)  ! Well, much thanks again to all.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now