Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Nokia - mail for Exchange - sync fail

Posted on 2009-07-02
12
940 Views
Last Modified: 2012-08-13
Hi
I'm trying to sync my Nokia phone to our exchange server. I've Installed mfe (mail for exchange) on the Nokia phone  - and the Mfe has been setup.

The phone is becomming connected to the exchange server - but is disconnected imminently - the log on the phone says - "fail in Exchange server - try again later" That is the only error message i get - so how to solve this problem?

Regards - Steffen .
0
Comment
Question by:UpgradeIT
  • 5
  • 4
  • 3
12 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24766991
Is ths your first phone that you are trying to work with activesyc on the server or do you have other working phones at present?
0
 

Author Comment

by:UpgradeIT
ID: 24767038
Do not have other working phones yet. I've tryed with another Nokia phone same fail. I do not have a windows mobile device to try with at the moment.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24767048
Are you using a self- signed certificate or a purchased one?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:UpgradeIT
ID: 24767058
selvf signed..
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24767084
Okay - I was going to suggest you check the connectivity on https://testexchangeconnectivity.com but self-signed certificates usually fail the test.
Can you confirm that the server is setup properly, asuming you have access, by following the steps in the following link please:
http://www.amset.info/exchange/rpc-http.asp
If you are using an SBS server - follow the single server section.
0
 

Author Comment

by:UpgradeIT
ID: 24767562
The test fails on certificate yes. I do not understand the guide on amset - more specific what do I need t tjec?

It's a small business server - and the connect to internet guide has done the job for me many times before - but not this time..

Outlook webaccess i working fine..

I've changed the http port to port 81 on the default website - but active sync is using 443 right? port 81 i not forwarded to the server - so only https site are avalible..

0
 
LVL 65

Expert Comment

by:Mestha
ID: 24767585
The guide you were pointed to was mine, but it isn't really correct.
That is for RPC over HTTPS, which is an Outlook feature, not a mobile device feature.

ActiveSync will only use port 80 or port 443. Furthermore if you have changed the HTTP port to something else, that will break Exchange. You need to leave it on port 80 as there are internal calls made on that port by Exchange - including by Exchange ActiveSync which the Nokia tool connects to.

Simon.
0
 

Author Comment

by:UpgradeIT
ID: 24767602
So the phones are using port 80 eventhung its a secure connection??

The problem is there is also running a apache webserver on the same server - and right now apache is using port 80 - for php applications.. Therefore I use port 81 on the ISS server - is that not possible?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24767860
Simon, as ever your knowledge is second to none - you truly deserve your Microsoft MVP award.
UpgradeIT - sorry if I was sending you off in the wrong direction - I have now updated my knowledge a little and will continue to do so, no doubt.
 
0
 
LVL 65

Accepted Solution

by:
Mestha earned 500 total points
ID: 24767928
No, the phones do not make a connection to the server over port 80.
There is an internal call - from one virtual directory to another inside Exchange. That is made over port 80. It isn't a security risk, as it is completely internal to the server.

Public Folder management also connects via port 80, so changing the port can break that as well.

Simon.
0
 

Author Comment

by:UpgradeIT
ID: 24768153
So its because i've changed the port on default website to 81 i doesnt work right?

If port 80 is only used for internal calls, then i can install apache on a virtual server and forward port 80 to apache again right?

I can conclude that its not possible to run apache on the same host as ISS and Exchange - right ..?
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24780304
As long as Exchange is still able to use port 80, what you do with external port 80 traffic is up to you. I never open port 80 on any site that I manage as I don't want the risk. I run Exchange with just two ports open to the internet.

Simon.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question