Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Updating php.ini on a Linux VPS

Posted on 2009-07-02
9
Medium Priority
?
456 Views
Last Modified: 2013-11-15
Hello,

I currently run the following on a VPS:

Operating system: Linux 2.6.9
Ubuntu 8.04
Plesk Control Panel v8.6.0 with Virtuozzo

I would like to amend the php.ini file in order to activate an extension.

Would you please be kind enough to guide me through the process?

Many thanks
0
Comment
Question by:wilson1000
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 29

Expert Comment

by:fosiul01
ID: 24766908
type this

locate php.ini
( normaly its /etc/php.ini)
it will show you where is php.ini

sudo nano php.ini

do your change

then restart apache
0
 
LVL 4

Author Comment

by:wilson1000
ID: 24766923
Sorry, where shall i type it?
0
 
LVL 29

Expert Comment

by:fosiul01
ID: 24766955
in ubuntu pc , command line
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 4

Author Comment

by:wilson1000
ID: 24767002
cool...

I have this screenshot, what should i type in here?

      I need to activate this extension:

     extension=php_mcrypt.dll

cmd.jpg
0
 
LVL 29

Expert Comment

by:fosiul01
ID: 24767012
how comes your php.ini file is empty ??

it should not be empty.

you sure you are editing right file, not empty file ??
0
 
LVL 29

Expert Comment

by:fosiul01
ID: 24767020
you can use, phpinfo() file to see the path of your php.ini

0
 
LVL 4

Author Comment

by:wilson1000
ID: 24767148
Thank you, this is the value from an info call:

/etc/php5/apache2/php.ini
0
 
LVL 29

Accepted Solution

by:
fosiul01 earned 2000 total points
ID: 24767159
ok then

go to
cd /etc/php5/apache2/

sudo nano php.ini

change as you want

0
 
LVL 4

Author Comment

by:wilson1000
ID: 24767393
It looks like the extension doesn't exist ? php.ini says:

; Directory in which the loadable extensions (modules) reside.
; extension_dir = "./"

But there is no list of extensions to uncomment ? Does that mean that what ever is in that directory will be activated?  
0

Featured Post

Python: Series & Data Frames With Pandas

Learn the basics of Python’s pandas library of series & data frames and how we can use these tools for data manipulation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can use conditional statements using Python.
This article discusses how to create an extensible mechanism for linked drop downs.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question