• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 826
  • Last Modified:

AirLink ANAS350 NAS peformance problem

I have an AirLink ANAS350 NAS device.  It seems like a nice piece of equipment, but when I copy data to it over my wired, 100Mbps LAN, I get a paltry 4 Mbps data transfer rate.  I bought a new Seagate 1.5 TB 7200 RPM SATA drive along with the device, so that isn't the problem.  If I install the drive directly in my computer, my transfer rate is a couple of orders of magnitude higher.  While I'd expect a large improvement since the transfer is all on the internal bus rather than over a LAN, 4Mbps is painfully slow.
Does anyone have any experience with this? Perhaps my expectations are too high?
  • 3
1 Solution
Rob HutchinsonDesktop SupportCommented:
The LAN port on the AirLink ANAS350 NAS device is a 10/100 port so looks like it's dropping down to a half duplex 10mb speed.

Make sure that the LAN connection matches on both so that you are running full duplex 100. You might have to set them both to manual and not use auto-negotiation.
Rob HutchinsonDesktop SupportCommented:
Looking through the AirLink ANAS350 NAS manual, I don't see anything about changing the network port speed so you may only have the option of changing it on the computer.

If this is the case, experiment with changing just the computer from it's existing port speed setting of ?"100 Auto" to 100 full or 100 half and test it again. It could just be the auto negotiation is not auto-negotiating.
DuMondeAuthor Commented:
hank you very much for your advice.
This was a new machine (running the beloved Vista), and I hadn't looked at the network speed settings.
It turns out it was set at 10Half.  A little odd, but whatever.
I tried various network speed settings:
Using 100Full, I get about 1.5x the throughput I was getting before, about 6Mbps.
using 100Half, I get about 36 Mbps! That's about 9 times what I was getting initially.
I also get this same throughput when I set it to auto or auto 100.

So it's now doing pretty well, given where I started.  Do you think there's any more tweaking that can be done?
I'm going to take a look at the router's settings.
You mentioned that there NAS's adapter didn't appear to be configurable.

Rob HutchinsonDesktop SupportCommented:
Yeah, it's prob as best as you are going to get unless you see some network port speed setting on the NAS that you can configure. Just make them match the PC if you do.

If you get the same speed using auto, then I'd leave it there until you have problems with it being slow again. This way, you should get the fastest speed when connecting to other devices.

It is kind of strange that the port would be set to 10 half.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now