Disable "Disconnect" from Remote Desktop

We have a Windows Server 2003 Enterprise Terminal Server.

We want to force users to use the "Log Off" option rather that ticking the "X" at the top of the screen, or disconnecting.

Is there a way we can do this via/ Group Policy?

Also can you prevent users from right clicking the RDP session on their local PC and clicking "Close"?
Drakin030Asked:
Who is Participating?
 
Shabarinath RamadasanInfrastructure ArchitectCommented:
If its only for once server, you can do this on "Terminal service Configuration" MMC Snapin.

Go to Start > Program files > Administrative Tools > TS Configuration >
Select Session

Check "Override user settings"

Select the time duration you need to have before ending an disconnected session.
(I prefer to make 5mins atlest - In case of a network or bandwidth issue, this will give 5mins time in case if we are able to get reconnected)

Cheerio
Shaba
0
 
Glen KnightCommented:
In terminal services manager right clock on TVP-rdp select properties and you can tell terminal services how to deal with disconnected sessions so they don't get jogged on your licenses
0
 
Drakin030Author Commented:
Well our goal is to prevent users from incorrectly disconnecting thus leaving printer sessions active and such. We wan tto try and force users to use the log off button.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Glen KnightCommented:
OK, sorry I misunderstood, try this: http://technet.microsoft.com/en-us/library/cc975906.aspx
0
 
Drakin030Author Commented:
Shabarinath,

I may need to go with your method.

Demazter,

That option would work under the start menu, but that would still give the user the option to hit the X at the top of the RDP client.
0
 
Glen KnightCommented:
I don't think you can stop them doing that as it's just like any other app on the client but the TCP-rdp settings I mentioned in my first post would help this situation
0
 
Glen KnightCommented:
Which are the same as the other post just I am on a mobile so couldn't type so much :-)
0
 
Drakin030Author Commented:
Even though we couldn't disable the actual "X", setting a disconnect option should work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.