Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Installing generic USB Bluetooth Dongle - Possibly Driver Problem

Posted on 2009-07-02
3
Medium Priority
?
5,897 Views
Last Modified: 2013-12-14
I have purchased an unbranded USB Bluetooth dongle from eBay. The purpose was to transfer photos from my bluetooth-enabled phone to my computer. The dongle did not come with any drivers disk. The only clue as to who made it is the company name "Cambridge Silicon Radio Ltd.", which is listed as the manufacturer for the "Generic Bluetooth Radio" under the Hardware tab in the Bluetooth Devices section of Control Panel.

 When I plugged it in to my XP Professional SP3 machine, Windows automatically installed generic drivers for it, and then said the device was ready for use. However, it doesn't work properly. When instructing the computer to search for new Bluetooth devices, using the "Add Bluetooth Device Wizard...", no devices are found, despite several being in range.

It does allow the PC to be seen by other devices (like my mobile phone) as a bluetooth device though, so it's not completely dead! It does not allow connections though. Iif you try to get the phone to connect to the computer, nothing at all happens at the computer end, even though all the options are set to allow connections, show as visible, etc. The connection request just times out.

I plugged the dongle in to my mums  Windows Visata machine to see if the Dongle itself was faulty, but everything worked perfectly. Vista did the same thing as XP, it found and installed generic drivers all by itself automatically, but on Vista it worked fine.

I then dug out an old laptop with XP SP2 on it. That also worked! It can see other devices, it pops up a message when a phone tries to connect to the computer, etc. Everything's good. But I want to use the dongle with my main machine, not these other two!

I went to see if my two XP machines were both using the same drivers, and found that they weren't.

On the (older) machine, which IS working with the dongle, the drivers are version 5.1.2600.2180, Driver date: 03/08/2004.

For the newer and more updated SP3 machine, which isn't working with the dongle, the drivers are newer: version 5.1.2600.5512, Driver date: 13/04/2008

If you go in to "Driver details..." it tells you the names of 5 files (bthport.sys, bthusb.sys, bthprops.ctl, fsquirt.exe, bthenum.sys) and their locations. I thought that if I overwrote all the  driver files on this newer XP system with the older drivers from the other XP system (which I know do work with the device), then this might fix it. So I tried this. I overwrote the above mentioned 5 files with older versions from the other PC. Some of the files were a slightly different file size. However, when I rebooted the computer and reinserted the dongle, they had all magically reappeared again as version 5512! All the files which I overwrote with 2180 versions had somehow managed to come back to being original 5.1.2600.5512 versions, and the same filesize as the original 5512 versions. I tried it once again and the same thing happened?!

So my question is, do you know how I can get it to accept and use older drivers?

Also, could there be another explanation, for why a system cannot search for and detect other bluetooth devices, but can be seen by other bluetooth devices, but no device can connect to it? I don't know for sure that it is the drivers, it's just one thing I was going to try and check before seeing if there was anything else I could think of.

Any help appreciated
0
Comment
Question by:pendulumx
  • 2
3 Comments
 
LVL 44

Expert Comment

by:Darr247
ID: 24773905
You should have gotten version 5.1.2600.5620 with KB951376 v2.
See http://support.microsoft.com/kb/951376

What type of BT dongle is it?
e.g. the $1 dongle I got off amazon has a Device Instance ID on the Details tab in Device Manager of
USB\VID_0A12&PID_0001\7&38E64336&0&2

and when I search for USB\VID_0A12&PID_0001 in google I find a couple different sites near the top telling me that's a broadcomm unit, so the widcomm stack should work with it if microsoft's did not (but it does).

Have you done a search for the files you're replacing with the Advanced options 'Search system folders', 'Search hidden files and folders' and 'Search subfolders' checked?
When I did that here I found bthport.sys in 9 different folders.
0
 
LVL 1

Accepted Solution

by:
pendulumx earned 0 total points
ID: 24828251
The BlueSoleil drivers did the trick
0
 
LVL 44

Expert Comment

by:Darr247
ID: 24828560
How did you find out it was a BlueSoleil dongle?
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question