How do I open (and access) Poet 22 on Ubuntu 9.04

I am attempting to access an Ubuntu 9.04 computer from a Windows XP computer using WinSCP.

On the Ubuntu, when I enter "sudo ufw status" I get: "22/tcp Allow Anywhere"

On Window, when I enter "telnet 169.254.113.80 22" I get "Could not open connection to the host, on port 22: Connect failed"

When I attempt to connect with WinSCP, I get "No connection could be made because the target machine actively refused it. Connection failed."

Note: I can ping the Ubuntu IP address from the Windows box.
gleibyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

thetmanvnCommented:
Hi gleiby,

1./ First, check if you've installed ssh server or not, and did it start?

root@xxx:~# dpkg-query -s openssh-server | grep Status
Status: install ok installed

After check if ssh server started or not:

root@xxx:~# netstat -natp | grep sshd
tcp6       0      0 :::22                   :::*                    LISTEN      4342/sshd

Your firewall seems ok

2./ Now if ssh server is not install, just install it with apt-get install openssh-server (or more simple apt-get install ssh)

3./ Start manually ssh server: /etc/init.d/sshd start

Hope this help
0
fosiul01Commented:
Hi
your ip  169.254.113.80

its seems to be a public ip

is this a server outside of your network ?? ( from your previous question, i thought both server and windows pc is in same network )

whats the Ip of your windows box ??

can you show me the output of ipconfig /all from windows pc ??

or this ubuntu server is public server??
0
thetmanvnCommented:
@fosiul01:

The 169.254 subnet range is for APIPA - Automatic Private IP Addressing. OS uses APIPA in instances where a DHCP server is not present. When a host cannot find a DHCP server, it will assign itself an address in the 169.254 subnet range, thus allowing communications between itself and other PCs who are using APIPA.

So assusmed here, both PCs are using APIPA.

But as fosiul01 said, can you put your ifconfig on Ubuntu 9.04 and ipconfig on Windows PC here?
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

fosiul01Commented:
@thetmanvn, true, true

i am  still sleeply i guess, so didnot notice its 169


0
QEMSCommented:
From another thread that gleiby has started it would appear that ssh is installed and working.

For some background have a look at http://www.experts-exchange.com/OS/Linux/Q_24539441.html?cid=238#a24764874

gleiby - How many devices are connected to your network with the ubuntu server and the windows machine?
0
gleibyAuthor Commented:
Ok it looks like I do not have ssh installed. Can you post a link to where I can download the package (my Ubuntu is not on line).

Background on my network setup:
1 Ubuntu desktop machine
1 Windows machine
1 4-port switch
0
fosiul01Commented:
it shold be

apt-get install openssh-server

but the output you sent to other post, by lookign that, your openssh server was installed!!
0
fosiul01Commented:
also please read:

the ip you set in your ubuntu server. thats wrong

you need to put the correct ip, other wise you would not able to ssh
0
QEMSCommented:
Is it possible to connect your ubuntu machine to the net for the purposes of installing ssh ?

If not, you may be able to install it from the CD/DVD used to install the ubuntu system - have you tried that? I'm not sure if it is included on the desktop disc, but it is definately on the server CD.
0
QEMSCommented:
if you look in /etc/apt/sources.list you may need to uncomment (remove the # at the start of the line) the CD repositories.

It will probably be the first line, it should start with the following:
#deb cdrom:[ubuntu 9.04....

That should enable the system to install packages from the CD.

Once you've done that you can try to install ssh again with the command:
sudo apt-get install ssh openssh-server

Assuming the package is on the desktop CD it should install it for you without needing a connection to the internet - I haven't had time to check if it is on that CD yet though. I'll post here if I have time to test it before I finish for the day.
0
thetmanvnCommented:
If your Ubuntu can't go online, and you have Ubuntu 9.04 install disc, you should issue these commands to get your ssh server go online:

Put your CD into CD-ROM Drive

root@xxx:~# apt-cdrom add
Using CD-ROM mount point /cdrom/
Unmounting CD-ROM
Waiting for disc...
Please insert a Disc in the drive and press enter
Mounting CD-ROM...
Identifying.. [b36baea778d37bbf48a3c8bd75b5cffb-2]
Scanning disc for index files..
Found 2 package indexes, 0 source indexes, 0 translation indexes and 1 signatures
This disc is called:
'Ubuntu-Server 8.04 _Hardy Heron_ - Release i386 (20080423.2)'
Copying package lists...gpgv: Signature made Wed 23 Apr 2008 07:22:50 PM ICT using DSA key ID FBB75451
gpgv: Good signature from "Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>"
Reading Package Indexes... Done
Writing new source list
Source list entries for this disc are:
deb cdrom:[Ubuntu-Server 8.04 _Hardy Heron_ - Release i386 (20080423.2)]/ hardy main restricted
Unmounting CD-ROM...
Repeat this process for the rest of the CDs in your set.
root@xxx:~#

My Examples is for Hardy Heron, but the same with all Ubuntu Version

And then

root@xxx:~# apt-get install ssh

for install both ssh client and server.

After that, set static IP address for your Ubuntu, also can assign APIPA address, that's no problem. But I wonder your state that you can ping your Ubuntu from Windows XP. Can you put that ping command here, then I will help you make sure you can access to Ubuntu ssh server via putty or WinSCP

If you need a link for package:

http://us.archive.ubuntu.com/ubuntu/pool/main/o/openssh/openssh-client_5.1p1-6ubuntu1_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/o/openssh/openssh-server_5.1p1-6ubuntu1_i386.deb

(for x32 version), for x64 you browse this folder and get corresponding package (amd64)

Then use dpkg -i  openssh-client_5.1p1-6ubuntu1_i386.deb
and dpkg -i openssh-server_5.1p1-6ubuntu1_i386.deb

Hope this help
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thetmanvnCommented:
Sorry, after apt-cdrom add and before apt-get install ssh, you must issue apt-get update
0
gleibyAuthor Commented:
ok, here is my "solution." Since I could not get the Ubuntu Desktop to work, I loaded and installed Ubuntu Sever. I am pleased to say I have attached from my Windows XP to my Ubuntu Server using WinSCP.

To those who followed me from my other post, i will go over the prior steps, then either announce "Success!" or ask for more help.

Finally, I have learned more about Linux (Ubuntu in particular) in the last three days than the rest of my life. Thak you for the help
0
thetmanvnCommented:
Cheers, have a new nice week then, gleiby
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.