Solved

Linux VPN with pptp

Posted on 2009-07-03
8
478 Views
Last Modified: 2012-05-07
Hello!
I need to configure a Linux VPN server PPTP based (I know... OpenVPN is better, but my boss wants pptp).

I configured my pptp-options as attached to this message, but when I try to connect from a Windows client I get a 732 error code: "Your computer and the remote computer could not agree on PPP control protocols".

If I disable data encryption in Windows all works fine, but I need encryption... what am I missing?

Thank you guys in advantage!
0
Comment
Question by:phoenix128
  • 4
  • 3
8 Comments
 
LVL 9

Expert Comment

by:jfer0x01
ID: 24772578
Hi,

have you established MSCHAPv2 on both ends the authentication protocol?

This it probably why it fails, are you running Vista? MSChapv1 is no longer supported, use MSChapv2 in any case

found an example in http://74.125.47.132/search?q=cache:0-9BZrliVdIJ:www.linux-bsd-central.com/index.php/content/view/8/+linux+vpn+pptp+732&cd=2&hl=en&ct=clnk&gl=us&client=firefox-a, the site was down so i used google cache


/usr/local/etc/pptpd.conf
----------------------------------------------------------------
debug
nobsdcomp
proxyarp
localip 172.16.0.4
remoteip 172.16.0.150-155
pidfile /var/run/pptpd.pid
+chapms-v2
mppe-40
mppe-128
mppe-stateless



/etc/ppp/ppp.conf
enable MSChapV2
enable mppe
0
 

Author Comment

by:phoenix128
ID: 24772624
Same problem here.
I tried both with Vista and XP... with Vista I have an error code 732 and with XP 741.

Any idea?
0
 
LVL 9

Expert Comment

by:jfer0x01
ID: 24775026
You verified the authentication protocols as MSChapv2 on both ends correct>?


0
New My Cloud Pro Series - organize everything!

With space to keep virtually everything, the My Cloud Pro Series offers your team the network storage to edit, save and share production files from anywhere with an internet connection. Compatible with both Mac and PC, you're able to protect your content regardless of OS.

 

Author Comment

by:phoenix128
ID: 24780525
Yes I did, I'm connecting from XP and I suppose it is by default and it is enabled on Linux as you can see from my configuration file.

0
 
LVL 9

Expert Comment

by:jfer0x01
ID: 24780568
Hi, can you post your config file?
0
 

Accepted Solution

by:
phoenix128 earned 0 total points
ID: 24780609
I'm sorry guys, I just misspelled "option" in "/etc/pptpd.conf".
Thank you anyway.
0
 
LVL 9

Expert Comment

by:jfer0x01
ID: 24781245
Hello, I consider points should be awarded, considering I was the only person who attended to your issue,

Also,

Although, you solved your issue, it was after recommending where to look

Jfer
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now