KB961143 install fails

I have SBS running with all updates installed - except KB961143 which refuses to install.

Tthe KB961143.log file contains the following:
1.485: 2009/07/03 11:18:13.421 (local)
1.547: C:\WINDOWS\SoftwareDistribution\Download\323d85ff57a6f2eb856a208cd2ac95a6\update\update.exe (version 6.3.14.0)
1.563: Failed To Enable SE_SHUTDOWN_PRIVILEGE
1.578: Hotfix started with following command line: -q /Z /ParentInfo:f13bd58a4c3a0649b27df9bd26903d19
1.578: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
1.578:  SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\KB961143 is not Present
1.578: Condition succeeded for section ChkInstalled.Section in Line 1 of PreRequisite
1.906: Return Value From IsSbs2003 = 1
1.906: IsSbs2003 returned value( 0x1 ) which is Equal To 0x1
1.906: Condition succeeded for section ChkSBS.Section in Line 2 of PreRequisite
1.906: ServicePackNumber is Present
1.906: SOFTWARE\Microsoft\SmallBusinessServer\ServicePackNumber is Equal To Specified Value
1.906: Condition succeeded for section ChkSBSSP.Section in Line 3 of PreRequisite
1.906:  SOFTWARE\Microsoft\.NETFramework\policy\v2.0 is Present
1.906: Condition succeeded for section ChkCLR20.Section in Line 4 of PreRequisite
1.906: LangID is Present
1.906: SOFTWARE\Microsoft\SmallBusinessServer\LangID is Equal To Specified Value
1.906: Condition succeeded for section ChkLang.Section in Line 5 of PreRequisite
10.110: In Function TestVolatileFlag, line 11825, RegOpenKeyEx failed with error 0x2
10.110: In Function TestVolatileFlag, line 11857, RegOpenKeyEx failed with error 0x2
10.110: ---- Old Information In The Registry ------
10.110: Source:C:\Config.Msi\28f2220.rbf (11.0.6361.0)
10.110: Destination:
10.110: ---- New Information In The Registry ------
10.110: Source:C:\Config.Msi\28f2220.rbf (11.0.6361.0)
10.110: Destination:
10.110: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
10.110: SetProductTypes: InfProductBuildType=BuildType.IL
10.110: SetAltOsLoaderPath: No section uses DirId 65701; done.
10.141: DoInstallation: FetchSourceURL for c:\windows\softwaredistribution\download\323d85ff57a6f2eb856a208cd2ac95a6\update\update.inf failed
10.141: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB961143$
10.141: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed: 0xe0000102
10.141: BuildCabinetManifest: update.url absent
10.156: Starting AnalyzeComponents
10.172: AnalyzePhaseZero used 0 ticks
10.172: OEM file scan used 0 ticks
10.172: AnalyzePhaseOne: used 0 ticks
10.172: AnalyzeComponents: Hotpatch analysis disabled; skipping.
10.172: AnalyzeComponents: Hotpatching is disabled.
10.266: AnalyzePhaseTwo used 94 ticks
10.266: AnalyzePhaseThree used 0 ticks
10.266: AnalyzePhaseFive used 0 ticks
10.266: AnalyzePhaseSix used 0 ticks
10.266: AnalyzeComponents used 94 ticks
10.266: Downloading 0 files
10.266: bPatchMode = FALSE
10.266: Inventory complete: ReturnStatus=0, 125 ticks
10.266: Num Ticks for invent : 125
10.266: Allocation size of drive C: is 512 bytes, free space = 8308111872 bytes
10.281: AnalyzeDiskUsage:  Skipping EstimateDiskUsageForUninstall.
10.281: Drive C: free 7923MB req: 5MB w/uninstall: NOT CALCULATED.
10.281: CabinetBuild complete
10.281: Num Ticks for Cabinet build : 15
10.281: DynamicStrings section not defined or empty.
10.281: FileInUse:: Detection disabled.
11.281: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed: 0xe0000102
11.313: Num Ticks for Backup : 1032
11.735: Num Ticks for creating uninst inf : 422
11.766: Registering Uninstall Program for -> KB961143, KB961143 , 0x0
11.766: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed: 0xe0000102
11.813: Copied file:  C:\WINDOWS\system32\spmsg.dll
11.875: PFE2: Not avoiding Per File Exceptions.
11.953: GetCatVersion:  Failed to retrieve version information from C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\KB961143.cat with error 0x57
12.078: Copied file:  C:\WINDOWS\$NtUninstallKB961143$\spuninst\SetAuthProviders.exe
12.156: DoInstallation: Installing assemblies with source root path: c:\windows\softwaredistribution\download\323d85ff57a6f2eb856a208cd2ac95a6\
12.156: Num Ticks for Copying files : 421
12.156: Num Ticks for Reg update and deleting 0 size files : 0      
12.156: Starting process:  SetAuthProviders.exe /install
12.156: Working directory:  C:\WINDOWS\$NtUninstallKB961143$\spuninst
17.063:  Return Code = 4294967295
17.063: DoInstallation:RunInfProcesses for ProcessesToRun Failed
17.063: KB961143 Setup encountered an error:  An error in updating your system has occurred.
17.078: An error in updating your system has occurred.

Select 'OK' to undo the changes that have been made.
17.078: Starting process:  C:\WINDOWS\$NtUninstallKB961143$\spuninst\spuninst.exe /~ -q -z
18.672: Software Update Rollback has completed successfully.  The original error message was:  0x1


Does anyone know how to overcome this install error?

Thanks
ATOCONSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
A previous EE quoestion suggests to ignore the patch:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_24412514.html
Are you experiencing this particular as outlined in the Fix?
http://support.microsoft.com/kb/961143
If not - then don't bother installing the patch.
0
ATOCONSAuthor Commented:
I get repeatedly asked for credentials and tyen get a 401.1 error.
This is from a client computer not from the server itself.
0
Alan HardistyCo-OwnerCommented:
Have you got .NET framework 2.0 installed on the server? (extract from the KB Article)
Prerequisites:
You must have .NET Framework 2.0 installed before you apply this update.
0
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

ATOCONSAuthor Commented:
I have indeed
0
Alan HardistyCo-OwnerCommented:
Is the client using IE8 to browse?
If so, please add the companyweb to the Local Intranet Site (IE, Tools, Internet Options, Scurity Tab, Local Intranet, Sites, Advanced - Add http://companyweb.
Does that resolve the problem?
If it does, please flag the update to be ignored from Windows Update.
0
ATOCONSAuthor Commented:
No it doesn't fix it.
I get a 401.1 from the browser on the server itself, 403 from the browser on another computer on the LAN
0
Alan HardistyCo-OwnerCommented:
Have you updated to Sharepoint 3.0?
If so, can you have a run through the following article and report back (particularly the last post):
http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windows.server.sbs&tid=d071db23-37bd-40ff-b0c8-c62f772ab0fe&cat=&lang=&cr=&sloc=&p=1
0
ATOCONSAuthor Commented:
I haven't gone to 3.
I wanted to get it working as is rather than introduce a whole new complication.
However if it will be easier to fix by upgrading to 3 first, then I'm OK to do that...?
0
Alan HardistyCo-OwnerCommented:
Not suggesting that you upgrade - just enquiring if you have already.
Everything points to having moved Sharepoint's location.  Do you recall having moved it? (Not sure how or why).
0
ATOCONSAuthor Commented:
If you mean the home directory - the companyweb home directory is moved yes. It's on the bigger D: drive as I was running out of space on the system partition.
I thought it had been working since then and I copied the permissions etc.

I can run through all the permissions against the old directory (that's still there) - or is it some other aspect of moving it that you're thinking of?
0
Alan HardistyCo-OwnerCommented:
I think the move has upset the default location and somewhere in the system it is looking for a file that has been moved.  Are you able to move it back then try the update again?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ATOCONSAuthor Commented:
I'll give it a go
0
ATOCONSAuthor Commented:
Still get a 403
0
Alan HardistyCo-OwnerCommented:
Have you moved it back and installed KB961143 successfully?
0
ATOCONSAuthor Commented:
I have - and now instead of a 401.1 I'm getting 403
0
Alan HardistyCo-OwnerCommented:
Okay - so the patch has been applied.
Separate problem now.
I think the best course of action now is to remove and reinstall the companyweb site by following the attached document which should resolve this issue:
http://support.microsoft.com/kb/829114 
0
ATOCONSAuthor Commented:
That will have to wait until later this evening.
Many thanks for the help so far!
0
Alan HardistyCo-OwnerCommented:
No problems - I am not surprised you are not rushing head-long into that one!
0
ATOCONSAuthor Commented:
Yes I'm going to read that one through a couple of times before I start on it, and make sure I can give it due attention!
0
ATOCONSAuthor Commented:
Well that was interesting!
It reinstalled in D:\inetpub!
So I searched the registry, found some keys set to point there and changed them to C:\inetpub\companyweb and moved the directory from D: to C:. Also changed the home directory in the SharepointCentralAdmin site properties.
Then the machine had SP3 waiting from Windows Update so I let that install.

It works! Many many thanks sir.
I had already done the reinstall but clearly it was the reg keys that made it reinstall in the wrong place.

Thanks again for all your help
0
ATOCONSAuthor Commented:
A couple of things there so I've split the points across them because one wouldn't have worked without the other
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.