Sharing \\Machine\C$ with domain

hi all,

Im trying to use psloggedon to find out which users are logged on which machines

and i get ERROR opening HKEY_USERS on \\machine all the time

i have checked:
file and printer sharing is on under the network card
under services: Server & Remote Registry are on and set to start auto

i have read that pslogged on needs access to the computers \\machine\C$

so im trying to do that

if im on a computer on the network by default should i be able to type from my machine

\\machine1 and then machine 1s share will come up?
because i  get windows error and diagnose problem etc
but i can ping the other machine fine

i have tried right clicking the c drive choosing share then permissions to set to everyone it says this has been set for administration services the permissions cannot be set

what can i do if anything?

Cheers
LVL 1
awilderbeastAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jasfoutCommented:
>if im on a computer on the network by default should i be able to type from my machine
>\\machine1 and then machine 1s share will come up?

yes but the C$ share will not show up because the $ makes it hidden when creating the share
however \\machine1\C$ should display contents of the share. If not then doublecheck your share settings...you might try sharing a test folder initially before sharing the whole drive just to make everything is in order
Firewall maybe?
Try removing the share then run through the File and Printer Sharing Wizard then try sharing again.
0
Nat WallisTechnical Services ManagerCommented:
are you just putting in \\computer name ?

or are you putting in \\computer name\c$ - because that is what it should be.

are you using simple file sharing?
can you view hidden folders?

one other thing you might need to look at is the following although I am not sure if this will apply for your requirements exactly:

http://www.experts-exchange.com/Networking/Windows_Networking/Q_23318285.html - accepted solution on this at the bottom

ControlPanel --> Administrative Tools --> Local Security Policy
The Local Security Settings dialog should pop up.
Security Settings --> Local Policies --> Security Options --> Network Security: Sharing and security model for local accounts
Double click this and Set it to "Classic - local users authenticate as themselves"
0
DatedmanCommented:
in a command window you should be able to type:

net view \\machinename

And get a reply that either has a list of shares or "No entries in list."  If you can do that you can then type start \\machinename\c$
but if not it could be a number of things including File Sharing not turned on, firewall issues, etc.  

As stated above c$ doesn't show in the list but if things are set up to share then C$ should be accessible.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

DatedmanCommented:
Oh and make sure you are using an account name/password that exists on the target machine and which has admin rights on that machine.  
0
awilderbeastAuthor Commented:
thanks for the assistance, ive tried naughtynat's method and have had no success
and i have been putting \\computername\c$ in

and the account that im using is an adminstrator on the domain

Cheers
Microsoft Windows [Version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.
 
C:\Users\ME>nslookup \\ITRoom
Name:    ITRoom.domain.local
Address:  192.168.172.8
 
 
C:\Users\ME>ping 192.168.172.8
 
Pinging 192.168.172.8 with 32 bytes of data:
Reply from 192.168.172.8: bytes=32 time=52ms TTL=126
 
Ping statistics for 192.168.172.8:
    Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 52ms, Maximum = 52ms, Average = 52ms
Control-C
^C
C:\Users\ME>net view \\ITRoom
System error 53 has occurred.
 
The network path was not found.

Open in new window

0
DatedmanCommented:
What does net view show?

0
awilderbeastAuthor Commented:
see above in the code

C:\Users\ME>net view \\ITRoom
System error 53 has occurred.
 
The network path was not found.
0
DatedmanCommented:
Ah sorry missed that.  OK then very likely either File Sharing is not enabled on ITRoom or there is a firewall issue.
0
awilderbeastAuthor Commented:
file sharing is enabled as far as i can tell
under network card properties it is checked, under services it is started
i am remote desktoping to the ITRoom machine also, is there any specific port file sharing uses?
0
DatedmanCommented:
When you are RDP'd into ITRoom please open a command prompt in that RDP session and type:

net view \\ITRoom
dir \\ITRoom\c$

0
awilderbeastAuthor Commented:
heres the results
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.
 
C:\WINDOWS>net view \\ITRoom
There are no entries in the list.
 
 
C:\WINDOWS>dir \\ITRoom\c$
 Volume in drive \\ITRoom\c$ has no label.
 Volume Serial Number is FC7F-5487
 
 Directory of \\ITRoom\c$
 
04/12/2007  13:00    <DIR>          38b59c14833d27217f
07/06/2007  13:55                 0 AUTOEXEC.BAT
03/02/2009  12:15    <DIR>          b02693d6e25ac1a9ff
07/06/2007  13:55                 0 CONFIG.SYS
02/04/2008  13:09    <DIR>          DELL
27/04/2009  10:06    <DIR>          Documents and Settings
07/06/2007  15:26    <DIR>          drvrtmp
07/08/2007  13:10    <DIR>          logs
29/06/2009  10:32    <DIR>          Program Files
16/06/2009  15:16    <DIR>          WINDOWS
               2 File(s)              0 bytes
               8 Dir(s)  31,434,477,568 bytes free
 
C:\WINDOWS>

Open in new window

0
DatedmanCommented:
OK so it's working from that machine so we know the share is there...

The other machine is a domain member?  Are you logged in as a domain admin?  ...hopefully the same one as you're using to log in for RDP to simplify things...

Then if you can PING ITRoom successfully from the other machine and you still can't see entries in NET VIEW it could be a firewall issue on either machine.  Does either machine have a firewall enabled?
0
awilderbeastAuthor Commented:
yeah both machines are domain members, and i am a admin on the domain and am logged into both computers with the same credientials

i can ping ITRoom yet no NET VIEW, both machines only have windows file sharing on

ok just tested something out the machine i was on was connected to the other machine via VPN

so i rdp'd to a machine that was on the same LAN as the ITRoom and i could open \\ITRoom

and i typed in my machines name from the ITRoom and i could open the share on my machine
so its my machine going to ITRoom that isnt working
0
DatedmanCommented:
Doesn't matter if your machine has file sharing on.

Could be firewall on your machine.  In Control Panel (classic view) under Windows Firewall is it turned on?  Or are you using a Symantec or McAfee product or whatever that has firewall elements?
0
awilderbeastAuthor Commented:
yeah im using windows firewall, file and printer sharing is ticked to be allowed through
no other firewall installed on this machine

its a vista machine this one, so is there any additional services need selecting?
0
DatedmanCommented:
Turn off the firewall and try it.  If it works (may  take a few minutes or you could even have to reconnect VPN) then that's the problem...if not it could still be a compication but try turning it off to see if that's the *only* problem.
0
DatedmanCommented:
BTW if you're RDP'd in, you should see your own drives and the server's drives in My Computer in the RDP session so you can move stuff back and forth freely so no real need for \\ITRoom\C$. :)
0
awilderbeastAuthor Commented:
turned it off, still cant get to it :|

yeah i can use an of the servers, but im not trying to share folders from one pc to another

my first post says that its for the psloggedon tool

the tool needs access to \\computername\c$ to work

so im trying to get access to \\ITRoom\c$ so i can use the tool on that

Cheers
0
DatedmanCommented:
Ah yes, sorry, not familiar with psloggedon.   Please post ipconfig /all from your machine while logged into the VPN.

No other firewall?  Symantec Endpoint Protection or Norton 360 etc?
0
awilderbeastAuthor Commented:
what i did was when my vista machine couldnt connect to the share at the other end of the LAN, i did the windows diagnose and it said

"The Machine ITRoom is viewable but cannot be contacted it may be behind a firewall etc, the firewall at this end is ok, please make sure that the other end has port 445 open"

so its the ITRoom end by the looks.

what you trying to gather from the ipconfig?

this lan is on the 192.168.10.0/24 network and the ITRoom is on 192.168.20.10/24
0
DatedmanCommented:
What's the DNS suffix on the VPN connect?  What's WINS etc.?

Unlikely the other machine's firewall is relevant if you can see C$ from other machines on the same subnet but not this one.   Hmmm what kind of VPN is it?  Running ISA Server or something on the VPN server?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
awilderbeastAuthor Commented:
dns is handled by the servers on each local link
wins again by the local servers

the vpns are handle by my cisco 877's using DMVPN, i think there maybe be a problem with allowing ports over a lan with them, im going to do some research and find out

thanks for your help
0
awilderbeastAuthor Commented:
thanks for your help bud
0
DatedmanCommented:
I think it's the cisco setup, yes.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.