Wordpress WP-Cache plugin - Won't work with Zeus server??

Hey guys.

I find my Wordpress driven site rather slow and am trying to do whatever I can to increase its speed. I found a plugin called WP-Cache which should help with load times. However, after I have activated the plugin, I keep getting an error message:

Warning: sem_get() [function.sem-get]: failed for key 0x152b: Permission denied in /primus/users/u84/raoc/public_html/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 98

I've tried finding a solution to this online but no luck. I'm not entirely sure what the issue is. I've looked into the file permission settings and that shouldn't be the problem.

The only thing I can think of is that my site is running on a Zeus web server so there may be some incapability issues. Anyway, if anyone has any suggestions, I can really use the help. Thanks!

P.S. You can find the site here: www.operationlifesaver.ca
Picture-1.png
LVL 1
AdamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

razor19Commented:
Hey there -

Try opening wp-cache config file - in the /wp-content/ folder

Look for the line:
//$use_flock = true; //..

Remove the slashes from the front:
$use_flock = true;

See if that works. :)

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
razor19Commented:
Make sure you keep the rest of the line (the // text....) after the semi-colon.
0
AdamAuthor Commented:
Thanks for the reply razor19.

Just to clarify, do you mean the wp-cache-config.php file that's in the /wp-content/ folder or the wp-cache.php file which is in the /wp-content/plugins/wp-cache/ folder.

Either way, I couldn't seem to find $use_flock = true;

I've attached the code from the wp-cache-config.php below if you want to take a look. Not sure if I'm missing something. Let me know if you would like to see the folder from the wp-cache plugin folder.

Thanks for the help!

<?php
/*
WP-Cache Config Sample File
 
See wp-cache.php for author details.
*/
 
$cache_enabled = false; //Added by WP-Cache Manager
$cache_max_time = 3600; //in seconds
//$use_flock = true; // Set it tru or false if you know what to use
$cache_path = ABSPATH . 'wp-content/cache/';
$file_prefix = 'wp-cache-';
 
// Array of files that have 'wp-' but should still be cached 
$cache_acceptable_files = array( 'wp-atom.php', 'wp-comments-popup.php', 'wp-commentsrss2.php', 'wp-links-opml.php', 'wp-locations.php', 'wp-rdf.php', 'wp-rss.php', 'wp-rss2.php');
 
$cache_rejected_uri = array('wp-');
$cache_rejected_user_agent = array ( 0 => 'bot', 1 => 'ia_archive', 2 => 'slurp', 3 => 'crawl', 4 => 'spider');
 
// Just modify it if you have conflicts with semaphores
$sem_id = 5419;
 
if ( '/' != substr($cache_path, -1)) {
	$cache_path .= '/';
}
 
?>

Open in new window

0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

AdamAuthor Commented:
And obviously - I'm aware of this line:

$cache_enabled = false;

I have to have keep it disabled or I will keep getting that error message :)

0
razor19Commented:
I meant the wp-cache-config file.

It's line 10 in the code you posted. :)

//$use_flock = true; // Set it tru or false if you know what to use

Change to:

$use_flock = true; // Set it tru or false if you know what to use
0
AdamAuthor Commented:
Wow...I can't believe I missed that! Strange though, I even did a search for it and it didn't show up.

Anyway, that seems to have done the trick! Thanks a bunch.

I hope you don't mind me asking you another question but do you know anything about the WP-Super Cache plugin? I was originally hoping to use that one but I was having issues activating the plugin as well. I have read that if you don't have Apache that it probably won't work.

Not sure if you know anything about it - I just figured it wouldn't hurt to ask. Either way, I will reward you the points.

Thanks again.


0
razor19Commented:
Hey Furio - No problem, and LOL  don't worry about missing it, that happens to me all the time. What editor do you use? My editor won't show commented code when I search for it - even though it says it will on their website. Strange. :)

I've heard that the Super-Cache plugin is better, but you're right, i've also heard it doesn't play well with anything other then Apache. Personally, though, I don't have any expierience with it - i've always just used the WP-Cache. I've also heard it conflicts with way more "standard" plugins then WP-Cache.

Cheers dude!

0
AdamAuthor Commented:
Thanks again for the help razor19. I really appreciate it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.