Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2007 - No email since adding SMTP service to SSL certificate

Posted on 2009-07-04
3
Medium Priority
?
1,012 Views
Last Modified: 2012-05-07
I recently needed to add the SMTP service to our SSL certificate for use with OCS2007.
Now none of the email is getting through the Hub Transport. All roles are on the one server (we dont have an Edge Transport Server). I rebooted the server only to find ALL services are now assigned to the SSL certificate. The self signed cert is still there with the SMPT, IIS servides applied.
The SSL cert wal already applied to the IIS sites.
Running the Exchange analyser, it initially comes up with the Hub Trnasport role installed, but then comes up saying it cant find the Hub Trnasport when checking the queues. Have I missed a step somewhere?
Without building a new Hub Transport server elsewhere, what can I do. I can remove the certificates as Exchange complains that some services will not work . (Fair enough)
Thoughts appreciated...
0
Comment
Question by:riskyflier
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 2

Accepted Solution

by:
William Yang earned 1500 total points
ID: 24777091
Did you get any 12014 error in event log?

If yes, it means the FQDN on SMTP receive connector does not match the one on the self-cert certificate.

You can try to fix it by:
1. check the FQDN on the receive connector. Make sure it is not configured to external FQDN.

2. Use the powershell command below to renew the self-cert and assign it for SMTP service.
New-ExchangeCertificate -SubjectName "CN=<server internal FQDN>" | Enable-ExchangeCertificate -Services "SMTP"
0
 

Author Comment

by:riskyflier
ID: 24777486
No such errors whatsoever in the event log. But I'll check the FQDN. From what I remember from yesterday it DID have the FQDN (external) configured on the receive connector.
Will let you know. Thx
0
 

Author Comment

by:riskyflier
ID: 24783974
Well, looking at the SAN certificate, it states invalid when running the Get-ExchangeCert command.
I think I'll follow your advise to renew the self cert...

Will let you know how it pans out.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question