Solved

Network performance very slow

Posted on 2009-07-04
7
297 Views
Last Modified: 2012-05-07
I backup my data from my my HP 8710w laptop using Second Copy. The laptop has a Gigabit NIC. OS is Windows Vista Business.
At the office the Second Copy & the NIC perform at Gigagbit speed.
When I get home the same backup takes 10 times as long  (even though I have a Gigabit Netgear switch).

The only way I have been able to speed up the backup is to downgrade the NIC driver to operate at 100MBps Full Duplex.
What's going on? How do I fix it?
0
Comment
Question by:nadish
  • 4
  • 2
7 Comments
 
LVL 8

Expert Comment

by:JT92677
ID: 24777747
You left out a description of the device on the other side of your Netgear switch.  Is it hooked up for 1000 mbit ?

If not, the switch is having to do speed switching, packet store and forward from devices operating at different speeds is not a great way to run a switch.

At the office, everything may be Gigabit compatible, but at home, maybe not.

Aside from the laptop, what else is hooked to your Gigabit Netgear switch? Or better, what is the device handling your backup storage?

Jeff
0
 

Author Comment

by:nadish
ID: 24778542
Jeff,
Good questions. The Switch is a Netgear GS116 (which is a gigabit switch). The destination device is a 100Mbps server.
My  HP 8710w laptop is normally set to Auto-negotiation. But at home this results in Second Copy times in the HOURS (terrible performance).
Only by switching to 100Mbps Full Duplex can I get a reasonable performance.
So maybe the better question is; Why does auto-nogtiation fail so miserably in this situation?
0
 
LVL 8

Accepted Solution

by:
JT92677 earned 250 total points
ID: 24778661
From Cisco troubleshooting:

"Duplex mismatch is a situation in which the switch operates at full-duplex and the connected device operates at half-duplex, or the other way around. The result of a duplex mismatch is extremely slow performance, intermittent connectivity, and loss of connection. Other possible causes of data link errors at full-duplex are bad cables, a faulty switch port, or NIC software or hardware issues."

For 1000 Mbit devices, it seems that you must use auto-negotiate to avoid some of the problems.  The switch will run this way by default, so here's what I'd try next:

Put your laptop back in auto-negotiate mode. Unplug the Cat-5 or Cat-6 cable that you're using, power off the switch, and power it back on. The switch does a form of basic "routing" of sorts, based on MAC addresses, so once it figures out how to hook one port to another, it kind of sticks that way.

When the switch is running, plug in the laptop (that is in auto-negotiate mode).

If this doesn't work, it might be the cable is not good (giving you various communications errors), or the driver in the laptop is not working that well, or the NIC driver on the 100 Mbps server.

Try the switch reset, then plug in laptop with autonegotiate ON, and hopefully the 100 Mbps server setting is also auto-negotiate, and last, a different ethernet cable.

Each time you make a change, "reboot" the switch (pull the power for a few seconds).

Jeff
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:nadish
ID: 24779768
Jeff,
Your comments really got me thinking. So I did some tests with a 262Mb file through Windows Explorer.

T's machine to Server : 50 secs
Server to T's machine : 30 secs


HP 8710w to Server : Estimated by Win Explorer at 9 minutes (gave up after 2 minutes)
Server to HP 8710w : 37 secs

So it would seem that upload to the server is the ONLY issue.
Following your procedures with auto-negotiate on + a new cable + switch reboot didnt improve things.

What do above tests tell you?
Bloody mystery to me!
0
 

Author Comment

by:nadish
ID: 24779776
I thought I'd one more test with Auto-negotiate off and NIC set to 100Mbps Full Duplex

HP 8710w to Server : 40 secs

So no question that auto-negotiate is the culprit.
BUT WHY???
0
 
LVL 5

Expert Comment

by:KETTANEH
ID: 24856891
what is your switch at home ?? the model ?
0
 

Author Closing Comment

by:nadish
ID: 31599753
I found out why the performance was slow. But I still have to downgrade settings manually to 100bps to get reasobale performance.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question