Windows 7 requires IPv6 for Homegroup

I've set up Windows 7 on two of my computers. The main computer hosts 6 external hard drives that I've added to the libraries to share in the homegroup on that computer.

I have a laptop that I want to share it with. It's set up wirelessly to connect to the homegroup. In the network sharing page, it displays my wireless connection and says I'm eligible to join a homegroup. When I click on the link and input the homegroup password, I get the error message below:

"Your network connection must have IPv6 enabled to create or join a homegroup. To enable IPv6, start the HomeGroup troubleshooter."

I've done that a dozen times with same result. Nada.

I've checked the network settings and both IPv4 and IPv6 are enabled.

Any idea how to correct this so I can join the homegroup?

Thanks

David
drperdewAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IanThCommented:
does your wireless router have ipv6 I doubt it thats your problem

see here
http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/4c0770bb-247a-46d6-8267-c3715410d98f
0
tenaj-207Commented:
Disable IPv6 on the server and any computers that are having the problem.

To do this click on Start and in the "Search programs and files" box type in ncpa.cpl.  This opens your network connections right click on your Ethernet or wireless connection, whichever you use to connect to the Internet, and choose properties.  Then uncheck the box next to Internet Protocol Version 6.  Finish by clicking on Ok.  Then reboot and retry.
Disable-IPv6.png
0
drperdewAuthor Commented:
I'm sorry - would that be Disabling IPv6. The error message says we need to Enable Ipv6.

I'm confused.

dp
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

IanThCommented:
you didn't read my link did you you cant use homegroup without ip v6
q:
IPv6 protocol installed by Windows 7 beta  to network adaptor, can cause some problems with network connectivity if is used router that does not support IPv6 or have problems working if IPv6 protocol is enabled.

You can disable IPv6 protocol to escape from these problems, but you must know, that disabling IPv6 protocol on windows 7 beta, prevents you from creating of home groups.
unq:

even if its enabled on your laptop its not on your wireless adapter that your using when setting up homegroup

it will be your router doesn't support ip v6 or its not setup and as your laptops are using your wireless router for your lan then your wireless lan must use ip v6 to allow homegroup across your wifi between your laptops

to see what I mean connect both laptops through a ip v6 switch with network cables and homegroup will work
0
drperdewAuthor Commented:
I did read the post, but I didn't see a solution. Just a problem.

Is there a solution? Is the solution to create a different type of network - ie, the old workgroup. Looking for suggestions.

dp
0
tenaj-207Commented:
Guess I'm wrong about turning off IPv6.  Clearly you must have it in order for a homegroup to work.  However, in working within an office environment I've found that IPv6 can cause problems, but that doesn't apply here.

Regardless I think that IanTh is saying that you need a new wireless router that supports IPv6.  But before you go out and buy a new router tell us what type of router you have.  Let's confirm that your current router doesn't support IPv6.

-Jeff
0
drperdewAuthor Commented:
0
IanThCommented:
I cannot find ipv6 on the WNDR3300 anywhere but I have found that currently ipv6 is tunnelled over ipv4
have you spoken to netgear tech support
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
drperdewAuthor Commented:
No - I haven't spoken to them. I'll go to their support forum and ask the question too.

Thanks

David
0
drperdewAuthor Commented:
Forgot. Other ideas: Is the solution to create a different type of network - ie, the old workgroup. Looking for suggestions.

d
0
IanThCommented:
test it by a cross over lead between the laptops
0
cantorisCommented:
I agree with the thoughts on the router.
If a crossover or IPv6-capable router still doesn't let it work, try moving IPv6 above IPv4 in the binding order (Manage Network Adapters screen - press Alt to bring up the menu bar - Advanced - Advanced Settings).
0
tinchoteCommented:
The answers here seem to overlook the fact that in W7 the term  "homegroup" is specific for a new networking way the operating system brings. With Ipv6 off, W7 still conects to good old fashioned workgroups.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.