Please make sure SQL Server Agent service is running on the database server

Trying to do a fresh install of vmware's vcenter 4 and I get the following message when entering the db credentials. I've tried both sql and windows authentication, same thing. Trying this on SQL 2005.

I checked the sql server and the agent is definitely running. Maybe there is something I'm missing.

Anyone know what the problem is?

Thanks!
vcenter.JPG
gregca80Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nasserdCommented:
From the screenshot, perhaps its the DSN you're using.

Or, how SQL Server 2005, by default, disables remote connectivity.  You'd have to get into the SQL Server configs to modify how and which protocols are connectable remotely.
0
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Open Services.msc and check whether SQL Server Agent Service is started.
Right Click on that service and choose properties, Change the Startup type to Automatic and then start it.

Its done and you wont face this issue later on.
0
gregca80Author Commented:
I've tried setting up multiple versions of the DSN with different versions of the sql native client, same thing.

The sql server agent is already running. That's the first thing I checked, it's already set to automatic.

Still stuck :(
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Do you have a 64 bit machine with you...

If you have 64 bit machine, then your 64 bit DSN will be in

c:\windows\system32\odbcad.exe

And your 32 bit version of DSN in the path below

c:\windows\sysWOW64\odbcad32.exe

Kindly check whether you are using the appropriate DSN versions.
0
gregca80Author Commented:
I downloaded the install media again, and now it's working. Must have been a bug.
0
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Kindly explain what you meant by install media so that it can be helpful for others who might be viewing this question later on.

Also close this question if the problem is resolved.
0
gregca80Author Commented:
i downloaded the vcenter software again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.