DNS Stop Responding after one line was added

Posted on 2009-07-05
Last Modified: 2012-05-07
My wuestion is base on the code below. The DNS server is workng now But I do not understand why.Can somebody outhere give or guide to an explanation what was tha I did to make it work?
Is there any tool to check the systaxtof a DNS file? why it have to be so hard to update a namaed file witout messit up?
; Notes
$TTL	14400
@	IN  	SOA          (
		; Serial Number YYYYMMDDVV
			; Refresh in
			; Retry in
			; Expire in 
			; Minimum TTL of
		IN	NS	Server1
			NS	Server2
 		IN      A       <IP web site hosted out side premises>
www		IN	CNAME	@
Server1		IN	A	<server IP>
Server2		IN	A	<server IP>
; A records and CNAMEs
name		IN	A	ip number 
name		IN	A	ip number 
name		IN	A	ip number 
name		IN	A	ip number 
This was working fine. Now I included the line on; A records and CNMES as:
kbp           IN      A       <IP hostess outside our premises>
And the DNS stopped working (the idea here was that anyone can type n the address browse and will go to the right web site. It was just a redirection
Now After many changes and many questions the line that worked was:   IN   A          < IP hostess outside our premises>
kbp                 IN   CNAME      Forentdomain,com.
So the dns dis not work with
; A records and CNAMEs
name		IN	A	ip number 
name		IN	A	ip number 
name		IN	A	ip number 
name		IN	A	ip number 
kbp         IN    A       <IP hostess outside our premises>
But it worked now with:
name		IN	A	ip number 
name		IN	A	ip number 
name		IN	A	ip number 
name		IN	A	ip number   IN   A  < IP hostess outside our premises>
kbp                 IN   CNAME
====why the  works on theeft side of the file? it should not be at the right side?????======

Open in new window

Question by:Jorge-123
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 30

Accepted Solution

Kerem ERSOY earned 500 total points
ID: 24779616
there are several problems with your SOA record, The commented areas should have some values such as:

You dont need this line:

Please modify the values such as these:

$TTL    7200
@       IN      SOA          (
                       2009070401  ; Serial Number YYYYMMDDVV
                       3600              ; Refresh in
                       600                ; Retry in
                       1209600        ; Exipires
                        7200             ; Minimum TTL of

For acceptable values for these values please see RFC-1912 and RFC-2308.

There's no problem with the definition:

kbp           IN      A       <IP hostess outside our premises>

It should normally work but I guess the problems with SOA has prevented it.

For a detailed problem record see your /var/log/messages file.


Author Comment

ID: 24781033
Thanks. I will look for the log files also I will look for the RFC.
When DNS stop responding , the NAMED file started fine but none of the names on the was resolving ( ????) .
Is there a utilility that I can test the named  or the databases inside it  that they are well written ? or theore is a way to test this file before puttingit on a live system?
just plain curuiosity.

Featured Post

Guide to Performance: Optimization & Monitoring

Nowadays, monitoring is a mixture of tools, systems, and codes—making it a very complex process. And with this complexity, comes variables for failure. Get DZone’s new Guide to Performance to learn how to proactively find these variables and solve them before a disruption occurs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
E-mail delayed during DNS server reboot 8 67
Forest and doamin tree 3 41
Question about DNS 2 46
Exchange 2016->2010 migration - Autodiscover SCP question. 5 35
This article explains how a domain name may be inadvertently appended to all DNS queries. This exhibits as described below. (CODE)And / Or: (CODE) Cause This issue can occur in either of these two scenarios. EITHER 1. A Primary DNS S…
Resolve DNS query failed errors for Exchange
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question