Solved

Asterisk sound file format error

Posted on 2009-07-05
12
1,080 Views
Last Modified: 2013-11-12
Hello,

  My primary Asterisk server is currently running on Ubuntu, in a 64 bit environment.

I am currently testing Asterisk on a second box, which is loaded with Centos, in a 32 bit environment.

I copied over all of my voice mail files, i.e. unavailable message greetings and the actual voice mail messages themselves, over to the Centos box, so the environment would be duplicated.

For some reason when Asterisk tries to play these files, I get an error in the CLI, and then a busy signal, as it is unable to play the WAV file.  Here is the message in the CLI

[Jul  5 13:56:48] WARNING[24266]: format_wav.c:140 check_header: Not a wav file 49
[Jul  5 13:56:48] WARNING[24266]: file.c:379 fn_wrapper: Unable to open format wav

- Now if I record new messages on the Centos box, it has no problem playing back those native recorded WAV files.

-  Both boxes are running asterisk 1.4.25.1 ..

-  My end goal is to be running Centos 64 bit on the primary server, and Centos 32 bit on the other box, and be able to back up the voicemail files etc, from the primary to the secondary server, and have everything be functional on the secondary as it is on the primary.  So far everything else about Asterisk seems to run fine with the settings from the primary, the only problem being these voicemail WAV files.  

Any ideas why this is happening?
0
Comment
Question by:jkockler
  • 7
  • 5
12 Comments
 
LVL 3

Expert Comment

by:three7six
Comment Utility
When you copied over the wav files did you chown them to the asterisk/asterisk user?  Might be a permission issue.

If that isnt the case,  does the .wav file play OK on a pc?  Maybe its a codec issue?
0
 
LVL 3

Expert Comment

by:three7six
Comment Utility
Also, asterisk (unless its been fixed) behaves funny if the file has a capital extension.  
0
 
LVL 4

Author Comment

by:jkockler
Comment Utility
The files play fine everywhere else.  The file even plays fine on the Linux box that asterisk is running on... weird..I did not chown the file though.
0
 
LVL 3

Expert Comment

by:three7six
Comment Utility
My guess is chowning the file will fix the issue then.
0
 
LVL 4

Author Comment

by:jkockler
Comment Utility
Also I noticed whenever asterisk saves the sound files, it makes 2 copies, one with extension WAV and another one with lowercase wav.... the lowercase is usually larger, but both have the same audio.... not sure why that is.
0
 
LVL 3

Accepted Solution

by:
three7six earned 500 total points
Comment Utility
the .WAV file is wav49 codec.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 4

Author Comment

by:jkockler
Comment Utility
so then it sounds like it is only trying to read the lowercase wav, and skipping the WAV...Why would it do that if both have the same permissions?
0
 
LVL 3

Assisted Solution

by:three7six
three7six earned 500 total points
Comment Utility
I believe the setting is in your voicemail.conf file.   Theres a line for voicemail format and it has two formats by default.  As for the "whys", I am uncertain.
0
 
LVL 3

Expert Comment

by:three7six
Comment Utility
Did you try chowning the files?  The two files is the default nature of asterisk, and I do not believe it to be the problem in this case.
0
 
LVL 4

Author Comment

by:jkockler
Comment Utility
I removed the small wav, and and left the WAV, and that solved the issue.  Let me check the voicemail.conf .. Thanks three7six ....

I have another question open here, if you want to check that one out...

http://www.experts-exchange.com/OS/Linux/Q_24545476.html
0
 
LVL 3

Expert Comment

by:three7six
Comment Utility
OR, the issue could be when the files were copied over they lost the .WAV for wav49 and .wav extensions.  If a standard .wav encoded voicemail file has an extension of .WAV,  asterisk is going to try to play it as a wav49.  If chowning doesnt fix it,  make sure your file extensions are correctly capitalized and not capitalized, depending on the file format.
0
 
LVL 4

Author Comment

by:jkockler
Comment Utility
chown tells me asterisk is an invalid user.... I don;t know but if copying out the wav fixes the issue, that is fine with me.... this is just a backup server anyway...


check out this question if you get a chance.. .thanks

http://www.experts-exchange.com/OS/Linux/Q_24545476.html
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

There are no good configuration guides for HP-H3C router to LYNC on the web. :( Big statement, but we havent been able to find one yet. We did find the following document useful, but the information was not enough to use H3C router for use as a L…
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now