Exchange Server rejecting pictures from an IPhone

We use Exchange 2007 for messaging. One of our administrators has a son with an IPhone. His son sends him pictures that he takes with his phone. His son has a gmail account configured on his IPhone. In the past he has been able to send these pictures and our Exchange server processed them without issue. All of a sudden, within the last couple of weeks he has been getting NDR's stating that the message exceeds the maximum size allowed. Please note: we have already configured the server to have unlimited send and recieve limits. Also the son is not trying to send mutliple pictures, he is only sending one picture at a time. This does not seem like a size limit issue. Below is the NDR message. Let me know if you need more details from NDR. Any help will be appreciated.

Delivery has failed to these recipients or distribution lists:
This message exceeds the maximum message size allowed. Microsoft Exchange will not try to redeliver this message for you. Please make the message smaller -- by removing attachments, for example -- and try sending it again, or provide the following diagnostic text to your system administrator.
Sent by Microsoft Exchange Server 2007

Diagnostic information for administrators:
Generating server: xxxx.local
#554 5.3.4 STOREDRV.Deliver; Content conversion limit(s) exceeded ##

Who is Participating?
Stephen CroftConnect With a Mentor Technical ArchitectCommented:
There are four places where Message size is set in Exchange - in 2003, these were all in the gui, in 2007 three are powershell (although MS are adding them back to the gui in the next SP) and one has no admin tool at all - you get to use LDAP to set it in the "raw" Active Directory. You must however set the parameters in all four places to the same value - the *lowest* of all four is used, as each is applied to the message in turn to decide if it should be rejected.

So, from the top:

Global setting:
   The systemwide default is held in Active Directory and is set to 10MB by default (this is 10240 K, the setting is just a number but is in K)

   Using ADSIedit, navigate to:
CN=Message Delivery,CN=Global Settings,
CN=Assocaited Network Solutions PLC,
CN=Microsoft Exchange,CN=Services,CN=Configuration,

the arguments you want are:
msExchRecipLimit     (default 5000)
submissionContLength (default 10240)
delivContLength      (default 10240)

the latter two are now set to 20480.

Transport Setting
Site Default is set in powershell; use Get-TransportConfig to get current settings, then:

Set-TransportConfig -MaxRecipientEnvelopeLimit <nn> -MaxReceiveSize <nn>MB -MaxSendSize <nn>MB

current setting:

Set-TransportConfig -MaxRecipientEnvelopeLimit 5000 -MaxReceiveSize 20MB -MaxSendSize 20MB

Receive and Send Connectors
Again, we use Powershell. First to list the connectors, you can use the two following commands:


you can get detailed information (including the current settings) by using the Format-List pipe:

Get-ReceiveConnector | Format-List
Get-SendConnector | Format-List

Now, for EACH connector you need to modify, use the following:

Set-ReceiveConnector "<connector name>" -MaxMessageSize <nn>MB
Set-SendConnector "<connector name>" -MaxMessageSize <nn>MB

Does this article assist you:

This mentions pickup directory size limits and other size limits that could be affected.

I know the scenario in that post is slightly different to yours but the NDR displays a similar message.

It could be a limit imposed elsewhere, other than the 'mail content' size limit.

Worth reviewing.

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

AutomatedITAuthor Commented:
Thanks, I will check it out. Another bit of info for you. The IPhone can send to other servers such as yahoo or google email accounts. Also he can send from the IPhone to my yahoo email account and I can forward that exact message with the picture to the exchange server and it handles it just fine. I was thinking it was something with the conversion from the IPhone.
Stephen CroftTechnical ArchitectCommented:
Really sounds like something to do with your Exchange server and the size of email they are sending, check all the locations I posted and take it from there :)
AutomatedITAuthor Commented:
I took a look at the size limits in Exchange. The 3 settings that you can view in Powel Shell were all set to unlimited. All 3 settings in ADSIEdit were set to <not set>. I was not sure if this meant unlimited or not but I changed them to a high value (2097151 KB) and rebooted the server and the pictures came through. Thanks for the help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.