Solved

unable to connect WLST to Node Manager using nmConnect()

Posted on 2009-07-06
4
5,334 Views
Last Modified: 2013-12-10
Hi,

Using nmConnect() command I was trying to connect WLST to Node Manager but unable to do so.

I get the following error if I give the following command

wls:/offline> nmConnect('weblogic', 'weblogic', 'localhost', '5556', 'base_domain', 'C:\bea9\user_projects\domains\base_domain', 'ssl')

Connecting to Node Manager ...
Traceback (innermost last):
File "<input>", line 1, in ?
File "<iostream>", line 1499, in nmConnect
WLSTException: 'Error occured while performing nmConnect : Cannot connect to the
Node Manager.I/O error while reading domain directory: java.io.IOException: C:\
\bea9\\weblogic90\\common\\bin\\\bea9\\user_projects\\domains\base_domain: The f
ilename, directory name, or volume label syntax is incorrect Use dumpStack() to
view the full stacktrace'

I also tried dumpStack(), this is the message I got

wls:/offline> dumpStack()
This Exception occured at Mon Jul 06 02:30:32 GMT 2009
weblogic.nodemanager.NMException: I/O error while reading domain directory: java
.io.IOException: C:\bea9\weblogic90\common\binea9\user_projects\domainase_domain
: The filename, directory name, or volume label syntax is incorrect
at weblogic.nodemanager.client.NMServerClient.checkResponse(NMServerClie
nt.java:239)
at weblogic.nodemanager.client.NMServerClient.connect(NMServerClient.jav
a:197)
at weblogic.nodemanager.client.NMServerClient.checkConnected(NMServerCli
ent.java:151)
at weblogic.nodemanager.client.NMServerClient.getVersion(NMServerClient.
java:41)
at weblogic.management.scripting.NodeManagerService.verifyConnection(Nod
eManagerService.java:183)
at weblogic.management.scripting.NodeManagerService.nmConnect(NodeManage
rService.java:176)
at jrockit.reflect.VirtualNativeMethodInvoker.invoke(Ljava.lang.Object;[
Ljava.lang.Object;)Ljava.lang.Object;(Unknown Source)
at java.lang.reflect.Method.invoke(Ljava.lang.Object;[Ljava.lang.Object;
I)Ljava.lang.Object;(Unknown Source)
at org.python.core.PyReflectedFunction.__call__(PyReflectedFunction.java
:160)
at org.python.core.PyMethod.__call__(PyMethod.java:96)
at org.python.core.PyObject.__call__(PyObject.java:248)
at org.python.core.PyObject.invoke(PyObject.java:2016)
at org.python.pycode._pyx2.nmConnect$93(<iostream>:1487)
at org.python.pycode._pyx2.call_function(ILorg.python.core.PyFrame;)Lorg
.python.core.PyObject;(<iostream>:???)
at org.python.core.PyTableCode.call(PyTableCode.java:208)
at org.python.core.PyTableCode.call(PyTableCode.java:404)
at org.python.core.PyFunction.__call__(PyFunction.java:184)
at org.python.core.PyObject.__call__(PyObject.java:248)
at org.python.pycode._pyx22.f$0(<input>:1)
at org.python.pycode._pyx22.call_function(ILorg.python.core.PyFrame;)Lor
g.python.core.PyObject;(<input>:???)
at org.python.core.PyTableCode.call(PyTableCode.java:208)
at org.python.core.PyCode.call(PyCode.java:14)
at org.python.core.Py.runCode(Py.java:1135)
at org.python.core.Py.exec(Py.java:1157)
at org.python.util.PythonInterpreter.exec(PythonInterpreter.java:148)
at org.python.util.InteractiveInterpreter.runcode(InteractiveInterpreter
.java:89)
at org.python.util.InteractiveInterpreter.runsource(InteractiveInterpret
er.java:70)
at org.python.util.InteractiveInterpreter.runsource(InteractiveInterpret
er.java:40)
at weblogic.management.scripting.WLST.main(WLST.java:130)


Could you guys tell me what could be the error?


Any help is appreciated


Thanks,
Charan
0
Comment
Question by:NikhilKotagiri
  • 2
4 Comments
 
LVL 10

Accepted Solution

by:
rajesh_bala earned 500 total points
ID: 24785524
Try this

 nmConnect('weblogic', 'weblogic', 'localhost', '5556', 'base_domain', 'C:/bea9/user_projects/domains/base_domain', 'ssl')

or

 nmConnect('weblogic', 'weblogic', 'localhost', '5556', 'base_domain', 'C:\\bea9\\user_projects\\domains\\base_domain', 'ssl')

Basically path separator seems to be an issue
0
 

Author Comment

by:NikhilKotagiri
ID: 24790149
nmConnect('weblogic', 'weblogic', 'localhost', '5556', 'base_domain', 'C:\\bea9\\user_projects\\domains\\base_domain', 'ssl')



This worked for me. basically I should enter double backward slashes


Thanks a lot rajesh_bala

Charan
0
 
LVL 10

Expert Comment

by:rajesh_bala
ID: 24790591
You are welcome Charan. :)
0
 

Expert Comment

by:pvasireddy4471
ID: 33291136
How about in unix?. :)
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Upgrading Tomcat – There are a couple of methods to upgrade Tomcat is to use The Apache Installer is to download and unzip and run the services.bat remove|install Tomcat6 Because of the App that we are working with, we can only use Tomcat 6.…
There are numerous questions about how to setup an IBM HTTP Server to be administered from WebSphere Application Server administrative console. I do hope this article will wrap things up and become a reference for this task. You need three things…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question