adding the stsadm command to the path statement so I don't have to navigate to the directory in dos

Super simple but I can't find the solution on line so how do I add the path statement to windows server 2003 so that i can access stsadm from the root of c in Dos . I tried to add it to the path but maybe I am not doing something correct. I just want to be able to open cmd prompt and type stsadm and have it launch and I don't want to see the long path in the prompt either. Please help I know this is simple but I am having a hard time with this.
boogieman01Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sharepointguru14Commented:
right click my computer then properties then the advanced tab then the enviornment variables button at the bottom. Then in the dialog box select path click edit and in the variable box add C:\Program Files\Common Files\Microsoft Shared\web server extensions\12
Then click ok and you will be able to type stsadm at any command prompt
0
boogieman01Author Commented:
That is what I already did and I am not sure why it is not working. I just receive an error stsadm.exe is not recognized as an internal or external command. I edited the path and placed a semi colon after the path statement that was already there. Below is an example

;c:\program files\common files\microsoft shared\webserver extensions\12 then rebooted and still I get that error
0
sharepointguru14Commented:
is that a copy and paste of what you have in your path variable? Cause you don't have a space between web and server you have webserver which will cause an error
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

ou_doberCommented:
Go to a command prompt, copy and paste, and hit enter:

PATH = %PATH%;"C:\Program Files\Common Files\Microsoft Shared\web server extensions\12"

This will append the stsadm directory to to default PATH settings of the OS.  You needs add "  " when adding directories with spaces.


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dp_expertCommented:
It didn't work for me, I still get "stsadm is not recognized..."
0
sharepointguru14Commented:
do you have sharepoint installed on that machine? If you don't have sharepoint and you don't have the path to the 12 hive then this won't work. Can you open windows explorer and actually navigate to the path above and see the stsadm.exe file?
0
boogieman01Author Commented:
It works I I place the command in the dos prompt but I have not tied it in windows so I will try again in windows. Yeah I have Sharepoint on this system
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.