Solved

Can't speak to remote network

Posted on 2009-07-06
8
333 Views
Last Modified: 2012-05-07
I have an internal PIX deployed. The untrusted side is 10.24.1.0/24
The trusted side is 172.16.31.0/24

There is another network on the untrusted side (10.24.2.0/24) which the 172.16.31.0 users need access too. If I ping from the outside interface, there is connectivity. If I ping from the inside interface, there is not connectivity. Logs do not show any ACls denying anything.  From the hosts side, they can ping anything on 10.24.1.0, but not 10.24.2.0

Ideas?

Thanks
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group network untrusted
  network-object 10.24.1.0 255.255.255.0
  network-object 10.24.2.0 255.255.255.0
object-group network from-sl
  network-object 172.16.1.0 255.255.255.0
  network-object 172.16.101.0 255.255.255.0
  network-object 172.16.31.0 255.255.255.0
  network-object 172.16.10.0 255.255.255.0
  network-object 172.16.200.0 255.255.255.0
  network-object 172.16.201.0 255.255.255.0
  network-object 172.16.202.0 255.255.255.0
  network-object 172.16.14.0 255.255.255.0
object-group network to-sl
  network-object 172.16.1.0 255.255.255.0
  network-object 172.16.101.0 255.255.255.0
  network-object 172.16.31.0 255.255.255.0
access-list outside-to-inside permit icmp any any
access-list outside-to-inside permit ip object-group untrusted object-group to-sl
access-list outside-to-inside deny ip any any log
access-list in-to-out permit ip object-group from-sl object-group untrusted
access-list in-to-out deny ip any any log
access-list nonat permit ip object-group from-sl object-group untrusted
pager lines 24
logging on
logging timestamp
logging console critical
logging buffered informational
logging trap emergencies
logging history informational
logging device-id string FWALL
logging host inside 172.16.1.20
mtu scada 1500
mtu inside 1500
ip address scada 10.24.1.2 255.255.255.0
ip address inside 172.16.31.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
nat (inside) 0 access-list nonat
access-group outside-to-inside in interface outside
access-group in-to-out in interface inside
router ospf 1
  network 10.24.1.0 255.255.255.0 area 100
  network 172.16.31.0 255.255.255.0 area 3
  area 3 virtual-link 172.17.1.31
  log-adj-changes
  redistribute static subnets
route inside 0.0.0.0 0.0.0.0 172.16.31.1 1
route outside 10.24.2.0 255.255.255.0 10.24.1.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
snmp-server host inside 172.16.1.20
no snmp-server contact
no snmp-server enable traps
floodguard enable
telnet 172.16.31.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
management-access inside
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
 
terminal width 80
Cryptochecksum:89afc741a574a8d9aa115f5269f77989
: end
fanfwl01#

Open in new window

0
Comment
Question by:WERAracer
  • 4
  • 3
8 Comments
 
LVL 10

Assisted Solution

by:atlas_shuddered
atlas_shuddered earned 100 total points
ID: 24787188
What does a trace look like to the .2 network?  How far is it getting?  From what you have posted, it looks like you are probably getting a nat translation failure to the .2 network.
0
 
LVL 13

Assisted Solution

by:3nerds
3nerds earned 400 total points
ID: 24787274
You probably have a routing problem.

You have a route that states to get to 10.24.2.0/24 go to 10.24.1.1 which I assume is some sort of router. In that router you need a route that states to get to 172.16.31.0/24 go to 10.24.1.2.

You most likely have the DG of the PC's on the 10.24.2.0/24 network to go to the router. But you have the PC's on the 10.24.1.0/24 network pointing to the PIX.

That should fix the problem.

3nerds
0
 
LVL 1

Author Comment

by:WERAracer
ID: 24788204
what about pointing the remote routers to 10.24.1.1
10.24.1.1 has a route in it that says "to get to 172.16.0.0, go to 10.24.1.2"

Wouldn't that make more sense?

thanks
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 13

Assisted Solution

by:3nerds
3nerds earned 400 total points
ID: 24788254
Can't they don't know how to get to it. You can only put the next hop in a routing statement and the next hop would be 10.24.1.2 which is the asa and is directly connected.

Regards,

3nerds
0
 
LVL 1

Author Comment

by:WERAracer
ID: 24788279
well 10.24.1.0 and 10.24.2.0 are connected via Frame Relay. I'm not sure if that matters or not. The intermittent routers between these two sites have a statement that says  172.16.0.0 255.255.0.0  10.24.1.1
0
 
LVL 1

Author Comment

by:WERAracer
ID: 24788288
sorry, I should have stated that 10.24.1.0 and 10.24.2.0 are two separate networks with a 24bit mask!
0
 
LVL 13

Accepted Solution

by:
3nerds earned 400 total points
ID: 24788345
Lots of pieces to this thanks for the additional info.

What you need to do to fix this if for the router at the head of the 10.24.1.0/24 to know how to get to 17.16.31/24 the way to get there is through 10.24.1.2.

This statement "172.16.0.0 255.255.0.0  10.24.1.1" mean that it thinks to get to any class B 172.16 address it needs to go to 10.24.1.1, which is fine as long as 10.24.1.1 points 172.16 to 10.24.1.2.

Good Luck,


3nerds
0
 
LVL 1

Author Comment

by:WERAracer
ID: 24788386
thanks
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Radius ASA Authentication Failed 4 72
Cisco ASA and Watchguard firewall 2 36
Cisco 5508 controller parsing error 4 55
clear arp 1 29
If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

816 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now