Solved

Laptop Keeps Booting From LAN

Posted on 2009-07-06
18
1,184 Views
Last Modified: 2013-11-17
My laptop keeps trying to boot from LAN. I checked in BIOS and LAN boot is 4th after:

Floppy
CD Drive
Hard Drive
LAN

Yet, when I turn it on I get this message:

Intel UNDI, PXE-2.0 (build 082)
Copyright (C) 1997-2000 Intel Corporation

For Realtek RTL8139(X)/8130/810X PCI Fast Ethernet Controller v2.13 (020326)

CLIENT MAC ADDR: 00 16 36 6E 47 15 GUID: 00F8D2CD-4FF4-DA11-8186-0016366E4715
DHCP....

PXE-MOF: Exiting PXE-ROM


After 15 or so tries I can get the computer to finally boot through to Windows XP without showing the above message.

My assumption is that my Hard Drive is failing most of the time. However, I haven't seen any other signs than of that other then the LAN boot. I also ran a disk check from HP which said the Hard Drive is working properly.

I also reformatted the computer and reinstalled the OS. That didn't help.

Is there something I'm missing?
0
Comment
Question by:NovaRising
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
  • +5
18 Comments
 
LVL 2

Expert Comment

by:Archonaus
ID: 24786723
Definitely sounds like something funny is going on with your BIOS.  You might try to find a BIOS update for your laptop which will probably require booting from a floppy and flashing it with a provided utility.  What's the make and model?
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24786755
What happens when you move the HD to the top of the list?

Also, check on Toshiba's web site for a windows BIOS flash and update it.

Also, there may be another setting to boot from PXE in BIOS.  Not necessarily within the boot menu.  You will need to dig around and find it.  Be careful not to change anything you are not sure about.  

More than likely, if you HD is ok, then you should be able to update the BIOS or reset it to defaults and you should be ok.

HTH
0
 
LVL 47

Expert Comment

by:noxcho
ID: 24786810
Why do you enable LAN boot option?
Normally vendors load system images to laptops via PXE (from network storage to local drive) in massive stream. It is called deployment. And your Laptop is not able to boot from network anymore but it is configured to boot first from LAN because it is convenient for vendors.
Make sure you disable LAN boot in BIOS and then press F10 to save the changes. Since then you should not get network boot attempts.
0
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

 
LVL 23

Accepted Solution

by:
ComputerTechie earned 100 total points
ID: 24786857
It almost sound like a harddrive failure. I would try using a software called spinrite. http://www.grc.com/sr/spinrite.htm

CT
0
 
LVL 3

Author Comment

by:NovaRising
ID: 24787531
My Bios is: F.52 (this was updated in 2007 and hasn't caused me problems until now)

The Computer is a Compaq V2000 and is three years old. It was cheap and old enough to die but I have done some minor upgrades to it and it runs well when it makes it past the LAN Boot.

I disabled Floppy & LAN boot (I don't have a floppy drive anyway). I also made sure the F12 key wasn't sticking as that could cause the LAN boot as well.

It seems to have booted fine now the last 5-6 times I tried but it sometimes booted fine before. I'll give it another few hours and try booting several more times.
0
 
LVL 23

Assisted Solution

by:ComputerTechie
ComputerTechie earned 100 total points
ID: 24787610
how about changing the powersupply and harddrive cable they may be going bad.

CT
0
 
LVL 1

Expert Comment

by:a24hrpc
ID: 24788474
At my office they had 90% of the computers set to boot like this on the off chance we want to use a RIS. I finially got them to change the policy.

Any way you just need to change your boot sequence in BIOS. move it down to the bottom. Don't disable it because you can disable your NIC. Flashing your BIOS is great, but again it wont change your computer from trying to boot to your NIC (through your LAN).
0
 
LVL 47

Expert Comment

by:noxcho
ID: 24789178
Turning off in BIOS "Boot on LAN" does not disable NIC card.
0
 
LVL 3

Author Comment

by:NovaRising
ID: 24789340
Alright, it happened to me again. This time I just got a little blinking cursor since LAN boot was turned off.

I tried Flashing the BIOS.

I'll try to get a copy of spinrite to check the hard drive.

I'll also look into replacing or testing cables if they are faulty or swapping drives and testing them that way.
0
 
LVL 1

Expert Comment

by:a24hrpc
ID: 24789411
I'm telling you its your Boot Order in your BIOS. I fix these all day long! Please see my comment above. I promise your wasting your time with this other stuff.
0
 
LVL 1

Expert Comment

by:a24hrpc
ID: 24789453
Whats happening is this:
BIOS tells your computer what to boot to. Normally set to Floppy, CD-ROM, Hard Drive. Someone activated the Boot w/PXE option which puts your NIC as your first boot device. So instead of looking in the normal places it is looking at your internet using DHCP to see if there is anything it can boot to. When it finds nothing, it exits athen goes to the next fevice in your boot order.

Ask any tech that uses a Remote Installation Service (or RIS). THERE IS NOTHING WRONG WITH YOUR COMPUTER. You only need to Access your BIOS, Select Boot Devices, and your BIOS should tell you how to change the order. Usually you press "D" or "+" to move the selected device down.
0
 
LVL 3

Author Comment

by:NovaRising
ID: 24789561
Look at my very fist post a24hrpc.

I already told you LAN is last in my boot order.  I also posted that I completely disabled LAN from the list which led to a blinking line and blank screen.
0
 
LVL 2

Expert Comment

by:SHagel
ID: 24789616
boot with lan and boot w/pxe are 2 different things make sure you have pxe boot disabled not the LAN
0
 
LVL 1

Expert Comment

by:a24hrpc
ID: 24789618
When you disable it your disabling your NIC entirely. Have you tried just Enabling it without PXE? The PXE is what actually makes it boot.

As for being last. Did you make sure it saved? I ask this because I work with it all day and I would not be so confident if I didn't. Spin Rite looks for error on your HD and this is an issue with your BIOS. If disabling just the PXE portion and it is saved then the problem is your BIOS, but in the 3k + computer I support I have never seen this problem come up (Not saying it's not happening to you just trying to point how rare it is). At this point you could flash your BIOS if a newer version is available or reverting it back to an earlier version.
0
 
LVL 3

Author Comment

by:NovaRising
ID: 24790586
1. Changes are saved. I confirmed that the boot order is correct:
  - CD Drive
  - Hard Drive
  - LAN (disabled)

My NIC still works with LAN boot disabled.

2. Where do I turn off PXE? I searched through every BIOS setting and didn't find a setting to turn off a PXE portion. If it was PXE, why does it not boot the same every time? Sometimes it tries to boot from LAN, sometimes it doesn't.

I'm using Phoenix BIOS.

3. As for Hard Drive, I ran a Disk Check Utility in the BIOS and it returned no errors.
0
 
LVL 8

Expert Comment

by:Kavostylin
ID: 24791525
OK OK OK OK.

Your system is attempting to boot from the LAN because it cannot find another boot device.

The problem is your HDD is faulty and without having a bootable CD or a USB floppy drive with bootable system disk inserted the system is going to continue to boot from the PXE ROM which is all there is left to check. The error message you are recieving is the PXE ROM failing to generate a GUID and detect a DHCP server to assign an IP address to which will allow it to boot.

Replace the HDD and reimage the system and you should be good to go again.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 24792100
Is there a key you could call Boot Menu with? Normally there is additional key (one is DEL to enter BIOS) that calls boot menu right after BIOS screen. Depending on vendor of machine the key could be one of these F8-F12.
Please look carefully what it offers and press correct key at very start of machine. Then you will be given choice to boot from CD-ROM, Floppy, USB or HDD manually.
Select HDD and see if it boots. This will give a clue to you and us what is going on with HDD or boot order.
Make sure you do not have USB flash drive connected, the machine could be trying to boot from it too when you disable Boot on LAN.
0
 
LVL 3

Author Comment

by:NovaRising
ID: 24927708
Hard drive power cables were working intermittently. Thanks guys for all the help!


0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Samsung SSD 840 EVO and 840 EVO mSATA have a well-known problem with a drop in read performance. I first learned about this in an interesting thread here at Experts Exchange: http://www.experts-exchange.com/Hardware/Storage/Hard_Drives/Q_2852…
This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question