Solved

Trying to Install BioPerl

Posted on 2009-07-06
3
299 Views
Last Modified: 2013-12-26
Hi Im trying to Install Bioperl from CPAN, but seem to be running into trouble with the install...

I was just wondered if anybody could take a look at the transcript?

Thanks.

Stephen
BioPerl-Install.doc
0
Comment
Question by:StephenMcGowan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 39

Accepted Solution

by:
Adam314 earned 500 total points
ID: 24788245
What version of perl are you using?  Post output from this (notice the capital V):  perl -V

Where did you get the C/CJ/CJFIELDS/BioPerl-1.6.0.tar.gz file?  Is this from CPAN?

Try a manual install:
download BioPerl-1.6.0.tar.gz
unzip: gunzip BioPerl-1.6.0.tar.gz
untar: tar -xvf BioPerl-1.6.0.tar
Change Directory: cd BioPerl-1.6.0
Build Makefile: perl Makefile.PL
compile: make
test: make test
install: make install

You may have to be root user.
0
 

Author Comment

by:StephenMcGowan
ID: 24788760
Hey Adam.. (perl -V is in code snippet)

I've tried re-installing (install C/CJ/CJFIELDS/BioPerl-db-1.6.0.tar.gz), and upon installing have noticed the error:

Checking prerequisites...
 - ERROR: Data::Stag is not installed

so i have then quit out of the install, and entered "install Data::Stag" in>CPAN

but receive the following error messages:

External Module XML::LibXSLT, XSLT,
 is not installed on this computer.
  Data::Stag::XSLTHandler in Data::Stag needs it for XSLT Transformations

External Module XML::Parser::PerlSAX, SAX Handler,
 is not installed on this computer.
  Data::Stag::XMLParser in Data::Stag needs it for parsing XML

External Module GD, Graphical Drawing Toolkit,
 is not installed on this computer.
  stag-drawtree.pl in Data::Stag needs it for drawing trees

External Module Graph::Directed, Generic Graph data stucture and algorithms,
 is not installed on this computer.
  Data::Stag::GraphHandler in Data::Stag needs it for transforming stag trees to graphs

External Module Tk, Tk,
 is not installed on this computer.
  stag-view.pl in Data::Stag needs it for tree viewer

ok so for the C/CJ/CJFIELDS/BioPerl-db-1.6.0.tar.gz install, it's lacking Data::Stag who's install is lacking the list above. How would i go about installing the above list? is there an easier way or something i'm doing wrong?

Thanks,

Stephen
Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
  Platform:
    osname=darwin, osvers=9.0, archname=darwin-thread-multi-2level
    uname='darwin b02.apple.com 9.0 darwin kernel version 9.3.0: tue aug 12 17:18:07 pdt 2008; root:xnu-1228.5.90~13release_i386 i386 '
    config_args='-ds -e -Dprefix=/usr -Dccflags=-g  -pipe  -Dldflags= -Dman3ext=3pm -Duseithreads -Duseshrplib'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=define use5005threads=undef useithreads=define usemultiplicity=define
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-arch ppc -arch i386 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include',
    optimize='-O3',
    cppflags='-no-cpp-precomp -arch ppc -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include'
    ccversion='', gccversion='4.0.1 (Apple Inc. build 5465)', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc -mmacosx-version-min=10.5.7', ldflags ='-arch ppc -arch i386 -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib
    libs=-ldbm -ldl -lm -lutil -lc
    perllibs=-ldl -lm -lutil -lc
    libc=/usr/lib/libc.dylib, so=dylib, useshrplib=true, libperl=libperl.dylib
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' '
    cccdlflags=' ', lddlflags='-arch ppc -arch i386 -bundle -undefined dynamic_lookup -L/usr/local/lib'
 
 
Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_IMPLICIT_CONTEXT
                        PERL_MALLOC_WRAP USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_REENTRANT_API
  Locally applied patches:
	fix for regcomp CVE-2007-5116 security vulnerability
	fix for double-free CVE-2008-1927 security vulnerability
	/Library/Perl/Updates/<version> comes before system perl directories
	installprivlib and installarchlib points to the Updates directory
  Built under darwin
  Compiled at Mar 11 2009 16:09:08
  @INC:
    /Library/Perl/Updates/5.8.8/darwin-thread-multi-2level
    /Library/Perl/Updates/5.8.8
    /System/Library/Perl/5.8.8/darwin-thread-multi-2level
    /System/Library/Perl/5.8.8
    /Library/Perl/5.8.8/darwin-thread-multi-2level
    /Library/Perl/5.8.8
    /Library/Perl
    /Network/Library/Perl/5.8.8/darwin-thread-multi-2level
    /Network/Library/Perl/5.8.8
    /Network/Library/Perl
    /System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level
    /System/Library/Perl/Extras/5.8.8
    /Library/Perl/5.8.6
    /Library/Perl/5.8.1
    .

Open in new window

0
 
LVL 39

Expert Comment

by:Adam314
ID: 24804938
You've accepted an answer, so I'm not sure if you have this solved, or not.  If not, read on...

Normally, to install a module, you use the install command from the CPAN module, as you tried.  This will download and install all prerequisites.  Maybe something is wrong with your CPAN configuration.  Your global configuration is stored in /etc/perl/CPAN, and your user specific config in ~/.cpan.  You can delete these, and you will be asked config questions next time you run CPAN.  Or you can run "o conf init" from the CPAN prompt.

After that, try installing BioPerl from cpan.  As root, run:
    cpan install BioPerl

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, an awarded photographer, Selina De Maeyer (http://www.selinademaeyer.com/), completed a photo shoot of a beautiful event (http://www.sintjacobantwerpen.be/verslag-en-fotoreportage-van-de-sacramentsprocessie-door-antwerpen#thumbnails) in An…
Creating and Managing Databases with phpMyAdmin in cPanel.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Six Sigma Control Plans

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question