Solved

connecting  t1 to cisco mc3810

Posted on 2009-07-06
21
349 Views
Last Modified: 2012-05-07
I am still having problems connecting my t1 line to mc3810 router
here is the config file....I configure the serial 0 interface but i am not connecting any cable to it...i was wondering if there is an option for me to route it to the T1 controller or something? here is the config file please help

Current configuration : 767 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname OMGBTN-RTR
!
!
network-clock base-rate 56k
ip subnet-zero
no ip domain-lookup
!
!
controller T1 0
 framing esf
 linecode b8zs
 loop-detect
!
controller T1 1
 framing sf
linecode ami
!
!
!
interface Ethernet0
 description connection to LAN
 ip address 12.48.121.17 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Serial0
 ip address 12.91.8.78 255.255.255.252
 ip access-group 101 in
 encapsulation ppp
!
interface Serial1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 0.0.0.0 0.0.0.0 12.91.8.77
interface Serial0
 ip address 12.91.8.78 255.255.255.252
 ip access-group 101 in
 encapsulation ppp
!
interface Serial1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 0.0.0.0 0.0.0.0 12.91.8.77
no ip http server
!
!
line con 0
line aux 0
line 2 3
line vty 0 4
 login
!
end
0
Comment
Question by:locster73
  • 12
  • 9
21 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24793301
>I configure the serial 0 interface but i am not connecting any cable to it

If the interface it not connected then it's not going to be functional.

You also need to define your timeslots

controller t1 0
 channel-group 0 timeslots 1-24

And you've got an access-list on serial 0 that doesn't exist.
0
 

Author Comment

by:locster73
ID: 24796108
i get this error message can you help

1w0d: %SYS-5-CONFIG_I: Configured from console by console
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, changed state t
o down
1w0d: %LINK-3-UPDOWN: Interface Serial0:0, changed state to up
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, changed state t
o up
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, changed state t
o down
1w0d: %LINK-3-UPDOWN: Interface Serial0:0, changed state to up
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, changed state t
o up
1w0d: %PQUICC_ETHER-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?
OMGBTN-RTR#
OMGBTN-RTR#
OMGBTN-RTR#
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, changed state t
o down
1w0d: %LINK-3-UPDOWN: Interface Serial0:0, changed state to up
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, changed state t
o up
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24796338
Please post your current config and the output of a "show int s0".
0
 

Author Comment

by:locster73
ID: 24796466
config file

urrent configuration : 867 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname OMGBTN-RTR
!
no logging console
!
network-clock base-rate 56k
ip subnet-zero
no ip domain-lookup
!
!
controller T1 0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
 loop-detect
controller T1 1
 framing sf
 linecode ami
!
!
!
interface Ethernet0
 description connection to LAN
 ip address 12.48.121.17 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 ip address 12.91.8.78 255.255.255.252
 encapsulation ppp
!
interface Serial1
 no ip address
 shutdown
ip address 12.91.8.78 255.255.255.252
 encapsulation ppp
!
interface Serial1
 no ip address
 shutdown
!
interface Serial0:0
 no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 12.91.8.77
no ip http server
!
!
line con 0
line aux 0
line 2 3
line vty 0 4
 login
!
end

show int s0

Serial0 is down, line protocol is down
  Hardware is PQUICC Serial
  Internet address is 12.91.8.78/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, crc 16, loopback not set
  Keepalive set (10 sec)
  Scramble enabled
  LCP Closed
  Closed: IPCP, CDPCP
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 1w0d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 --More--
Closed: IPCP, CDPCP
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 1w0d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
  Cable attached: No cable
  Hardware config: No cable; DTE;  DSR = DOWN   DTR = DOWN   RTS = DOWN   CTS =
DOWN   DCD = DOWN
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24797830
Third to the last line says it all:

"Cable attached: No cable"

You've either got a bad cable, bad circuit or nothing plugged in.
0
 

Author Comment

by:locster73
ID: 24800700
i thought i don't need a cable to the serial 0 port because controller t1 0 is a physical interface that the connection terminates....i don't know where to connect the serial cable to if i need to...please advice
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24801855
The T1 interface is a serial connection. Don't you have a "T1" port on the router?
0
 

Author Comment

by:locster73
ID: 24802912
i connect the cable from the t1 box to the t1 port.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24803150
Do the LED's for the T-1 port indicate any faults?
0
 

Author Comment

by:locster73
ID: 24803161
the led for the t1 is sold green....
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 50

Expert Comment

by:Don Johnston
ID: 24803186
Please post the output of a "show ip int brief".
0
 

Author Comment

by:locster73
ID: 24803214
the router is at my work...i will post when i get there..thanks
0
 

Author Comment

by:locster73
ID: 24806113
show ip int brief

Interface                  IP-Address      OK? Method Status                Prot
ocol
Ethernet0                  12.48.121.17    YES NVRAM  up                    up

Serial0                    12.91.8.78      YES NVRAM  down                  down

Serial1                    unassigned      YES NVRAM  administratively down down

Serial0:0                  unassigned      YES manual administratively down down

please advice......
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24806221
I'm assuming that 12.91.8.78 is the address you want for the T1?

If so, here's what you need to do:


int s0 

 no ip address

int s0:0

 ip address 12.91.8.78 255.255.255.252

 encap ppp

 no shut

Open in new window

0
 

Author Comment

by:locster73
ID: 24809557
the router seems to be working fine..the thing now is i can't get on the internet yet....sorry if i miss anything...do i need to connect it to a switch?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24809822
Is the serial 0:0 interface up/up?

Can you ping 12.91.8.77?

0
 

Author Comment

by:locster73
ID: 24809859
yes
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 500 total points
ID: 24809956
Well, 12.91.8.77 is the internet. Do you have a default route (show ip route)?
0
 

Accepted Solution

by:
locster73 earned 0 total points
ID: 24816768
sorry i can not ping 12.91.8.77

here is the result for show ip route

OMGBTN-RTR#ping 12.91.8.77

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.91.8.77, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
OMGBTN-RTR#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     12.0.0.0/29 is subnetted, 1 subnets
C       12.48.121.16 is directly connected, Ethernet0
0
 

Author Comment

by:locster73
ID: 24816911
sorry here is the result of the show ip route again....

MGBTN-RTR#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     12.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C       12.91.8.77/32 is directly connected, Serial0:0
C       12.91.8.76/30 is directly connected, Serial0:0
C       12.48.121.16/29 is directly connected, Ethernet0
S*   0.0.0.0/0 is directly connected, Serial0:0
               [1/0] via 12.91.8.77
OMGBTN-RTR#
0
 

Author Comment

by:locster73
ID: 24818083
I think i got it now...thanks for all the help ....couldn't of done it without you...
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now