Cannot stop activex controls warning on company website

 Good afternoon everyone,

        My company website www.securitysolutions-usa.com works great with the exception of one link. When you go to the partners tab of the website located at the top everyone begins to receive "To help protect your security, Internet Explorer has restricted this webpage from running scripts or ActiveX controls that could access your computer". Then unless you open a new browser or tab and go back the other pages begin showing the same active x warning. This is annoying a lot of people and im not sure how to clear this hurdle. We outsourced the design of the website and when i contacted the developers they told me that it had something to do with the security certificate. I have updated the security certificate as of Monday last week and the problem still persists. Does anyone have any suggestions what I can do to get rid of this pesky warning?

       Thank you,

 -Casper
casper114Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AnobeCommented:
Its the browser settings at the client end. The web page should be having some custom (third party)  controls that reqires some script to run on the client end. On the browser (Internet Explorer) select the 'Seciroty' tab, select Internet and click on 'Custom Level' button. On the pop up window, go to ActiveX controls and Plug-ins section and enable every option. Select Ok and close the IE. Open a new IE browser and try browsing the web site.
0
Saqib KhanSenior DeveloperCommented:
Go through your partners page and remove or update all the HTTP pages to HTTP(s). For example I found "http://www.seedtechnologies.com" on your partners page. if you are on HTTPS channel its a requirement to have all HTTPS references on your page.
0
Shalom CarmelCTOCommented:
adilkhan,
you are wrong about the SSL :) there is no such requirement..

casper,
your outsourced developers don't know sh*t.
the problem is with the content management system used for your web site.
it uses the old, unsafe DOMDocument ActiveX object.
It should use MSXML 6.0 which is marked safe for IE7.

Technically speaking, your web site looks like someone whipped out Visual Studio and decided to give every feature a try :P
0
casper114Author Commented:
Is there a way that I can change it to use MSXML 6.0?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.